PAT 甲级 1003. Emergency (25)

1003. Emergency (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output

2 4题意:寻找两点最短路的数量以及所有最短路中的权重和的最大值。思路:dfs深搜。
#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<algorithm>
#include<set>
#include<queue>
#include<cmath>
#include<vector>
#include<bitset>
#include<string>
#include<queue>
#include<cstring>
#include<cstdio>
#include <climits>
using namespace std;
#define INF 0x3f3f3f3f
const int N_MAX = 500+5;
int N, M, from, to;
int dis[N_MAX][N_MAX];
bool vis[N_MAX];
int num[N_MAX];
int Distance;//记录最短距离
int cnt;//记录最短路的条数
int max_amou;
void init() {
    for (int i = 0; i < N; i++) {
        for (int j = 0; j < N;j++) {
            dis[i][j] = INT_MAX;
        }
    }
}

void dfs(int cur,const int end,int dist,int amou) {//amou是团队数,dist是源点当前点的距离
    if (cur == end) {//当前如果走到了终点
        if (Distance > dist) {//找到了更短的路
            cnt= 1;
            Distance = dist;
            max_amou = amou;
        }
        else if (Distance==dist) {
            cnt++;
            if(amou>max_amou)
            max_amou = amou;
        }
        return;
    }
    if (dist > Distance)return;//如果距离已经超过了最小距离不用继续搜索

    for (int i = 0; i < N;i++) {
        if (!vis[i]&&dis[cur][i]!=INT_MAX) {
            vis[i] = true;
            dfs(i,end,dist+dis[cur][i],amou+num[i]);
            vis[i] = false;
        }
    }
}

int main() {
       scanf("%d%d%d%d", &N, &M, &from, &to);
        memset(num, 0, sizeof(num));
        memset(vis, 0, sizeof(vis));
        init();
        Distance = INT_MAX;
        cnt = 0;
        for (int i = 0; i < N; i++) {
            scanf("%d",&num[i]);
        }
        for (int i = 0; i < M;i++) {
            int a, b, c;
            scanf("%d%d%d", &a, &b, &c);
            if (c < dis[a][b]) {
                dis[a][b] = c;
                dis[b][a] = dis[a][b];
            }
        }
        dfs(from, to, 0, num[from]);
        printf("%d %d\n",cnt,max_amou);

    return 0;
}
				
时间: 2024-10-13 00:35:46

PAT 甲级 1003. Emergency (25)的相关文章

PAT 甲级 1003 Emergency

1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 #include <cstdlib> 5 #include <algorithm> 6 7 using namespace std; 8 typedef long long ll; 9 const int inf=0x3f3f3f3f; 10 const int o=505; 11 bool vis[o]; 12 in

PAT:1003. Emergency (25) AC

#include<stdio.h> #include<string.h> #include<algorithm> using namespace std; const int MAXV=510; const int INF=0x3fffffff; int n,m,c1,c2; bool vis[MAXV]; int G[MAXV][MAXV]; //城市间距离 int weight[MAXV]; //每个城市的救援人数 int d[MAXV]; //最短距离 int w

【PAT甲级】1003 Emergency (25分)

1003 Emergency (25分) As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between an

1003. Emergency (25)——PAT (Advanced Level) Practise

题目信息: 1003. Emergency (25) 时间限制 400 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads.

PAT 1003. Emergency (25)

1003. Emergency (25) As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between an

PAT 1003 Emergency (25)(25 分)

1003 Emergency (25)(25 分) As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road betwe

甲级1003 Emergency

1003 Emergency (25 分) As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between a

PAT (Advanced Level) 1003. Emergency (25)

最短路+dfs 先找出可能在最短路上的边,这些边会构成一个DAG,然后在这个DAG上dfs一次就可以得到两个答案了. 也可以对DAG进行拓扑排序,然后DP求解. #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> #include<queue> #include<vector> using nam

1003. Emergency (25)

时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in e