HDUJ 3177 Crixalis's Equipment 贪心

Crixalis‘s Equipment

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2568    Accepted Submission(s): 1059

Problem Description

Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he‘s a guardian of Lich King now, he keeps the living habit of a scorpion
like living underground and digging holes.

Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it‘s just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis
has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely
Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.

Input

The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next
N lines contain N pairs of integers: Ai and Bi.

0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.

Output

For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".

Sample Input

2

20 3
10 20
3 10
1 7

10 2
1 10
2 11

Sample Output

Yes
No

分析:

该题讲的是搬家问题,搬运东西需要占多大空间还有搬运时要求的空间。该题的贪心原则则是尽可能的装入东西,即

           停放体积 移动体积

第一件物品   a1   b1

第二件物品   a2   b2

假设这两件物品的移动体积都不大于洞的体积V

那么将单独比较两个物品的时候会发现 a1+b2为先放第一件物品 后放第二件物品的最大瞬时体积

a2+b1为先放第二件物品 后放第一件物品的最大瞬时体积

我们应该选择a1+b2和a2+b1中比较小的先放那么从2件物品 扩展到N件物品

假设n件物品的移动体积都不大于洞的体积V(如果有大于的 那么结果必然是NO)

将N件物品按照b1-a1>b2-a2进行排序 然后依次放入洞中,即按照差值从大到小放入洞中

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

struct node
{
	int a,b,c;
}s[1005];

int cmp(node x,node y)
{
	return x.c>y.c;
}

int main()
{
	int T;
	cin>>T;
	while(T--)
	{
		int n,m;
		cin>>n>>m;
		int i,flag=0;;
		for(i=0;i<m;i++)
		{
			cin>>s[i].a>>s[i].b;
			s[i].c=s[i].b-s[i].a;
		}

		sort(s,s+m,cmp);
		for(i=0;i<m;i++)
		{
			if(n>=s[i].b)   n-=s[i].a;
			else
			{
				flag=1;
				break;
			}
		}

		if(flag)
			cout<<"No\n";
		else
			cout<<"Yes\n";
	}

	return 0;
}

HDUJ 3177 Crixalis's Equipment 贪心

时间: 2024-08-05 00:44:40

HDUJ 3177 Crixalis's Equipment 贪心的相关文章

hdu 3177 Crixalis&#39;s Equipment(贪心)

Problem Description Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he's a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes. Someday Crixalis decides

hdoj 3177 Crixalis&#39;s Equipment 【贪心】

Crixalis's Equipment Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3073    Accepted Submission(s): 1250 Problem Description Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts

[HDU] 3177.Crixalis&#39;s Equipment (贪心)

Problem Description 题目大意: 有V的空间以及N个物品,对于放入每个物品有Ai(放入物品后剩余空间的减少大小),Bi(放入该物品之前需要的最小剩下空间大小,如果大于当前剩余空间大小则无法放入) Input T组数据,每组数据有N+1行,每组数据第一行输入V,N,之后的N行每行描述一个物品的Ai,Bi 0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000. Output

Hdu 3177 Crixalis&#39;s Equipment

Crixalis's Equipment Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2795    Accepted Submission(s): 1141 Problem Description Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts

杭电 3177 Crixalis&#39;s Equipment

http://acm.hdu.edu.cn/showproblem.php?pid=3177 Crixalis's Equipment Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2562    Accepted Submission(s): 1056 Problem Description Crixalis - Sand King

HDU Crixalis&#39;s Equipment(贪心)

贪心策略: 数据(v1, v2),按 v2 - v1 的差值从大到小进行排序 分析: 例(1): v = 10 2件物品:a(2, 5) b(6, 8) -----如果先进a,再进b: 进a:v = 10 --> v >= 5 (成立) --> v -= 2 --> v = 8 进b:v = 8 --> v >= 8 (成立) --> v -= 6 --> v = 2 物品全部进入 输出Yes -----如果先进b,再进a: 进b:v = 10 -->

hdu 3177 Crixalis&amp;#39;s Equipment

Crixalis's Equipment Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2562    Accepted Submission(s): 1056 Problem Description Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts

ZCMU Problem H: Crixalis&#39;s Equipment(贪心,排序)

#include<stdio.h> #include<stdlib.h> struct node { int a,b; }c[1002]; int cmpxy(const struct node *c,const struct node *d) { return (d->b - d->a) - (c->b - c->a); } int main() { int n,i,v,t,flag; // freopen("a.txt","

hdu acm-step 1.3.8 Crixalis&#39;s Equipment

本题题意:蝎子王搬家,洞的空间是V,共有N件物品要搬,每件物品在搬运过程中要占用Bi空间,搬运完后占用Ai,问蝎子王能否搬完所有的物品. 代码如下: #include <cstdio> #include <algorithm> using namespace std; struct Node { int A,B; bool operator < (const Node &node){if(B-A>node.B-node.A)return true;else if