HDU 1398 Square Coins(母函数或DP)

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12929    Accepted Submission(s): 8885

Problem Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.

Sample Input

2
10
30
0

Sample Output

1
4
27

Source

Asia 1999, Kyoto (Japan)

Recommend

Ignatius.L   |   We have carefully selected several similar problems for you:  1171 1085 2152 2082 1709

母函数代码:

#include<iostream>
using namespace std;
#define M 1000
#define MAXN 310      //MAXN为最大有多少项相乘
int a[M],b[M];//a[M]中存最终项系数;b[M]中存取中间变量;
int main()
{
    int m,n;
    int i,j,k;
    m=MAXN;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)break;
        //可以加一个跳出循环的条件
        //n为所求的指数的值: ";
        //因为只求指数为n的系数的值:所以循环只到n就结束
        for(i=0;i<=n;i++)//初始化第一个式子:(1+X^2+X^3+...) 所以将其系数分别存到a[n]
        {
            a[i]=1;
            b[i]=0;
        }
        for(i=2;i<=17;i++)//从第2项式子一直到第n项式子与原来累乘项的和继续相乘
        {
            for(j=0;j<=n;j++)//从所累乘得到的式子中指数为0遍历到指数为n 分别与第i个多项式的每一项相乘
                 for(k=0;k+j<=n;k+=i*i)//第i个多项式的指数从0开始,后面的每项指数依次比前面的多i,比如当i=3时,第3项的表达式为(1+x^3+x^6+x^9+……),直到所得指数的值i+j>=n退出
                 {
                     b[j+k]+=a[j];//比如前面指数为1,系数为3,即a[1]=3 的一项和下一个表达式的指数为k=3的相乘,则得到的式子的系数为,b[j+k]=b[4]+=a[1],又a[1]=3,所以指数为4的系数为b[4]=3;
                 }

             for(j=0;j<=n;j++)//  然后将中间变量b数组中的值依次赋给数组a,然后将数组b清零,继续接收乘以下一个表达式所得的值
              {
                  a[j]=b[j];
                  b[j]=0;
              }
        }
        printf("%d\n",a[n]);  // 指数为n的项的系数为:
    }

    return 0;
}

DP代码:

#include<iostream>
using namespace std;
#define M 1000
int dp[300]={1};
int main()
{
    int n;
     for(int i=1;i<=17;i++)
        for(int j=i*i;j<=300;j++)
          dp[j]+=dp[j-i*i];
        while(scanf("%d",&n)!=EOF)
        {
          if(n==0)break;
           printf("%d\n",dp[n]);
        }
    return 0;
}
时间: 2024-09-28 17:14:28

HDU 1398 Square Coins(母函数或DP)的相关文章

hdu 1398 Square Coins(母函数)

#include <stdio.h> #include <string.h> #include <iostream> #include <algorithm> #include <vector> #include <queue> #include <set> #include <map> #include <string> #include <math.h> #include <s

hdu 1398 Square Coins(母函数|完全背包)

http://acm.hdu.edu.cn/showproblem.php?pid=1398 题意:有价值为1^2,2^2....7^2的硬币共17种,每种硬币都有无限个.问用这些硬币能够组成价值为n的钱数共有几种方案数. 母函数: #include <stdio.h> #include <iostream> #include <map> #include <set> #include <stack> #include <vector>

hdu 1398 Square Coins(母函数,完全背包)

链接:hdu 1398 题意:有17种货币,面额分别为i*i(1<=i<=17),都为无限张, 给定一个值n(n<=300),求用上述货币能使价值总和为n的方案数 分析:这题可以用母函数的思想,对300以内的值进行预处理即可 也可用完全背包思想求300以内的方案数 母函数: #include<stdio.h> int main() { int c1[305],c2[305],i,j,k,n; for(i=0;i<=300;i++){ c1[i]=1; c2[i]=0;

HDU 1398 Square Coins(DP)

Square Coins Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 8800    Accepted Submission(s): 5991 Problem Description People in Silverland use square coins. Not only they have square shapes but

HDU 1398 Square Coins (母函数-整数拆分变形)

Square Coins Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7612    Accepted Submission(s): 5156 Problem Description People in Silverland use square coins. Not only they have square shapes but

(平方幂母函数)hdu 1398 Square Coins

Square Coins Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8891    Accepted Submission(s): 6067 Problem Description People in Silverland use square coins. Not only they have square shapes but

hdu 1398 Square Coins(生成函数,完全背包)

pid=1398">链接:hdu 1398 题意:有17种货币,面额分别为i*i(1<=i<=17),都为无限张. 给定一个值n(n<=300),求用上述货币能使价值总和为n的方案数 分析:这题能够用母函数的思想,对300以内的值进行预处理就可以 也可用全然背包思想求300以内的方案数 母函数: #include<stdio.h> int main() { int c1[305],c2[305],i,j,k,n; for(i=0;i<=300;i++){

杭电ACM hdu 1398 Square Coins

Problem Description People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ...

HDU 1398 Square Coins 平方硬币 (普通母函数,水)

题意:有17种硬币,每种的面值为编号的平方,比如 1,4,9,16.....给出一个数字,求组成这个面值有多少种组法? 思路:用普通母函数解,主要做的就是模拟乘法,因为硬币是无限的,所以每个构造式中每一个项的系数都是1.我们只需要第n项的系数,大于n的并不需要,所以大于n的项就不用再做计算了. 1 #include <bits/stdc++.h> 2 using namespace std; 3 const int N=310; 4 int main() 5 { 6 freopen("