hdu3371 Connect the Cities (MST)

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 13722    Accepted Submission(s): 3711

Problem Description

In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t
want to take too much money.

Input

The first line contains the number of test cases.

Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected
cities.

To make it easy, the cities are signed from 1 to n.

Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.

Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.

Output

For each case, output the least money you need to take, if it’s impossible, just output -1.

Sample Input

1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6

Sample Output

1

Author

dandelion

Source

HDOJ Monthly Contest – 2010.04.04

Recommend

lcy   |   We have carefully selected several similar problems for you:  1102 1301 1162 1198 1598

Statistic | Submit | Discuss | Note

难理解的就是最后那k行。開始的数字t表示有几个城市。然后输入t个城市,表示第一个城市和第二个连接,第二个和第三个连接。

。。

用kruskal算法超时的多提交两次。

。当然也能够用pri算法。。

不想写。。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct node
{
	int a,b,cost;
}c[30000];
int fa[505];
void init(int n)
{
	for(int i=1;i<=n;i++)
	fa[i]=i;
}
bool cmp(node x,node y)
{
	return x.cost<y.cost;
}
int find(int x)
{
	if(fa[x]!=x) fa[x]=find(fa[x]);
	return fa[x];
}
int main()
{
	int n,k,m,ncase;
	scanf("%d",&ncase);
	while(ncase--)
	{
		scanf("%d %d %d",&n,&k,&m);
		init(n);
		for(int i=0;i<k;i++)
		scanf("%d %d %d",&c[i].a,&c[i].b,&c[i].cost);
		for(int i=1;i<=m;i++)
		{
			int x,pos,pos1;
			scanf("%d %d",&x,&pos);
			for(int j=1;j<x;j++)
			{
				scanf("%d",&pos1);
				c[k].a=pos,c[k].b=pos1,c[k].cost=0;
				pos=pos1;
				k++;
			}
		}
		sort(c,c+k,cmp);
		int sum=0;
		for(int i=0;i<k;i++)
		{
			int x=find(c[i].a);
			int y=find(c[i].b);
			if(x!=y)
			sum+=c[i].cost,fa[x]=y;
		}
		int count=0;
		for(int i=1;i<=n;i++)
		if(fa[i]==i)
		count++;
		if(count!=1)
		printf("-1\n");
		else
		printf("%d\n",sum);
	}
	return 0;
}
时间: 2024-10-26 12:30:22

hdu3371 Connect the Cities (MST)的相关文章

HDU3371 Connect the Cities 【最小生成树Kruskal】

Connect the Cities Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 9856    Accepted Submission(s): 2800 Problem Description In 2100, since the sea level rise, most of the cities disappear. Thou

HDU3371 Connect the Cities【Kruskal】

Connect the Cities Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 11152    Accepted Submission(s): 3155 Problem Description In 2100, since the sea level rise, most of the cities disappear. Tho

Connect the Cities(MST prim)

Connect the Cities Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 3371 Description In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connect

HDU3371 Connect the Cities

题目描述: 有n个小岛,其中有的小岛之间没有通路,要修这样一条通路需要花费一定的钱,还有一些小岛之间是有通路的.现在想把所有的岛都连通起来,求最少的花费是多少. 输入: 第一行输入T,代表多少组数据. 第二行输入三个整数n , m , k,分别代表一共有n个小岛,m条路径可供选择,k表示有连通岛的个数. 接下来的m行,每行三个整数p , q , c ,代表建设p到q的通路需要花费的钱为c. 接下的k行,每一行的数据输入如下:先输入Q,代表这个连通分量里面有Q个小岛,然后输入Q个小岛,代表这Q个小

【HDU3371】Connect the Cities(MST基础题)

注意输入的数据分别是做什么的就好.还有,以下代码用C++交可以过,而且是500+ms,但是用g++就会TLE,很奇怪. 1 #include <iostream> 2 #include <cstring> 3 #include <cstdio> 4 #include <cstdlib> 5 #include <cmath> 6 #include <cctype> 7 #include <algorithm> 8 #incl

【HDU3371】Connect the Cities

Connect the Cities Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 12861    Accepted Submission(s): 3543 Problem Description In 2100, since the sea level rise, most of the cities disappear. Tho

hdu oj 3371 Connect the Cities (最小生成树)

Connect the Cities Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 9985    Accepted Submission(s): 2843 Problem Description In 2100, since the sea level rise, most of the cities disappear. Thou

HDU 3371 kruscal/prim求最小生成树 Connect the Cities 大坑大坑

这个时间短 700多s #include<stdio.h> #include<string.h> #include<iostream> #include<algorithm> using namespace std; struct node{ int u; int v; int w; }que[100000]; int father[505]; bool cmp(struct node a,struct node b){ return a.w<b.w;

hdu 3371 Connect the Cities

链接:hdu 3371 已知已连通的路的序号,以及未连通的路的费用,求将所有城市连通的最小费用 也是将已连通的路的费用记为0,就转化成了基本最小生成树的题 不过这题数组要开的大点,不然很容易就RE了... #include<cstdio> #include<algorithm> using namespace std; int f[510],n,m; struct stu { int a,b,c; }t[100000]; int cmp(struct stu x,struct st