POJ 题目3321 Apple Tree(线段树)

Apple Tree

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 21566   Accepted: 6548

Description

There is an apple tree outside of kaka‘s house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 toN and the root is always numbered by 1. Apples will grow on the forks and two apple won‘t grow on the same fork. kaka wants to know how many apples are
there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.

The following N - 1 lines each contain two integers u and v, which means forku and fork
v are connected by a branch.

The next line contains an integer M (M ≤ 100,000).

The following M lines each contain a message which is either

"C x" which means the existence of the apple on fork
x
has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.

or

"Q x" which means an inquiry for the number of apples in the sub-tree above the forkx, including the apple (if exists) on the fork x

Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

Source

POJ Monthly--2007.08.05, Huang, Jinsong

题目大意给你一棵树,每一个节点開始的时候有一个苹果,下边m个操作,Q a,查询以a和a的子树的总共的苹果数,c b。改动操作,改变b节点,,開始在有变没有,没有变成有

ac代码

#include<stdio.h>
#include<string.h>
struct node
{
	int u,v,next;
}edge[100010<<1];
int head[100010],cnt,num[100010],son[100010],cc,vis[100100];
void add(int u,int v)
{
	edge[cnt].u=u;
	edge[cnt].v=v;
	edge[cnt].next=head[u];
	head[u]=cnt++;
}
void dfs(int u)
{
	num[u]=++cc;
	//son[u]=1;
	vis[u]=1;
	for(int i=head[u];i!=-1;i=edge[i].next)
	{
		int v=edge[i].v;
		if(!vis[v])
			dfs(v);
	//	son[u]+=son[v];
	}
	son[u]=cc;
}
struct s
{
	int sum,cover;
}node[100010<<2];
void pushdown(int tr,int m)
{
	if(node[tr].cover)
	{
		node[tr<<1].cover=node[tr<<1|1].cover=1;
		node[tr<<1].sum=m-(m>>1);
		node[tr<<1|1].sum=(m>>1);
		node[tr].cover=0;
	}
}
void build(int l,int r,int tr)
{
	node[tr].cover=1;
	node[tr].sum=r-l+1;
	if(l==r)
	{
		return;
	}
	int mid=(l+r)>>1;
	build(l,mid,tr<<1);
	build(mid+1,r,tr<<1|1);
}
void update(int pos,int l,int r,int tr)
{
	if(l==pos&&r==pos)
	{
		if(node[tr].cover)
		{
			node[tr].cover=0;
			node[tr].sum=0;
		}
		else
		{
			node[tr].cover=1;
			node[tr].sum=1;
		}
		return;
	}
	pushdown(tr,r-l+1);
	int mid=(l+r)>>1;
	if(pos<=mid)
		update(pos,l,mid,tr<<1);
	else
		update(pos,mid+1,r,tr<<1|1);
	node[tr].sum=node[tr<<1].sum+node[tr<<1|1].sum;
	if(node[tr<<1].cover&&node[tr<<1|1].cover)
	{
		node[tr].cover=1;
	}
}
int query(int L,int R,int l,int r,int tr)
{
	if(L<=l&&R>=r)
	{
		return node[tr].sum;
	}
	int mid=(l+r)>>1;
	pushdown(tr,r-l+1);
	int ans=0;
	if(L<=mid)
		ans+=query(L,R,l,mid,tr<<1);
	if(R>mid)
		ans+=query(L,R,mid+1,r,tr<<1|1);
	return ans;
	/*if(R<=mid)
		return query(L,R,l,mid,tr<<1);
	else
		if(L>mid)
			return query(L,R,mid+1,r,tr<<1|1);
		else
			return query(L,mid,l,mid,tr<<1)+query(mid+1,R,mid+1,r,tr<<1|1);*/
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		cnt=0;
		cc=0;
		memset(head,-1,sizeof(head));
		memset(vis,0,sizeof(vis));
		int i;
		for(i=0;i<n-1;i++)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			add(a,b);
		}
		dfs(1);
		int m;
		scanf("%d",&m);
		build(1,n,1);
		while(m--)
		{
			char s[2];
			scanf("%s",s);
			if(s[0]=='Q')
			{
				int a;
				scanf("%d",&a);
				int ans=query(num[a],son[a],1,n,1);
				printf("%d\n",ans);
			}
			else
			{
				int a;
				scanf("%d",&a);
				update(num[a],1,n,1);
			}
		}
	}
}
时间: 2024-08-11 13:53:07

POJ 题目3321 Apple Tree(线段树)的相关文章

POJ - 3321 Apple Tree (线段树 + 建树 + 思维转换)

POJ - 3321 Apple Tree Time Limit: 2000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u Submit Status Description There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very muc

poj 3321:Apple Tree(树状数组,提高题)

Apple Tree Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 18623   Accepted: 5629 Description There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been

【POJ 2486】 Apple Tree(树型dp)

[POJ 2486] Apple Tree(树型dp) Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 8981   Accepted: 2990 Description Wshxzt is a lovely girl. She likes apple very much. One day HX takes her to an apple tree. There are N nodes in the tree. Each

POJ 3321 Apple Tree 【树状数组+建树】

题目链接:http://poj.org/problem?id=3321 Apple Tree Time Limit: 2000MS Memory Limit: 65536K Total Submissions: 34812 Accepted: 10469 Description There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka like

(简单) POJ 3321 Apple Tree,树链剖分+树状数组。

Description There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree. The tree has N forks which are connected by branches.

POJ 3321—— Apple Tree(树状数组)

Apple Tree Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 19160   Accepted: 5831 Description There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been

poj 3321 Apple Tree(树状数组)

辉煌北大的月赛题质量真高啊,这种树状数组真难想到. 树状数组的基本用法是区间,单点的应用,起初这个怎么都想不到如何套用到树状数组. 转化方法是 将树上的节点信息查询,转为深度优先中节点顺序(代表结点编号).进结点与出结点分别代表该结点管辖范围. 题目大意级是说,给你一颗树,最初每个节点上都有一个苹果,有两种操作:修改(即修改某一个节点,修改时这一个节点苹果从有到无,或从无到有)和查询(查询某一个节点他的子树上有多少个苹果). 由于此题数据比较大(N<=10^5),而且不是标准的二叉树,所以这里我

POJ 题目3667 Hotel(线段树,区间更新查询,求连续区间)

Hotel Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 13805   Accepted: 5996 Description The cows are journeying north to Thunder Bay in Canada to gain cultural enrichment and enjoy a vacation on the sunny shores of Lake Superior. Bessie

POJ 3321 Apple Tree (dfs+线段树)

题目大意: 修改树上的节点,然后求子树的和. 思路分析: dfs 重新编号,烂大街了... #include <cstdio> #include <iostream> #include <cstring> #include <algorithm> #define maxn 100005 #define lson num<<1,s,mid #define rson num<<1|1,mid+1,e using namespace std