POJ2029——Get Many Persimmon Trees

Get Many Persimmon Trees

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 3656   Accepted: 2378

Description

Seiji Hayashi had been a professor of the Nisshinkan Samurai School in the domain of Aizu for a long time in the 18th century. In order to reward him for his meritorious career in education, Katanobu Matsudaira, the lord of the
domain of Aizu, had decided to grant him a rectangular estate within a large field in the Aizu Basin. Although the size (width and height) of the estate was strictly specified by the lord, he was allowed to choose any location for the estate in the field.
Inside the field which had also a rectangular shape, many Japanese persimmon trees, whose fruit was one of the famous products of the Aizu region known as ‘Mishirazu Persimmon‘, were planted. Since persimmon was Hayashi‘s favorite fruit, he wanted to have
as many persimmon trees as possible in the estate given by the lord.

For example, in Figure 1, the entire field is a rectangular grid whose width and height are 10 and 8 respectively. Each asterisk (*) represents a place of a persimmon tree. If the specified width and height of the estate are 4 and 3 respectively, the area surrounded
by the solid line contains the most persimmon trees. Similarly, if the estate‘s width is 6 and its height is 4, the area surrounded by the dashed line has the most, and if the estate‘s width and height are 3 and 4 respectively, the area surrounded by the dotted
line contains the most persimmon trees. Note that the width and height cannot be swapped; the sizes 4 by 3 and 3 by 4 are different, as shown in Figure 1.

Figure 1: Examples of Rectangular Estates

Your task is to find the estate of a given size (width and height) that contains the largest number of persimmon trees.

Input

The input consists of multiple data sets. Each data set is given in the following format.

N

W H

x1 y1

x2 y2

...

xN yN

S T

N is the number of persimmon trees, which is a positive integer less than 500. W and H are the width and the height of the entire field respectively. You can assume that both W and H are positive integers whose values are less than 100. For each i (1 <= i <=
N), xi and yi are coordinates of the i-th persimmon tree in the grid. Note that the origin of each coordinate is 1. You can assume that 1 <= xi <= W and 1 <= yi <= H, and no two trees have the same positions. But you should not assume that the persimmon trees
are sorted in some order according to their positions. Lastly, S and T are positive integers of the width and height respectively of the estate given by the lord. You can also assume that 1 <= S <= W and 1 <= T <= H.

The end of the input is indicated by a line that solely contains a zero.

Output

For each data set, you are requested to print one line containing the maximum possible number of persimmon trees that can be included in an estate of the given size.

Sample Input

16
10 8
2 2
2 5
2 7
3 3
3 8
4 2
4 5
4 8
6 4
6 7
7 5
7 8
8 1
8 4
9 6
10 3
4 3
8
6 4
1 2
2 1
2 4
3 4
4 2
5 3
6 1
6 2
3 2
0

Sample Output

4
3

Source

Japan 2003 Domestic

二维树状数组+枚举终点即可,因为数据范围不大

#include <map>
#include <set>
#include <list>
#include <stack>
#include <vector>
#include <queue>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>  

using namespace std;

int c[222][222];

int w, h;
int n;

int lowbit(int x)
{
	return x & (-x);
}

void add(int x, int y)
{
	for (int i = x; i <= w; i += lowbit(i))
	{
		for (int j = y; j <= h; j += lowbit(j))
		{
			c[i][j]++;
		}
	}
}

int sum(int x, int y)
{
	int ans = 0;
	for (int i = x; i > 0; i -= lowbit(i))
	{
		for (int j = y; j > 0; j -= lowbit(j))
		{
			ans += c[i][j];
		}
	}
	return ans;
}

int main()
{
	while (~scanf("%d", &n), n)
	{
		scanf("%d%d", &w, &h);
		memset (c, 0, sizeof(c) );
		int x, y;
		for (int i = 0; i < n; i++)
		{
			scanf("%d%d", &x, &y);
			add(x, y);
		}
		int s, t;
		scanf("%d%d", &s, &t);
		int ans = 0;
		for (int i = 1; i <= w; i++)
		{
			for (int j = 1; j <= h; j++)
			{
				ans = max(ans, sum(i, j) - sum(i, j - t) - sum(i - s, j) + sum(i - s, j - t));
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}
时间: 2024-10-17 13:22:11

POJ2029——Get Many Persimmon Trees的相关文章

POJ2029:Get Many Persimmon Trees(二维树状数组)

Description Seiji Hayashi had been a professor of the Nisshinkan Samurai School in the domain of Aizu for a long time in the 18th century. In order to reward him for his meritorious career in education, Katanobu Matsudaira, the lord of the domain of

poj2029 Get Many Persimmon Trees

Description Seiji Hayashi had been a professor of the Nisshinkan Samurai School in the domain of Aizu for a long time in the 18th century. In order to reward him for his meritorious career in education, Katanobu Matsudaira, the lord of the domain of

POJ 2029 Get Many Persimmon Trees (二维树状数组)

Get Many Persimmon Trees Time Limit:1000MS    Memory Limit:30000KB    64bit IO Format:%I64d & %I64u SubmitStatusPracticePOJ 2029 Description Seiji Hayashi had been a professor of the Nisshinkan Samurai School in the domain of Aizu for a long time in

poj2029--Get Many Persimmon Trees(dp)

Get Many Persimmon Trees Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 3708   Accepted: 2410 Description Seiji Hayashi had been a professor of the Nisshinkan Samurai School in the domain of Aizu for a long time in the 18th century. In

POJ 2029 Get Many Persimmon Trees

这是动态规划?我一点思路怎么也没有.最后还是用矩阵部分求和枚举0MS. 题目大意: 给出一个矩阵,上面有几个点.在给一个小点儿的矩阵,求这个矩阵最多能套上几个点.(注意:小矩阵长宽给定,不能旋转). 解题思路: 建立数组num[i][j]代表点(1,1)到点(i,j)组成的矩阵里有几个点. 下面是代码: #include <stdio.h> #include <string.h> int num[105][105]; int cal(int x1,int y1,int x2,int

【POJ 2029】 Get Many Persimmon Trees(DP)

[POJ 2029] Get Many Persimmon Trees(DP) Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 4024   Accepted: 2628 Description Seiji Hayashi had been a professor of the Nisshinkan Samurai School in the domain of Aizu for a long time in the 18

(简单) POJ 2029 Get Many Persimmon Trees,暴力。

Description Seiji Hayashi had been a professor of the Nisshinkan Samurai School in the domain of Aizu for a long time in the 18th century. In order to reward him for his meritorious career in education, Katanobu Matsudaira, the lord of the domain of

POJ 2029 Get Many Persimmon Trees(DP)

题目链接 题意 : 给你每个柿子树的位置,给你已知长宽的矩形,让这个矩形包含最多的柿子树.输出数目 思路 :数据不是很大,暴力一下就行,也可以用二维树状数组来做. 1 //2029 2 #include <stdio.h> 3 #include <string.h> 4 #include <iostream> 5 6 using namespace std ; 7 8 int mapp[110][110] ; 9 10 int main() 11 { 12 int N

xtu数据结构 B. Get Many Persimmon Trees

B. Get Many Persimmon Trees Time Limit: 1000ms Memory Limit: 30000KB 64-bit integer IO format: %lld      Java class name: Main Submit Status Seiji Hayashi had been a professor of the Nisshinkan Samurai School in the domain of Aizu for a long time in