Crashing Robots

Description

In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving. 
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

Input

The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction. 
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively. 
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position. 
 
Figure 1: The starting positions of the robots in the sample warehouse
Finally there are M lines, giving the instructions in sequential order. 
An instruction has the following format: 
< robot #> < action> < repeat> 
Where is one of

  • L: turn left 90 degrees,
  • R: turn right 90 degrees, or
  • F: move forward one meter,

and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

Output

Output one line for each test case:

  • Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.)
  • Robot i crashes into robot j, if robots i and j crash, and i is the moving robot.
  • OK, if no crashing occurs.

Only the first crash is to be reported.

Sample Input

4
5 4
2 2
1 1 E
5 4 W
1 F 7
2 F 7
5 4
2 4
1 1 E
5 4 W
1 F 3
2 F 1
1 L 1
1 F 3
5 4
2 2
1 1 E
5 4 W
1 L 96
1 F 2
5 4
2 3
1 1 E
5 4 W
1 F 4
1 L 1
1 F 20

Sample Output

Robot 1 crashes into the wall
Robot 1 crashes into robot 2
OK
Robot 1 crashes into robot 2

Source

Nordic 2005

题意:机器人碰撞模拟,自己写很烦,网上拉来一段代码~稍修改,关键点1:用一个数组来存改变方向的值,用0123来确定要去的方向;关键点2:用一个数组来标记是否机器人在该点,标记的值为机器人的number,若机器人离开,该标记就变成零.关键点3:用cin>>来同时输入整形和浮点型交叉的数据.

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int M = 110;
int map[M][M];
int xy[4][2]={{0,-1},{1,0},{0,1},{-1,0}};
bool reported;
int A,B,n,m;
struct Robot
{
    int x, y;
    int d;
}r[M];

int dir(char d)
{
    if(d==‘S‘) return 0;
    if(d==‘E‘) return 1;
    if(d==‘N‘) return 2;
    if(d==‘W‘) return 3;
}
void move(int id, int times)
{
    int d = r[id].d;
    map[r[id].x][r[id].y]=0;
    for(int i=0; i<times; i++)
    {
        r[id].x += xy[d][0];
        r[id].y += xy[d][1];
        if((!r[id].x||r[id].x>A) || (!r[id].y||r[id].y>B))
        {
            reported = true;
            printf("Robot %d crashes into the wall\n", id);
            return ;
        }
        if(map[r[id].x][r[id].y]!=0)
        {
            reported = true;
            printf("Robot %d crashes into robot %d\n", id, map[r[id].x][r[id].y]);
            return ;
        }
    }
    map[r[id].x][r[id].y] = id;
}
int main()
{
    int i,t,id,times;
    char d;
    scanf("%d", &t);
    while(t--)
    {
        memset(map, 0, sizeof(map));
        reported = false;
        scanf("%d%d", &A, &B);
        scanf("%d %d", &n, &m);
        for(i=1; i<=n; i++)
        {
            cin>>r[i].x>>r[i].y>>d;
            r[i].d = dir(d);
            map[r[i].x][r[i].y] = i;
        }
        for(i=0; i<m; i++)
        {
            cin>>id>>d>>times;
            if(d==‘F‘ && !reported) move(id, times);
            else if(d==‘L‘ && !reported)
            {
                times %=4;
                r[id].d = (r[id].d+times)%4;
            }
            else if(d==‘R‘ && !reported)
            {
                times %= 4;
                r[id].d = (r[id].d-times)%4;
                if(r[id].d<0) r[id].d +=4;
            }
        }
        if(!reported) printf("OK\n");
    }
    return 0;
}

时间: 2024-10-06 21:58:15

Crashing Robots的相关文章

poj 2632 Crashing Robots, 模拟

点击打开链接 简单 模拟机器人的移动,发生碰撞时输出相应的信息. code #include <cstdio> #include <cstring> using namespace std; struct node{ int k; int s; } mtx[200][200]; struct node1{ int x, y; } rob[200]; int n, m; int dir[4][2]= {{0,1},{1,0},{0,-1},{-1,0}}; //N, E, S, W

POJ2632——Crashing Robots

Crashing Robots DescriptionIn a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and a

Crashing Robots(imitate)

Crashing Robots Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 8124   Accepted: 3528 Description In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destination

POJ 2632 Crashing Robots(模拟题)

Crashing Robots Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7880   Accepted: 3429 Description In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destination

poj -2632 Crashing Robots

http://poj.org/problem?id=2632 Crashing Robots Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7470   Accepted: 3265 Description In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the

POJ 2632:Crashing Robots

Crashing Robots Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 8424   Accepted: 3648 Description In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destination

POJ 2632 Crashing Robots (模拟 坐标调整)(fflush导致RE)

题目链接:http://poj.org/problem?id=2632 先话说昨天顺利1Y之后,直到今天下午才再出题 TAT,真是刷题计划深似海,从此AC是路人- - 本来2632是道稍微恶心点的模拟,但毕竟是模拟,一般模拟都是只要示例过了基本就AC了,但这个题很特殊 我开始的时候一直跑不出测试示例,才发现题目中的插图和我构想的坐标系是不一样的(看来还不能轻易忽视掉插图啊) 这个题给出的坐标系是纵轴为y,横轴为x,y从下到上依次递增,x轴是从左到右递增 而我用的二维数组记录的地图,也就是说我的纵

Poj OpenJudge 百练 2632 Crashing Robots

1.Link: http://poj.org/problem?id=2632 http://bailian.openjudge.cn/practice/2632/ 2.Content: Crashing Robots Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7912   Accepted: 3441 Description In a modernized warehouse, robots are used to

Crashing Robots(水题,模拟)

1020: Crashing Robots 时间限制(普通/Java):1000MS/10000MS     内存限制:65536KByte 总提交: 207            测试通过:101 描述 In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations withou