1009 Product of Polynomials (25分) 多项式乘法

1009 Product of Polynomials (25分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N?1?? a?N?1???? N?2?? a?N?2???? ... N?K?? a?N?K????

where K is the number of nonzero terms in the polynomial, N?i?? and a?N?i???? (i=1,2,?,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N?K??<?<N?2??<N?1??≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

注意系数为0的情况

#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
#include<stack>
#include<algorithm>
#include<map>
#include<string.h>
#include<string>
#define MAX 1000000
#define ll long long
using namespace std;
double a[10005],b[10005],c[10005];
double y;
int x;
int main()
{
    int k;
    cin>>k;
    for(int i=0;i<2006;i++)
        a[i]=b[i]=c[i]=0;
    for(int i=0;i<k;i++)
    {
        cin>>x>>y;
        a[x]=y;
    }
    cin>>k;
    for(int i=0;i<k;i++)
    {
        cin>>x>>y;
        b[x]=y;
    }
    for(int i=0;i<1005;i++)
    {
        for(int j=0;j<1005;j++)
            c[i+j]=c[i+j]+a[i]*b[j];//合并同类项
    }

    int cnt=0;
    for(int i=0;i<2005;i++)
    {
        if(c[i]!=0)//去除多项式系数为0的项
            cnt++;
    }
    cout<<cnt;
    for(int i=2005;i>=0;i--)
    {
        if(c[i]!=0)
            printf(" %d %.1lf",i,c[i] );
    }
    cout<<endl;
    return 0;
}
 

原文地址:https://www.cnblogs.com/-citywall123/p/12123007.html

时间: 2024-09-30 07:15:59

1009 Product of Polynomials (25分) 多项式乘法的相关文章

[PTA] PAT(A) 1009 Product of Polynomials (25 分)

目录 Problem Description Input Output Sample Sample Input Sample Output Solution Analysis Code Result Problem portal:1009 Product of Polynomials Description Input Output Sample Sample Input Sample Output Solution Analysis Code #include <bits/stdc++.h>

PAT Advanced 1009 Product of Polynomials (25分)

This time, you are supposed to find A×B where A and B are two polynomials. Input Specification: Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N?1?? a?N?1???? N?2?? a?N?2?

1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials. Input Specification: Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N?1?? a?N?1???? N?2?? a?N?2?

1009 Product of Polynomials (25)(25 分)

1009 Product of Polynomials (25)(25 分) This time, you are supposed to find A*B where A and B are two polynomials. Input Specification: Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a pol

PAT 1009. Product of Polynomials (25)

1009. Product of Polynomials (25) This time, you are supposed to find A*B where A and B are two polynomials. Input Specification: Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomi

1009. Product of Polynomials (25)——PAT (Advanced Level) Practise

题目信息: 1009. Product of Polynomials (25) 时间限制 400 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue This time, you are supposed to find A*B where A and B are two polynomials. Input Specification: Each input file contains one test case. Each c

PAT甲题题解-1009. Product of Polynomials (25)-多项式相乘

多项式相乘 注意相乘结果的多项式要开两倍的大小!!! #include <iostream> #include <cstdio> #include <algorithm> #include <cstring> #include <string.h> using namespace std; //两个多项式相乘 const int maxn=1000+5; int k; //原本定义个exp导致编译错误,没想到定义成exp1.exp2也会编译错误,

1009 Product of Polynomials (25)(25 point(s))

problem This time, you are supposed to find A*B where A and B are two polynomials. Input Specification: Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ..

1009. Product of Polynomials (25)

1 #include <stdio.h> 2 3 struct MyStruct 4 { 5 int exp; 6 double coe; 7 }; 8 9 int main() 10 { 11 int k1,k2,i,j; 12 MyStruct ans1[10],ans2[10]; 13 double dans[2001]; //两个 最高幂相乘 , 最高幂为2000 14 while(scanf("%d",&k1)!=EOF) 15 { 16 for(i=0;