JS trim去除字符串收尾指定字符

String.prototype.trim = function (char, type) {
if (char) {
if (type == ‘left‘) {
return this.replace(new RegExp(‘^\\‘+char+‘+‘, ‘g‘), ‘‘);
} else if (type == ‘right‘) {
return this.replace(new RegExp(‘\\‘+char+‘+$‘, ‘g‘), ‘‘);
}
return this.replace(new RegExp(‘^\\‘+char+‘+|\\‘+char+‘+$‘, ‘g‘), ‘‘);
}
return this.replace(/^\s+|\s+$/g, ‘‘);
};

// 去除字符串首尾的全部空白
var str = ‘ Ruchee ‘;
console.log(‘xxx‘ + str.trim() + ‘xxx‘); // xxxRucheexxx

// 去除字符串左侧空白
str = ‘ Ruchee ‘;
console.log(‘xxx‘ + str.trim(‘ ‘, ‘left‘) + ‘xxx‘); // xxxRuchee xxx

// 去除字符串右侧空白
str = ‘ Ruchee ‘;
console.log(‘xxx‘ + str.trim(‘ ‘, ‘right‘) + ‘xxx‘); // xxx Rucheexxx

// 去除字符串两侧指定字符
str = ‘/Ruchee/‘;
console.log(str.trim(‘/‘)); // Ruchee

// 去除字符串左侧指定字符
str = ‘/Ruchee/‘;
console.log(str.trim(‘/‘, ‘left‘)); // Ruchee/

// 去除字符串右侧指定字符
str = ‘/Ruchee/‘;
console.log(str.trim(‘/‘, ‘right‘)); // /Ruchee

原文地址:https://www.cnblogs.com/jiangqiuju/p/8350633.html

时间: 2024-09-29 00:25:58

JS trim去除字符串收尾指定字符的相关文章

js如何截取字符串右边指定长度的字符

js如何截取字符串右边指定长度的字符:通常情况下都从字符串的左边开始截取字符串,下面介绍一下如何从字符串的右边截取字符串.代码如下: String.prototype.right=function(length_) { var _from=this.length-length_; if(_from<0) _from=0; return this.substring(this.length - length_,this.length); } var str="antzone"; c

js获取一个字符串中指定字符串第n次出现的位置

1.JS获取一个字符串中指定字符串第n次出现的位置 了解类似的获取字符位置的方法: 1.1 charAt() 获取字符串指定位置的字符 用法:strObj是字符串对象,index是指定的位置,(位置从0开始数) strObj.charAt(index) 1.2 indexOf() 方法可返回某个指定的字符串值在字符串中首次出现的位置 用法:stringObject是字符串对象,searchvalue是指定的字符串值,fromindex(可有可无)指定开始匹配字符串值的位置,若无,表示从0位置开始

C# 移除字符串头尾指定字符

1 private void button1_Click(object sender, EventArgs e) 2 {//去掉字符串头尾指定字符 3 string MyInfo= "--中华人民共和国--"; 4 //显示 "中华人民共和国" 5 MessageBox.Show(MyInfo.Trim(new char[1] { '-' }), "信息提示", MessageBoxButtons.OK, MessageBoxIcon.Infor

js如何将字符串中的字符位置倒转

js如何将字符串中的字符位置倒转:在实际需要中,可能需要将字符串中的字符的位置反转,当然可能应用不会这么直接,下面就通过代码示例介绍一下如何实现此效果,希望能够给需要的朋友或多或少带来一定的帮助.代码实例如下: var str="antzone"; var strArray=str.split(""); console.log(strArray.reverse().join("")); 以上代码实现了我们的要求,非常的简单,就是使用split()

C# 移除字符串末尾指定字符

#region 移除字符串末尾指定字符 /// <summary> /// 移除字符串末尾指定字符 /// </summary> /// <param name="str">需要移除的字符串</param> /// <param name="value">指定字符</param> /// <returns>移除后的字符串</returns> public static s

jquery $.trim()去除字符串空格详解

语法 jQuery.trim()函数用于去除字符串两端的空白字符. 作用 该函数可以去除字符串开始和末尾两端的空白字符(直到遇到第一个非空白字符串为止).它会清除包括换行符.空格.制表符等常见的空白字符. 参数 如果参数str不是字符串类型,该函数将自动将其转为字符串(一般调用其toString()方法).如果参数str为null或undefined,则返回空字符串(""). 返回值 jQuery.trim()函数的返回值为String类型,返回去除两端空白字符串后的字符串. 示例&a

Java去除字符串首尾特定字符

工作中,由于mysql存储格式特定,字符串首尾均带有单引号,需要对首尾单引号做一个去除处理.我将此封装到一个公共的方法里,代码如下: 1 /** 2 * 去除首尾指定字符 3 * @param str 字符串 4 * @param element 指定字符 5 * @return 6 */ 7 public static String trimFirstAndLastChar(String str, String element){ 8 boolean beginIndexFlag = true

JavaSE8基础 String trim 去除字符串两端的空格

os :windows7 x64    jdk:jdk-8u131-windows-x64    ide:Eclipse Oxygen Release (4.7.0)        code: package jizuiku.t02; public class Demo3 { public static void main(String[] args) { String s1 = " h ell wor l d "; //去除字符串两头的空格 System.out.println(s1

统计字符串中指定字符的个数

输入一个字符串和一个字符,统计这个字符在字符串中出现的次数 输入格式: 输入2行.第1行是字符串,第2行是要查找的字符. 输出格式: 字符出现的次数 输入样例: abcdefgabcdefg a 输出样例: 2 a=input() b=input() def CountAa(s): return s.lower().count(b) if __name__ == "__main__": s = a print(CountAa(s)) 原文地址:https://www.cnblogs.c