(字符串 枚举)The Hardest Problem Ever hdu1048

The Hardest Problem Ever

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1048

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31307    Accepted Submission(s):
14491

Problem Description

Julius Caesar lived in a time of danger and intrigue.
The hardest situation Caesar ever faced was keeping himself alive. In order for
him to survive, he decided to create one of the first ciphers. This cipher was
so incredibly sound, that no one could figure it out without knowing how it
worked.
You are a sub captain of Caesar‘s army. It is your job to decipher
the messages sent by Caesar and provide to your general. The code is simple. For
each letter in a plaintext message, you shift it five places to the right to
create the secure message (i.e., if the letter is ‘A‘, the cipher text would be
‘F‘). Since you are creating plain text out of Caesar‘s messages, you will do
the opposite:

Cipher text
A B C D E F G H I J K L M N O P Q R S T U V
W X Y Z

Plain text
V W X Y Z A B C D E F G H I J K L M N O P Q R S T U

Only letters are shifted in this cipher. Any non-alphabetical character
should remain the same, and all alphabetical characters will be upper
case.

Input

Input to this problem will consist of a (non-empty)
series of up to 100 data sets. Each data set will be formatted according to the
following description, and there will be no blank lines separating data sets.
All characters will be uppercase.

A single data set has 3 components:

Start line - A single line, "START"

Cipher message - A single
line containing from one to two hundred characters, inclusive, comprising a
single message from Caesar

End line - A single line, "END"

Following the final data set will be a single line,
"ENDOFINPUT".

Output

For each data set, there will be exactly one line of
output. This is the original message by Caesar.

Sample Input

START

NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX

END

START
N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ

END

START
IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ

END

ENDOFINPUT

Sample Output

IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES

I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME

DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE

Source

South
Central USA 2002

可以用JAVA进行枚举。

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        @SuppressWarnings("resource")
        Scanner inScanner = new Scanner(System.in);
        while(inScanner.hasNext()) {
            String string = inScanner.nextLine();
            if(string.equals("ENDOFINPUT")) {
                break;
            }
            else if(string.equals("START") || string.equals("END")) {
                continue;
            }
            else {
                for(int i = 0;i<string.length();i++) {
                    if(string.charAt(i)>=‘A‘ && string.charAt(i)<=‘E‘) {
                        System.out.printf("%c",string.charAt(i)+26-5);
                    }
                    else if(string.charAt(i)>=‘F‘&&string.charAt(i)<=‘Z‘){
                        System.out.printf("%c", string.charAt(i)-5);
                    }
                    else {
                        System.out.printf("%c",string.charAt(i));
                    }
                }
            }
            System.out.println();
        }
    }
}

原文地址:https://www.cnblogs.com/Weixu-Liu/p/9661377.html

时间: 2024-10-06 20:05:26

(字符串 枚举)The Hardest Problem Ever hdu1048的相关文章

HDU 1048.The Hardest Problem Ever【字符串处理】【8月25】

The Hardest Problem Ever Problem Description Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cip

HDU1048 The Hardest Problem Ever

The Hardest Problem Ever Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 15790    Accepted Submission(s): 7298 Problem Description Julius Caesar lived in a time of danger and intrigue. The hard

The Hardest Problem Ever(杭电1048)

/*The Hardest Problem Ever Problem Description Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This c

HDU-1048-The Hardest Problem Ever(C++ &amp;&amp; 偶尔一水......)

The Hardest Problem Ever Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 19343    Accepted Submission(s): 9061 Problem Description Julius Caesar lived in a time of danger and intrigue. The hard

JAVA HDU 1048 The Hardest Problem Ever

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1048 1 package hdu; 2 3 import java.io.BufferedInputStream; 4 import java.util.Scanner; 5 6 public class hdu_1048 { 7 8 public static void main(String[] args) { 9 Scanner in = new Scanner(new BufferedInp

C - The Hardest Problem Ever

Description Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that

1298 The Hardest Problem Ever

题目链接:http://poj.org/problem?id=1298 思路: 水题,字符偏移求解,注意字符串输入问题即可. 代码: #include <iostream> #include <string> using namespace std; const int MAX_N = 200 + 10; char A[MAX_N]; int main() { int Len; char Tmp[20]; while ( scanf( "%s", Tmp )!=

The Hardest Problem Ever(有史以来最难的题)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 19083    Accepted Submission(s): 8885 Problem Description Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever

D语言字符串枚举的使用

D语言中enum不只是可以使用数字类型,也可以使用字符串: import std.stdio; import std.range; int main(string[] argv) { enum XYZ : string { a = "foo" } writeln(XYZ.a == "foo"); writeln(XYZ.a); readln(); return 0; } 运行 第一行输出来true,说明XYZ.a与"foo"字符串相等,第二行输出