uva 116 Unidirectional TSP (DP)

uva 116 Unidirectional TSP

Background

Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Problem (TSP) – finding whether all the cities in a salesperson’s route can be visited exactly once with a specified limit on travel time – is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are simple to check.

This problem deals with finding a minimal path through a grid of points while traveling only from left to right.

The Problem

Given an tex2html_wrap_inline352 matrix of integers, you are to write a program that computes a path of minimal weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i+1 in an adjacent (horizontal or diagonal) row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix “wraps” so that it represents a horizontal cylinder. Legal steps are illustrated below.

The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited.

For example, two slightly different tex2html_wrap_inline366 matrices are shown below (the only difference is the numbers in the bottom row).

The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows.

The Input

The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by tex2html_wrap_inline376 integers where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive. There will be one or more matrix specifications in an input file. Input is terminated by end-of-file.

For each specification the number of rows will be between 1 and 10 inclusive; the number of columns will be between 1 and 100 inclusive. No path’s weight will exceed integer values representable using 30 bits.

The Output

Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of n integers (separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output.

Sample Input

5 6

3 4 1 2 8 6

6 1 8 2 7 4

5 9 3 9 9 5

8 4 1 3 2 6

3 7 2 8 6 4

5 6

3 4 1 2 8 6

6 1 8 2 7 4

5 9 3 9 9 5

8 4 1 3 2 6

3 7 2 1 2 3

2 2

9 10 9 10

Sample Output

1 2 3 4 4 5

16

1 2 1 5 4 5

11

1 1

19

题目大意:给出一个n*m的矩阵,要求从第一列任意一行开始,到最后一列的最小花费。(每次有三个方向可以选择)输出花费最小且字典序最小的行走路线,并输出总花费。

解题思路:从最后一列开始往前逆推,公式为dp[i][j] = min(dp[dir[k]][j + 1] + num[i][j])。

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#define N 105
using namespace std;
int num[N][N], n, m;
int dp[N][N], rec[N][N], ans, begin;
int DP() { //dp[i][j]数组记录的是 格子i j 出发,到最后一列的最小开销
    for (int j = m - 1; j >= 0; j--) {
        for (int i = 0; i < n; i++) {
            if (j == m - 1) {
                dp[i][j] = num[i][j];
            }
            else {
                int dir[3] = {i + 1, i, i - 1};
                if (dir[0] == n) dir[0] = 0;
                if (dir[2] == -1) dir[2] = n - 1;
                sort(dir, dir + 3);
                dp[i][j] = 0xFFFFFFF;
                for (int k = 0; k < 3; k++) {
                    int temp = dp[dir[k]][j + 1] + num[i][j];
                    if (temp < dp[i][j]) {
                        dp[i][j] = temp;
                        rec[i][j] = dir[k];
                    }
                }
            }
            if (j == 0 && dp[i][j] < ans) {
                ans = dp[i][j];
                begin = i;
            }
        }
    }
}
int main() {
    while (scanf("%d %d", &n, &m) == 2) {
        memset(dp, 0, sizeof(dp));
        memset(rec, 0, sizeof(rec));
        for (int i = 0; i < n; i++) {
            for (int j = 0; j < m; j++) {
                scanf("%d", &num[i][j]);
            }
        }
        ans = 0xFFFFFFF;

        DP();

        printf("%d", begin + 1);
        int i = rec[begin][0];
        for (int j = 1; j < m; j++) {
            printf(" %d", i + 1);
            i = rec[i][j];
        }
        printf("\n%d\n", ans);
    }
    return 0;
}
时间: 2024-11-07 04:37:51

uva 116 Unidirectional TSP (DP)的相关文章

116 - Unidirectional TSP(DP)

多段图的最短路问题 .  运用了很多的技巧 :如 记录字典序最小路径 . 细节参见代码: #include<bits/stdc++.h> using namespace std; const int INF = 2000000000; int m,n,a[15][105],d[15][105],next_[15][105]; int main() { while(~scanf("%d%d",&m,&n)) { for(int i=0;i<m;i++)

UVA - 116 - Unidirectional TSP (简单DP + 打印路径)

题目传送:UVA - 116 思路:可以定义状态为dp[i][j] 为从第i行第j列开始往后走到第n列(总共n列)的最小值(赋初始值为无穷),且状态方程很好推出来:dp[i][j] = a[i][j] + max(dp[i-1][j+1], dp[i][j+1], dp[i+1][j+1]);    最后最优解  ans = max(dp[i][1])(1<=i<=m); 不过这题难点不在这里,而是可能有多组最小值,输出字典序最小的那组: 这里要注意好递推的方向,只能从右往左递推列数,而如果从

HDU 1619 &amp; UVA 116 Unidirectional TSP(树形dp,入门 , 数塔变形)

Unidirectional TSP Description Background Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Travelin

uva 116 Unidirectional TSP(动态规划,多段图上的最短路)

这道题目并不是很难理解,题目大意就是求从第一列到最后一列的一个字典序最小的最短路,要求不仅输出最短路长度,还要输出字典序最小的路径. 这道题可以利用动态规划求解.状态定义为: cost[i][j] = max{cost[i+1][j+k]+c[i][j]}(k=-1,0,1) 关于最短路长度的求法,我们可以通过上边的状态转移方程递推求解.cost代表从第i列到第c-1列的最短路,只要找出cost[0][j](j代表行号)中的最大值,我们得到的结果就是最短路. 我们已经得到了最短路的长度.下一步,

Unidirectional TSP(dp)

Description Background Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Probl

UVA 116 Unidirectional TSP(DP最短路字典序)

Description  Unidirectional TSP  Background Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Travel

uva 116 - Unidirectional TSP (动态规划)

第一次做动规题目,以下均为个人理解以及个人方法,状态转移方程以及状态的定义也是根据个人理解,请过路大神指教. 状态:每一列的每一个数[ i ][ j ]都是一个状态: 然后定义状态[ i ][ j ]的指标函数d[ i ][ j ]为从[ i ][ j ]向右出发的可以得到的最小的整数和: 状态转移方程:d[ i ][ j ]=min(d[ i+1 ][ j+1 ][ i-1 ][ j+1 ][ i ][ j+1 ])+a[ i ][ j ]; 其中a[ i ][ j ]为当前位置的数值: 然后

uva 116 Unidirectional TSP【号码塔+打印路径】

主题: uva 116 Unidirectional TSP 意甲冠军:给定一个矩阵,当前格儿童值三个方向回格最小值和当前的和,就第一列的最小值并打印路径(同样则去字典序最小的). 分析:刚開始想错了,从前往后走,这种话没有办法控制字典序最小,用dfs标记了一下超时了. 事实上从后往前走就好了. 以后一定先想清楚顺序.然后dp的时候选择字典序最小的.用father数据记录就可以. AC代码: #include<iostream> #include<cstdio> #include&

uva 116 Unidirectional TSP【数塔+打印路径】

题目: uva 116 Unidirectional TSP 题意:给出一个矩阵,当前的格子值为后面三个方向的格子最小值和当前的和,就第一列的最小值并打印路径(相同则去字典序最小的). 分析:刚开始想错了,从前往后走,这样的话没有办法控制字典序最小,用dfs标记了一下超时了. 其实从后往前走就好了.以后一定先想清楚顺序,然后dp的时候选择字典序最小的,用father数据记录即可. AC代码: #include<iostream> #include<cstdio> #include&