HDU-5086-Revenge of Segment Tree (BestCoder Round #16)

Revenge of Segment Tree

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 205    Accepted Submission(s): 83

Problem Description

In computer science, a segment tree is a tree data structure for storing intervals, or segments. It allows querying which of the stored segments contain a given point. It is, in principle, a static structure; that is, its content cannot be modified once the
structure is built. A similar data structure is the interval tree.

A segment tree for a set I of n intervals uses O(n log n) storage and can be built in O(n log n) time. Segment trees support searching for all the intervals that contain a query point in O(log n + k), k being the number of retrieved intervals or segments.

---Wikipedia

Today, Segment Tree takes revenge on you. As Segment Tree can answer the sum query of a interval sequence easily, your task is calculating the sum of the sum of all continuous sub-sequences of a given number sequence.

Input

The first line contains a single integer T, indicating the number of test cases.

Each test case begins with an integer N, indicating the length of the sequence. Then N integer Ai follows, indicating the sequence.

[Technical Specification]

1. 1 <= T <= 10

2. 1 <= N <= 447 000

3. 0 <= Ai <= 1 000 000 000

Output

For each test case, output the answer mod 1 000 000 007.

Sample Input

2
1
2
3
1 2 3

Sample Output

2
20

Hint

For the second test case, all continuous sub-sequences are [1], [2], [3], [1, 2], [2, 3] and [1, 2, 3]. So the sum of the sum of the sub-sequences is 1 + 2 + 3 + 3 + 5 + 6 = 20.
Huge input, faster I/O method is recommended. And as N is rather big, too straightforward algorithm (for example, O(N^2)) will lead Time Limit Exceeded.
And one more little helpful hint, be careful about the overflow of int.

Source

BestCoder Round #16

简单题!!

刚开始看的时候没想法,就不想做了,后来学长发来代码也没看,不过这回排名88,288,488有机械键盘,然后我猥琐的把学长的代码提交了O(∩_∩)O哈哈~

后来自己又看了看,还挺简单的嘛!唉:-(

题意:求一个序列的所有连续子序列的序列和的和。

思路:考虑每个数出现在多少个子序列之中,假设第i个数为Ai,区间为[ L , R ] (1 <=  L <= i ,  i <= R  <= n  )。那么包含Ai的区间满足i*(n-i+1)。累加i*(n-i+1)?A[i]就可以了。

注意了,这个  (i*(n-i+1))%maxn  公式里要全部定义为long  long,  不然会WA,所以以后有long long就最好全部定义为long  long

AC代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#define LL long long
using namespace std;

const LL maxn = 1000000007;

int main()
{
	int T;
	scanf("%d", &T);
	while(T--)
	{
		int n;
		LL a, ans=0;
		scanf("%d", &n);
		for(LL i=1; i<=n; i++)
		{
			scanf("%I64d", &a);
			LL tmp = ((i*(n-i+1))%maxn);
			ans += ((a*tmp) % maxn);
			ans %= maxn;
		}
		printf("%I64d\n", ans);
	}
	return 0;
} 
时间: 2024-10-06 00:16:00

HDU-5086-Revenge of Segment Tree (BestCoder Round #16)的相关文章

hdu 5087 Revenge of LIS II(BestCoder Round #16)

Revenge of LIS II                                                  Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 528    Accepted Submission(s): 173 Problem Description In computer science, th

[ACM] HDU 5086 Revenge of Segment Tree(全部连续区间的和)

Revenge of Segment Tree Problem Description In computer science, a segment tree is a tree data structure for storing intervals, or segments. It allows querying which of the stored segments contain a given point. It is, in principle, a static structur

[ACM] HDU 5086 Revenge of Segment Tree(所有连续区间的和)

Revenge of Segment Tree Problem Description In computer science, a segment tree is a tree data structure for storing intervals, or segments. It allows querying which of the stored segments contain a given point. It is, in principle, a static structur

hdu 5088 Revenge of Nim II(BestCoder Round #16)

Revenge of Nim II                                                          Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 203    Accepted Submission(s): 63 Problem Description Nim is a mathema

hdu 5086 Revenge of Segment Tree(BestCoder Round #16)

Revenge of Segment Tree                                                          Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 420    Accepted Submission(s): 180 Problem Description In comput

HDU 5067 Harry And Dig Machine(BestCoder Round #14)

Problem Description: As we all know, Harry Porter learns magic at Hogwarts School. However, learning magical knowledge alone is insufficient to become a great magician. Sometimes, Harry also has to gain knowledge from other certain subjects, such as

HUD 5086 Revenge of Segment Tree(递推)

http://acm.hdu.edu.cn/showproblem.php?pid=5086 题目大意: 给定一个序列,求这个序列的子序列的和,再求所有子序列总和,这些子序列是连续的.去题目给的第二组数据的 3 1 2 3 这个序列的子序列有 [1].[2].[3].[1.2].[2.3].[1.2.3],这些子序列的和是分别是1.2.3.3.5.6.再将这些和加起来 1+2+3+3+5+6=20这个就是最终的答案. 解题思路: 我们假设n等于5.序列为1.2.3.4.5.然后我们将它们如下排列

HDU 4932 Miaomiao&#39;s Geometry(BestCoder Round #4)

Problem Description: There are N point on X-axis . Miaomiao would like to cover them ALL by using segments with same length. There are 2 limits: 1.A point is convered if there is a segments T , the point is the left end or the right end of T.2.The le

hdu 5066 Harry And Physical Teacher(Bestcoder Round #14)

Harry And Physical Teacher Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 91    Accepted Submission(s): 68 Problem Description As we all know, Harry Porter learns magic at Hogwarts School. How