HDU 1425 sort(堆排序/快排)

传送门

Description

给你n个整数,请按从大到小的顺序输出其中前m大的数。

Input

每组测试数据有两行,第一行有两个数n,m(0<n,m<1000000),第二行包含n个各不相同,且都处于区间[-500000,500000]的整数。

Output

对每组测试数据按从大到小的顺序输出前m大的数。

Sample Input

5 3 3 -35 92 213 -644

Sample Output

213 92 3

1、使用内建sort函数

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int ans[1000001];
int main()
{
    int n,m;
    while (scanf("%d%d",&n,&m) != EOF)
    {
        for (int i = 0;i < n;i++)
        {
            scanf("%d",&ans[i]);
        }
        sort(ans,ans + n);
        printf("%d",ans[n - 1]);
        for(int i = n - 2;m > 1;m--,i--)
        {
            printf(" %d",ans[i]);
        }
        printf("\n");
    }
    return 0;
}

2、使用内建优先队列

#include<iostream>
#include<queue>
#include<cstdio>
using namespace std;

int main()
{
    int N,M;
    while (~scanf("%d%d",&N,&M))
    {
        priority_queue<int>que;
        bool first = true;
        int tmp;
        while (N--)
        {
            scanf("%d",&tmp);
            que.push(tmp);
        }
        while (M--)
        {
            first?printf("%d",que.top()):printf(" %d",que.top());
            que.pop();
            first = false;
        }
        printf("\n");
    }
    return 0;
}

3、使用内部堆函数

#include <cstdio>
#include <algorithm>
using namespace std;

static int a[1000000];

int main()
{
    int i,n,m;
    while(EOF != scanf("%d %d",&n,&m))
    {
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        make_heap(a,a+n);
        printf("%d",a[0]);
        for(i=1;i<m;i++)
        {
            pop_heap(a,a+n-i+1);
            printf(" %d",a[0]);
        }
        printf("\n");
    }
    return 0;
}

4、手写堆排序

#include<stdio.h>
#include<string.h>
const int maxn = 1000005;
int heap[maxn],sz = 0;

void push(int x)
{
    int i = sz++;
    while (i > 0)
    {
        int p = (i - 1)/2;
        if (heap[p] >= x)    break;
        heap[i] = heap[p];
        i = p;
    }
    heap[i] = x;
}

int pop()
{
    int ret = heap[0];
    int x = heap[--sz];
    int i = 0;
    while (i*2+1<sz)
    {
        int a = i*2+1,b = i*2+2;
        if (b < sz && heap[b]>heap[a])    a = b;
        if (heap[a] <= x)    break;
        heap[i] = heap[a];
        i = a;
    }
    heap[i] = x;
    return ret;
}

int main()
{
    int n,m,tmp;
    while (~scanf("%d%d",&n,&m))
    {
        sz = 0;
        memset(heap,0,sizeof(heap));
        for (int i = 0;i < n;i++)    scanf("%d",&tmp),push(tmp);
        for (int i = 1;i < m;i++)    printf("%d ",pop());
        printf("%d\n",pop());
    }
    return 0;
}

  

时间: 2024-10-12 21:46:59

HDU 1425 sort(堆排序/快排)的相关文章

HDU 1425 sort 题解

选择出数列中前k个最大的数. 这里因为数据特殊,所以可以使用hash表的方法: #include <cstdio> #include <algorithm> #include <stdlib.h> #include <limits> using namespace std; const int SIZE = 1000005; const int SMALL = -500000; bool arr[SIZE]; int main() { int n, m, a

E题hdu 1425 sort

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1425 sort Time Limit: 6000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 33461    Accepted Submission(s): 9968 Problem Description 给你n个整数,请按从大到小的顺序输出其中前m大的数. Inpu

HDU 1425 sort (排序)

sort Time Limit: 6000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 28997    Accepted Submission(s): 8796 Problem Description 给你n个整数,请按从大到小的顺序输出其中前m大的数. Input 每组测试数据有两行,第一行有两个数n,m(0<n,m<1000000),第二行包含n个各不相同,

HDU 1425 sort (hash)

sort Time Limit: 6000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 29001    Accepted Submission(s): 8799 Problem Description 给你n个整数,请按从大到小的顺序输出其中前m大的数. Input 每组测试数据有两行,第一行有两个数n,m(0<n,m<1000000),第二行包含n个各不相同,

HDU 1425 sort 【哈希入门】

题意:给出n个数,输出前m大的数 和上一题一样,将输入的数加上一个极大地值作为地址 1 #include<iostream> 2 #include<cstdio> 3 #include<cstring> 4 #include <cmath> 5 #include<algorithm> 6 using namespace std; 7 8 typedef long long LL; 9 const int M=500000; 10 int a,ha

【转】HDU 1425 sort:哈希入门

#include<iostream> #include<cstring> #include<cstdio> using namespace std; const int Size = 1000000; int Hash[Size+1]; int main() { int n, m, num; while(cin>>n>>m) { memset(Hash, 0, sizeof(Hash)); for(int i=0; i<n; i++){ s

hdu 1425 sort

这种方法也是万万没想到的~ #include<iostream> #define maxn 1000000+5 using namespace std; int f[maxn]; int n,m; int main() { cin.sync_with_stdio(false); while(cin>>n>>m) { fill(f,f+maxn,0); for(int i=0;i<n;i++) { int x; cin>>x; f[x+500000]++

排序算法复习:直接插入排序、堆排序、快排、冒泡排序

冒泡排序,感觉是最简单的排序: 基本思路:每次把数组中最小的一个元素像气泡一样浮动.固定到最顶端: 从前向后遍历数组,每次拿到一个元素,就执行一遍冒泡: 从数组末尾开始,到当前元素截止,从后向前遍历,每次比较数组中相邻的两个元素,如果后者比较小,就把两者互换. 这样经过第一次冒泡,可以把最小的元素『浮』到数组的首位.第二次冒泡会把第二小的元素『浮』到数组的第二位.直到所有的元素都被『浮动』到正确的位置. 代码极其简单: var BubbleSort = function (array) { va

『ACM C++』HDU杭电OJ | 1425 - sort (排序函数的特殊应用)

今天真的是累哭了,周一课从早八点半一直上到晚九点半,整个人要虚脱的感觉,因为时间不太够鸭所以就回头看看找了一些比较有知识点的题来总结总结分析一下,明天有空了就开始继续打题,嘻嘻嘻. 今日兴趣电影: <超能查派> 这是一部关于未来人工智能的一个故事,感觉特别有思维开拓性,一个程序员写出了真正的AI智能机器人,可以从婴儿开始学习,然后以极快极强的学习速度不断成长,最后拯救身边人的故事.很感人,强烈推荐哈哈~ 爱奇艺:https://www.iqiyi.com/v_19rroly1wo.html?f