POJ1094 Sorting It All Out(拓扑排序)

Sorting It All Out

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 30110   Accepted: 10411

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y.

Sorted sequence cannot be determined.

Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a
sorted sequence is determined or an inconsistency is found, whichever
comes first, and yyy...y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

题意:这题题意好蛋疼啊!!!一个一个给边,一个一个的判断,先判断是否有环。然后再判断是否确定序列。最后前两者都不满足,则此序列不确定。收获:1.知道只有有环时才k<n。2.入度为0的点不唯一,则此序列不确定。3.入度很重要。下面是能AC代码,但是 0 0会有问题,不知道为什么?还请各位指教。
#include <cstdio>
#include <iostream>
//#include <cstdlib>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <string>
#include <cstring>
#include <stack>
#include <queue>
#include <list>
#include <vector>
#include <map>
#include <set>
using namespace std;

const int INF=0x3f3f3f3f;
const double eps=1e-10;
const double PI=acos(-1.0);

const int maxn=5000;
struct Edge
{
    int u, v, next;
};
Edge edge[maxn];
int head[maxn];
int num, n,m;
void init_edge()
{
    num = 0;
    memset(head, -1, sizeof(head));
}
void addedge(int u, int v)
{
    edge[num].u = u;
    edge[num].v = v;
    edge[num].next = head[u];
    head[u] = num++;
}
int ans;
int topo[maxn];
int in[maxn];
int topsort()
{
    queue<int> q;
    int indeg[26];
    for(int i = 65; i < 65+n; i++)
    {
        indeg[i] = in[i];
        if(indeg[i] == 0) q.push(i);
    }
    int k = 0;
    int flag=0;
    while(!q.empty())
    {
        if(q.size()>1)
            flag = 1;
        int u = q.front();
        q.pop();
        topo[k++] = u;
        for(int i = head[u]; i != -1; i = edge[i].next)
        {
            int v = edge[i].v;
            indeg[v]--;
            if(indeg[v]==0)
                q.push(v);
        }
    }
    if(k < n)
        return 0;
    if(flag)
        return -1;
    else
    return 1;
}
char s[5];
int main()
{
    while(~scanf("%d%d", &n, &m))
    {
        if(n==0 && m==0)
           break;
        init_edge();
        memset(in, 0, sizeof(in));
        int flag2 = 0;
        int flag3 = 0;
        for(int j = 1; j <= m; j++)
        {
            scanf("%s",s);
            if(!flag2&&!flag3)
            {
                in[s[2]]++;
                addedge(s[0],s[2]);
                int res = topsort();
                if(res == 0)
                {
                    printf("Inconsistency found after %d relations.\n", j);
                    flag2 = 1;
                }
                if(res == 1)
                {
                    printf("Sorted sequence determined after %d relations: ", j);
                    for(int i=0; i < n; i++)
                        printf("%c", topo[i]);
                    printf(".\n");
                    flag3 = 1;
                }
            }
        }
        if(!flag2&&!flag3)
            puts("Sorted sequence cannot be determined.");

    //puts("QAQ");
    }
    return 0;
}
时间: 2024-10-29 19:12:10

POJ1094 Sorting It All Out(拓扑排序)的相关文章

nyoj349 poj1094 Sorting It All Out(拓扑排序)

nyoj349   http://acm.nyist.net/JudgeOnline/problem.php?pid=349poj1094   http://poj.org/problem?id=1094这两个题是一样的,不过在poj上A了才算真的过,ny上数据有一点弱. 题目大意输入n,m. 一共有n个字母(从A开始), m行语句每个语句“x﹤y”,说明x,y之间的偏序关系.让你判断是否可以通过这些关系得到一个唯一的升序序列,若能则输出这个序列并指出通过前多少条语句得出的,如果n个字母间存在矛

POJ1094 Sorting It All Out 拓扑排序(深搜)

题意:给定n和m,n表示大写字母的前n个,m表示m个关系对,求能否确定唯一排序. 分析:分三种情况 (1)当输入完当前的关系对之后,已经能确定矛盾(不需要完全输入m个关系对时) eg. 3 3       A<B       B<A         B<C       当输入到第二对已经能判断矛盾,此时记下当前的所需要用到的关系对数ans=2:       接着输入,但是后面的关系对不作处理 (2) 当输入完当前的关系对之后,已经能确定唯一排序(不需要完全输入m个关系对,    但是必须

POJ- 1094 Sorting It All Out---拓扑排序是否唯一的判断

题目链接: https://vjudge.net/problem/POJ-1094 题目大意: 该题题意明确,就是给定一组字母的大小关系判断他们是否能组成唯一的拓扑序列.是典型的拓扑排序,但输出格式上确有三种形式: 1.该字母序列有序,并依次输出: 2.该序列不能判断是否有序(序列不唯一): 3.该序列字母次序之间有矛盾,即有环存在. 思路: 这里应该用Kahn算法拓扑排序 每加入一条边需要进行一次拓扑排序,如果拓扑排序发现有环,或者排序唯一那么就可以直接输出结果,如果所有的边输入完成还不是上述

Sorting It All Out 拓扑排序+确定点

这一道题的话  数据有一点问题    ........     例如 不过 还是   能理解一下  试试吧  ......... 3 5 A<B B<C C<A A<C B<A 这几组数据 明显反映出来 这是成环的 , 然后 按照 输入输出案例来说 这个是 有序的 ABC 题目要求     在每组数据的   第一行  给你需要排序 的 字母数    和  他们之间的关系数量      然后  输入每组数据    你首先许亚萍判断在输入  第几组 数据的时候 出现了 环    

nyoj Sorting It All Out (拓扑排序)

三种情况分别是: 1. 在某位置可以确定拓扑排序. 2. 在某位置出现了环 3. 到最后都不能确定拓扑排序(某一位置入度为0的点有多个),可以续输入执行下去. 每输入一组数据都要做一次判断 1 #include<cstdio> 2 #include<cstring> 3 #include<vector> 4 #include<queue> 5 using namespace std; 6 const int N = 105; 7 int n, m, in[N

POJ 1094 Sorting It All Out 拓扑排序

Sorting It All Out Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%lld & %llu Description An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to

zoj 1060 Sorting It All Out(拓扑排序)

#include<bits/stdc++.h> using namespace std; vector< vector<char> >v; int n,m,use[30],cnt[30]; char ans[30],s[10]; int topsort(int x) { int i,j,t[30],f=1,r,c; memset(ans,0,sizeof(ans)); for(i=0; i<30; i++) t[i]=cnt[i]; c=0; r=0; while

Sorting It All Out (拓扑排序+思维)

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this pro

[ACM] POJ 1094 Sorting It All Out (拓扑排序)

Sorting It All Out Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 26801   Accepted: 9248 Description An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from sm

POJ1094 拓扑排序

问题:POJ1094 本题考查拓扑排序算法 拓扑排序: 1)找到入度为0的点,加入已排序列表末尾: 2)删除该点,更新入度数组. 循环1)2)直到 1. 所有点都被删除,则找到一个拓扑排序: 2. 或剩余结点中没有入度为0的点,则原图中必存在环. 本题算法 1.依次输入一组关系 对当前关系进行拓扑排序 1)若存在环,则无法排序 2)若根据当前关系,每次循环都唯一的确定入度为0的点,则存在排序 2.若输完所有的大小关系之后,仍然没有确定大小排序,也没有发现回环,则排序无法唯一确定 AC代码: 1