HDU 2122 Ice_cream’s world III【最小生成树】

解题思路:基础的最小生成树
反思:不明白为什么i从1开始取,就一直WA,难道是因为村庄的编号是从0开始的吗

Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1032    Accepted Submission(s): 335

Problem Description

ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.

Input

Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.

Output

If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.

Sample Input

2 1 0 1 10 4 0

Sample Output

10 impossible

Author

Wiskey

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int pre[10010];
struct Edge
{

    int u,v,w;
} edge[10010];
bool cmp(Edge n1,Edge n2)
{
   return n1.w<n2.w;
}
int find(int root)
{
   return root == pre[root] ? root : pre[root] = find(pre[root]);
}
int unionroot(int x,int y)
{
	int root1=find(x);
	int root2=find(y);
	if(root1==root2)
	return 0;
	pre[root1]=root2;
	return 1;
}
int main()
{
    int n,m,i,j,tmp,x,y,ans;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
    	tmp=0;
    	ans=0;
        for(i=0;i<=10010;i++)
        pre[i]=i;
        for(i=0;i<m;i++)
        scanf("%d %d %d",&edge[i].u,&edge[i].v,&edge[i].w);

        sort(edge,edge+m,cmp);
        for(i=0;i<m;i++)
        {
        	x=find(edge[i].u);
        	y=find(edge[i].v);
        	if(unionroot(x,y))
        	{
        		ans+=edge[i].w;
        		tmp++;
        	}
        }
        if(tmp!=n-1)
        printf("impossible\n");
        else
        printf("%d\n",ans);
		printf("\n");
    }
}

  

时间: 2024-08-04 22:01:44

HDU 2122 Ice_cream’s world III【最小生成树】的相关文章

hdu 2122 Ice_cream’s world III(最小生成树)

感觉就是 畅通工程的改版 直接贴代码了 #include<stdio.h> #include<string.h> #include<math.h> #include<iostream> #include<algorithm> #include<queue> #include<stack> #define mem(a,b) memset(a,b,sizeof(a)) #define ll __int64 #define MA

HDU - 2122 Ice_cream’s world III

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=2122 最小生成树问题,可采用Kruskal算法,贪心策略,每次选取无向带权图的最短边,并把两端点用 并查集的方式添加到一个集合内. 1 #include<stdio.h> 2 #include<string.h> 3 #include<algorithm> 4 const int maxn=1000+5,maxm=10000+10; 5 int u[maxm],v[maxm

hdoj 2122 Ice_cream’s world III 【最小生成树】

Ice_cream's world III Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1254    Accepted Submission(s): 414 Problem Description ice_cream's world becomes stronger and stronger; every road is buil

hdoj 2122 Ice_cream’s world III【最小生成树】

Ice_cream's world III Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1237    Accepted Submission(s): 408 Problem Description ice_cream's world becomes stronger and stronger; every road is buil

hdoj 2122 Ice_cream’s world III

并查集+最小生成树 Ice_cream’s world III Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1121    Accepted Submission(s): 365 Problem Description ice_cream’s world becomes stronger and stronger; every roa

Ice_cream’s world III//最小生成树kruskal

题目: Ice_cream's world III Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2566    Accepted Submission(s): 904 Problem Description ice_cream's world becomes stronger and stronger; every road is b

hdu 2122(Ice_cream’s world III)(最小生成树,两种算法都可以)

Ice_cream's world III Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 926    Accepted Submission(s): 303 Problem Description ice_cream's world becomes stronger and stronger; every road is built

HDU2122 Ice_cream’s world III 【最小生成树】

Ice_cream's world III Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 802    Accepted Submission(s): 274 Problem Description ice_cream's world becomes stronger and stronger; every road is built

HDU2122 Ice_cream’s world III【Kruskal】

Ice_cream's world III Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 997    Accepted Submission(s): 321 Problem Description ice_cream's world becomes stronger and stronger; every road is built