ACM培训 Robot Motion

Description


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are
N north (up the page)        S south (down the page)        E east (to the right on the page)        W west (to the left on the page)       
For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.       
Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.       
You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

AC代码:

#include<stdio.h>
int move[4][2]={{0,1},{0,-1},{-1,0},{1,0}};
int turn(char w)
{
    if(w==‘N‘)
        return 2;
    if(w==‘E‘)
        return 0;
    if(w==‘S‘)
        return 3;
    return 1;
}
int main()
{
    char grid[100][100];
    int m,n,x,y,tx,ty,start_N;

    while(scanf("%d%d",&m,&n)!=EOF){
        int book[100][100]={0};
        if(m==0&&n==0)
            return 0;
        scanf("%d",&start_N);
        int step=0,loop,flag=0;
        for(int i=0;i<m;i++)
            scanf("%s",grid[i]);
        x=0,y=start_N-1;
        while(1){
            if(x==0&&y==start_N-1&&book[x][y]==0)
                book[x][y]=1;
            tx=x+move[turn(grid[x][y])][0];
            ty=y+move[turn(grid[x][y])][1];
            if(tx>=m||ty>=n||tx<0||ty<0){
                step=book[x][y];
                flag=1;
                break;
            }
            else if(book[tx][ty]!=0){
                step=book[tx][ty]-1;
                loop=book[x][y]-step;
                flag=2;
                break;
            }
            book[tx][ty]=book[x][y]+1;
            x=tx,y=ty;
        }
        if(flag==1)
            printf("%d step(s) to exit\n",step);
        else
            printf("%d step(s) before a loop of %d step(s)\n",step,loop);
    }
    return 0;
}
时间: 2024-11-05 18:54:12

ACM培训 Robot Motion的相关文章

ACM题目————Robot Motion

Description A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are N north (up the page) S south (down the page) E east (to t

HDU ACM 1035 Robot Motion 简单模拟题

分析:一步步的走,走出矩阵则说明没有环,若走到已经走过的地方,说明有环,按格式输出结果,OK. #include<iostream> using namespace std; #define N 15 int dir[4][2]={-1,0,1,0,0,-1,0,1}; char map[N][N]; int vis[N][N]; char ch[]="NSWE"; int n,m; int id(char c) { int i; for(i=0;i<4;i++) i

[ACM] hdu 1035 Robot Motion (模拟或DFS)

Robot Motion Problem Description A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are N north (up the page) S south (down t

poj1573&amp;&amp;hdu1035 Robot Motion(模拟题)

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents 题目链接: HDU:http://acm.hdu.edu.cn/showproblem.php?pid=1035 POJ:   http://poj.org/problem?id=1573 Description A robot has been programmed to follow the instructions in its path. Instructions for

hdoj 1035 Robot Motion

Robot Motion Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 7974    Accepted Submission(s): 3685 Problem Description A robot has been programmed to follow the instructions in its path. Instruct

POJ 1573 Robot Motion 搜索

Robot Motion Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6297    Accepted Submission(s): 2952 Problem Description A robot has been programmed to follow the instructions in its path. Instruc

hdu1035 Robot Motion (DFS)

Robot Motion Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8180    Accepted Submission(s): 3771 Problem Description A robot has been programmed to follow the instructions in its path. Instruc

poj1573 Robot Motion

题目链接: http://poj.org/problem?id=1573 题目: Robot Motion Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 10202   Accepted: 4971 Description A robot has been programmed to follow the instructions in its path. Instructions for the next direct

HDOJ1035 Robot Motion 【模拟】

Robot Motion Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6079    Accepted Submission(s): 2844 Problem Description A robot has been programmed to follow the instructions in its path. Instruc