hdu 1045 Fire Net DFS入门题

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7012    Accepted Submission(s): 3975

Problem Description

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least
one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses
in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city;
n will be at most 4. The next n lines each describe one row of the map, with a ‘.‘ indicating an open space and an uppercase ‘X‘ indicating a wall. There are no spaces in the input file.

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample Input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample Output

5
1
5
2
4

没什么好解释的,就是暴力搜索。数据 小,不会超时

代码:

#include <stdio.h>
#include <string.h>
int n;
char map[5][5] ;
bool visited[5][5] ;
int dir[4][2] = {1,0,-1,0,0,-1,0,1} ;

bool isTrue(int x , int y)
{
	if(x<0||y<0 || x>=n||y>=n )
	{
		return false ;
	}
	return true ;
}

bool judge(int x , int y)
{

	int mid = x-1 ;
	while(mid>=0)
	{
		if(map[mid][y]=='*')
		{
			return false ;
		}
		else if(map[mid][y]=='X')
		{
			break ;
		}
		mid-- ;
	}
	mid = x+1 ;
	while(mid<n)
	{
		if(map[mid][y]=='*')
		{
			return false ;
		}
		else if(map[mid][y]=='X')
		{
			break ;
		}
		mid++ ;
	}
	mid = y-1 ;
	while(mid>=0)
	{
		if(map[x][mid]=='*')
		{
			return false ;
		}
		else if(map[x][mid]=='X')
		{
			break ;
		}
		mid-- ;
	}
	mid = y+1 ;
	while(mid<n)
	{
		if(map[x][mid]=='*')
		{
			return false ;
		}
		else if(map[x][mid]=='X')
		{
			break ;
		}
		mid++ ;
	}
	return true ;
}
int ans = 0 ;
void DFS(int pos , int c)
{
	int x = pos/n , y = pos%n ;
	if(c>ans)
	{
		ans = c ;
	}
	for(int i = 0 ; i < 4 ; ++i)
	{
		int nextx = x+dir[i][0] , nexty = y + dir[i][1] ;
		if(visited[nextx][nexty]||!isTrue(nextx,nexty))
		{
			continue ;
		}
		if(judge(nextx,nexty) && map[nextx][nexty]!='X')
		{
			map[nextx][nexty] = '*' ;
			visited[nextx][nexty] = true ;
			DFS(nextx*n+nexty,c+1);
			visited[nextx][nexty] = false ;
			map[nextx][nexty] = '.' ;
		}
		else
		{
			visited[nextx][nexty] = true ;
			DFS(nextx*n+nexty,c);
			visited[nextx][nexty] = false ;
		}
	}
}

int main()
{
	while(~scanf("%d",&n) && n)
	{
		for(int i = 0 ; i < n ; ++i)
		{
			scanf("%s",map[i]) ;
		}
		memset(visited,false,sizeof(visited)) ;
		ans = 0 ;
		for(int i = 0 ; i < n*n ; i++)
		{
			if(map[i/n][i%n]=='.')
			{
				map[i/n][i%n] = '*' ;
				visited[i/n][i%n] = true ;
				DFS(i,1) ;
				visited[i/n][i%n] = false ;
				map[i/n][i%n] = '.' ;
			}
		}
		printf("%d\n",ans) ;
	}
	return 0 ;
}

与君共勉

时间: 2024-11-01 04:23:00

hdu 1045 Fire Net DFS入门题的相关文章

HDU 1045 Fire Net(DFS)

Fire Net Problem Description Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. A blockhouse is a small castle that has four openings t

HDU 1045 - Fire Net (最大独立集)

题意:给你一个正方形棋盘.每个棋子可以直线攻击,除非隔着石头.现在要求所有棋子都不互相攻击,问最多可以放多少个棋子. 这个题可以用搜索来做.每个棋子考虑放与不放两种情况,然后再判断是否能互相攻击来剪枝.最后取可以放置的最大值. 这里我转化成求最大独立集来做. 首先将每个空地编号,对于每个空地,与该位置可以攻击到的空地连边.找最多的空地使得不互相攻击,即求该图的最大独立集.与搜索做法基本一致,但是说法略有不同. 1 #include<iostream> 2 #include<cstring

Oil Deposits(poj 1526 DFS入门题)

http://poj.org/problem?id=1562 Oil Deposits Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 12595   Accepted: 6868 Description The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp wor

HDU 1045 Fire Net 贪心

Problem Description Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. A blockhouse is a small castle that has four openings through wh

HDU 1045 Fire Net(dfs,跟8皇后问题很相似)

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1045 Fire Net Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 14670    Accepted Submission(s): 8861 Problem Description Suppose that we have a squar

hdu 1045 Fire Net(最小覆盖点+构图(缩点))

http://acm.hdu.edu.cn/showproblem.php?pid=1045 Fire Net Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 1045 Description Suppose that we have a square city with straight streets. A map of a city

hdu 2767 Proving Equivalences(强连通入门题)

1 /************************************************* 2 Proving Equivalences(hdu 2767) 3 强连通入门题 4 给个有向图,求至少加多少条边使得图是所有点都是强连通的 5 由a->b->c->a易知n个点至少要n条边,每个出度和入度都要大 6 于1.先求所有所有强连通分量,把每个强连通分量看成一个点 7 在找每个点的出度和入度,最后还差的出度和入度的最大值就是 8 答案. 9 10 ************

HDU 1045 Fire Net 状压暴力

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1045 Fire Net Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 8073    Accepted Submission(s): 4626 Problem Description Suppose that we have a squar

HDU 1045——Fire Net——————【最大匹配、构图、邻接矩阵做法】

Fire Net Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 1045 Description Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, e