POJ1308——Is It A Tree?

Is It A Tree?

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 22631   Accepted: 7756

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist
of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

Source

判断一些点形成的结构是否是一棵树,坑点好多,用并查集判断连通支数以及环,判断每个点的入度,判断是否有自己连向自己的边

#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

int father[100010];
bool vis[100010];
int in_deg[100010];

int find(int x)
{
    if (father[x] == -1)
    {
        return x;
    }
    return father[x] = find(father[x]);
}

void init()
{
    memset( father, -1, sizeof(father));
    memset( vis, 0, sizeof(vis));
    memset(in_deg, 0, sizeof(in_deg));
}

int main()
{
    int x, y;
    int icase = 1;
    while (~scanf("%d%d", &x, &y))
    {
        if (x == -1 && y == -1)
        {
            break;
        }
        if (x == 0 && y == 0)
        {
            printf("Case %d is a tree.\n", icase++);
            continue;
        }
        init();
        map<int, int> bianhao;
        bianhao.clear();
        int cnt = 0;
        bool flag = true;
        while (x && y)
        {
            if (!x && !y)
            {
                break;
            }
            if (x == y)
            {
                flag = false;
            }
            if (flag && !vis[x])
            {
                vis[x] = 1;
                bianhao[x] = ++cnt;
            }
            if (flag && !vis[y])
            {
                vis[y] = 1;
                bianhao[y] = ++cnt;
            }
            if (flag)
            {
                int a = find(bianhao[x]);
                int b = find(bianhao[y]);
                if (a == b)
                {
                    flag = false;
                }
                father[a] = b;
                in_deg[bianhao[y]]++;
            }
            scanf("%d%d", &x, &y);
        }
        if (!flag)
        {
            printf("Case %d is not a tree.\n", icase++);
            continue;
        }
        int ans = 0;
        // for (int i = 1; i <= cnt; ++i)
        // {
            // printf("%d ", in_deg[i]);
        // }
        for (int i = 1; i <= cnt; ++i)
        {
            if (in_deg[i] == 0)
            {
                ans++;
            }
            if (ans >= 2)
            {
                break;
            }
            if (in_deg[i] >= 2)
            {
                flag = false;
                break;
            }
        }
        if (ans >= 2 || !flag)
        {
            printf("Case %d is not a tree.\n", icase++);
            continue;
        }
        printf("Case %d is a tree.\n", icase++);
    }
    return 0;
}
时间: 2024-08-01 00:15:54

POJ1308——Is It A Tree?的相关文章

poj1308 Is It A Tree?(并查集)详解

poj1308   http://poj.org/problem?id=1308 题目大意:输入若干组测试数据,输入 (-1 -1) 时输入结束.每组测试数据以输入(0 0)为结束标志.然后根据所给的所有(父亲, 孩子)数据对判断 是否能构成一棵树. 分析: 都以了解树只有一个根节点,那么我们就判断是不是有多个树:又知道每个节点只有一个父亲节点,那么我们就判断他是不是构成环,成环则不是树. 注意: ①可以是空树: ②所给的节点构成森林(多个树)是不可以的,必须只能构成一棵树. #include<

hdu-1325 &amp; poj-1308 Is It A Tree?

http://acm.hdu.edu.cn/showproblem.php?pid=1325 题意: 判断一个图是不是说树 只有树的根入度为 0 ,其余结点入度均为 1; Is It A Tree? Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 15503    Accepted Submission(s): 3443 Problem

POJ1308 Is It A Tree?

题目大意:和HDU1272-小希的迷宫题目一样, 如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路).小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路.比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8.  Input 输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号.房间的编号至少为1,

hdu1325is it a tree?&amp;&amp;poj1308 is it a tree?(并查集)

题目链接: huangjing||huangjing 建议做hdu上的这个题,因为poj上面的数据很弱,就是因为只做了poj上面的导致我在一次比赛中一直wa到比赛结束,因为比赛的那次挂的是hdu上的题... 题意: 判断由给出的数据得到的是否是一棵树... 思路: 这个题有几个要注意的地方. [1]首先一棵树只能有一个入度为0的点即根节点..所以根节点唯一.. [2]除根节点外其他点的入度均为1. 题目: Language: Default Is It A Tree? Time Limit: 1

POJ1308 Is It A Tree? (easy but...)

Description A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. There is exactly one node, called the root, t

HDU-1325&amp;&amp;POJ-1308 Is It A Tree?(基础并查集)

Is It A Tree? Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 26976    Accepted Submission(s): 6213 Problem Description A tree is a well-known data structure that is either empty (null, void, no

POJ-1308 Is It A Tree?(并查集判断是否是树)

http://poj.org/problem?id=1308 Description A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.There is exactl

题单二:图论500

http://wenku.baidu.com/link?url=gETLFsWcgddEDRZ334EJOS7qCTab94qw5cor8Es0LINVaGMSgc9nIV-utRIDh--2UwRLvsvJ5tXFjbdpzbjygEdpGehim1i5BfzYgYWxJmu ==========  以下是最小生成树+并查集=========================[HDU]1213         How Many Tables        基础并查集★1272         小

图论五百题!

生死看淡不服就淦,这才是人生! =============================以下是最小生成树+并查集======================================[HDU]1213 How Many Tables 基础并查集★1272 小希的迷宫 基础并查集★1325&&poj1308 Is It A Tree? 基础并查集★1856 More is better 基础并查集★1102 Constructing Roads 基础最小生成树★1232 畅通工程 基