hdoj 1008 Elevator

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 49406    Accepted Submission(s):
27244

Problem Description

The highest building in our city has only one elevator.
A request list is made up with N positive numbers. The numbers denote at which
floors the elevator will stop, in specified order. It costs 6 seconds to move
the elevator up one floor, and 4 seconds to move down one floor. The elevator
will stay for 5 seconds at each stop.

For a given request list, you are
to compute the total time spent to fulfill the requests on the list. The
elevator is on the 0th floor at the beginning and does not have to return to the
ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a
positive integer N, followed by N positive numbers. All the numbers in the input
are less than 100. A test case with N = 0 denotes the end of input. This test
case is not to be processed.

Output

Print the total time on a single line for each test
case.

Sample Input

1 2

3 2 3 1

0

Sample Output

17

41

#include<stdio.h>
int main()
{
	int n,m,j,i,l,t,sum;
	int a[110];
	while(scanf("%d",&n)&&n!=0)
	{
		m=0;sum=0;
		a[0]=0;
		for(i=1;i<=n;i++)
		{
		    scanf("%d",&a[i]);
		    if(a[i]>m)    //上楼的情况
		    {
		    	sum+=(a[i]-a[i-1])*6+5;
		    	m=a[i];
		    }
		    else if(a[i]<m)  //下楼的情况
		    {
		    	sum+=(m-a[i])*4+5;
		    	m=a[i];
		    }
		    else if(a[i]==m)  //在相同楼层的问题
		    {
		    	sum+=5;
		    	m=a[i];
		    }
		}
		printf("%d\n",sum);
	}
	return 0;
}

  

时间: 2024-08-01 02:20:31

hdoj 1008 Elevator的相关文章

1008. Elevator (20)——PAT (Advanced Level) Practise

题目信息: 1008. Elevator (20) 时间限制 400 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator w

Programming Ability Test学习 1008. Elevator (20)

1008. Elevator (20) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will st

杭电 1008 Elevator

杭电ACM 2014暑期集训队--选拔安排~ Elevator Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 40905    Accepted Submission(s): 22387 Problem Description The highest building in our city has only one elevator

甲级1008 Elevator

1008 Elevator (20 分) The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up

[PTA] PAT(A) 1008 Elevator (20 分)

目录 Problem Description Input Output Sample Sample Input Sample Output Solution Analysis Code Problem portal: 1008 Elevator (20 分) Description  The highest building in our city has only one elevator. A request list is made up with $N$ positive numbers

【PAT甲级】1008 Elevator (20分)

1008 Elevator 题目: The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one

1008 Elevator (20分)

1008 Elevator (20分) 题目: The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator

Elevator(hdoj 1008)

Problem Description The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up o

HDOJ 1008

Elevator Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 25560 Accepted Submission(s): 13793 Problem Description The highest building in our city has only one elevator. A request list is made up w