HDU5024 Wang Xifeng's Little Plot 【记忆化搜索】

Wang Xifeng‘s Little Plot

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 319    Accepted Submission(s): 214

Problem Description

《Dream of the Red Chamber》(also 《The Story of the Stone》) is one of the Four Great Classical Novels of Chinese literature, and it is commonly regarded as the best one. This novel was created in Qing Dynasty, by Cao Xueqin. But the
last 40 chapters of the original version is missing, and that part of current version was written by Gao E. There is a heart breaking story saying that after Cao Xueqin died, Cao‘s wife burned the last 40 chapter manuscript for heating because she was desperately
poor. This story was proved a rumor a couple of days ago because someone found several pages of the original last 40 chapters written by Cao.

In the novel, Wang Xifeng was in charge of Da Guan Yuan, where people of Jia family lived. It was mentioned in the newly recovered pages that Wang Xifeng used to arrange rooms for Jia Baoyu, Lin Daiyu, Xue Baochai and other teenagers. Because Jia Baoyu was
the most important inheritor of Jia family, and Xue Baochai was beautiful and very capable , Wang Xifeng didn‘t want Jia Baoyu to marry Xue Baochai, in case that Xue Baochai might take her place. So, Wang Xifeng wanted Baoyu‘s room and Baochai‘s room to be
located at two ends of a road, and this road should be as long as possible. But Baoyu was very bad at directions, and he demanded that there could be at most one turn along the road from his room to Baochai‘s room, and if there was a turn, that turn must be
ninety degree. There is a map of Da Guan Yuan in the novel, and redists (In China English, one whose job is studying 《Dream of the Red Chamber》is call a "redist") are always arguing about the location of Baoyu‘s room and Baochai‘s room. Now you can solve this
big problem and then become a great redist.

Input

The map of Da Guan Yuan is represented by a matrix of characters ‘.‘ and ‘#‘. A ‘.‘ stands for a part of road, and a ‘#‘ stands for other things which one cannot step onto. When standing on a ‘.‘, one can go to adjacent ‘.‘s through
8 directions: north, north-west, west, south-west, south, south-east,east and north-east.

There are several test cases.

For each case, the first line is an integer N(0<N<=100) ,meaning the map is a N × N matrix.

Then the N × N matrix follows.

The input ends with N = 0.

Output

For each test case, print the maximum length of the road which Wang Xifeng could find to locate Baoyu and Baochai‘s rooms. A road‘s length is the number of ‘.‘s it includes. It‘s guaranteed that for any test case, the maximum length
is at least 2.

Sample Input

3
#.#
##.
..#
3
...
##.
..#
3
...
###
..#
3
...
##.
...
0

Sample Output

3
4
3
5

Source

2014 ACM/ICPC Asia Regional Guangzhou Online

题意:在给定图中‘.‘为空地,空地上的点可以往八个方向走(左0,左上1,上2,右上3..)在最多只能有一次拐弯且拐弯只能为直角的情况下求合法路径的最长距离。

题解:以该直角为关键进行枚举分两条直角边搜索下去。

#include <stdio.h>
#include <string.h>
#define maxn 102

char map[maxn][maxn];
int dist[maxn][maxn][8], n;
int dir[8][2] = {0, -1, -1, -1, -1, 0, -1, 1,
                 0, 1, 1, 1, 1, 0, 1, -1};

int DFS(int x, int y, int dire) {
    if(dist[x][y][dire]) return dist[x][y][dire];
    if(x < 0 || y < 0 || x >= n || y >= n || map[x][y] == '#')
        return 0;
    return dist[x][y][dire] = 1 + DFS(x + dir[dire][0], y + dir[dire][1], dire);
}

int main(int argc, char *argv[]) {
    int i, j, k, ans, tmp;
    while(scanf("%d", &n), n) {
        for(i = 0; i < n; ++i)
            scanf("%s", map[i]);
        memset(dist, 0, sizeof(dist));
        for(i = ans = 0; i < n; ++i)
            for(j = 0; j < n; ++j)
                if(map[i][j] == '.') {
                    tmp = DFS(i, j, 0) + DFS(i, j, 2);
                    if(tmp > ans) ans = tmp;
                    tmp = DFS(i, j, 0) + DFS(i, j, 6);
                    if(tmp > ans) ans = tmp;
                    tmp = DFS(i, j, 1) + DFS(i, j, 3);
                    if(tmp > ans) ans = tmp;
                    tmp = DFS(i, j, 1) + DFS(i, j, 7);
                    if(tmp > ans) ans = tmp;
                    tmp = DFS(i, j, 2) + DFS(i, j, 4);
                    if(tmp > ans) ans = tmp;
                    tmp = DFS(i, j, 3) + DFS(i, j, 5);
                    if(tmp > ans) ans = tmp;
                    tmp = DFS(i, j, 4) + DFS(i, j, 6);
                    if(tmp > ans) ans = tmp;
                    tmp = DFS(i, j, 5) + DFS(i, j, 7);
                    if(tmp > ans) ans = tmp;
                }
        printf("%d\n", ans - 1);
    }
    return 0;
}

HDU5024 Wang Xifeng's Little Plot 【记忆化搜索】

时间: 2024-11-09 05:57:39

HDU5024 Wang Xifeng's Little Plot 【记忆化搜索】的相关文章

HDU 5024 (广州网络赛) Wang Xifeng&#39;s Little Plot 记忆化搜索+枚举

Problem Description <Dream of the Red Chamber>(also <The Story of the Stone>) is one of the Four Great Classical Novels of Chinese literature, and it is commonly regarded as the best one. This novel was created in Qing Dynasty, by Cao Xueqin.

HDU5024Wang Xifeng&#39;s Little Plot(记忆化搜索)

HDU5024Wang Xifeng's Little Plot(记忆化搜索) 题目链接 题目大意:给一张地图,#代表不能走的位置,.代表可以走的位置.现在要求找一条最长的路径,并且拐弯最多只能有一个并且还要是90度的. 解题思路:记忆化搜索,dp[x][y][k][d] : x, y 代表坐标,k代表拐了k次90弯,d代表方向.因为这里最多只能转一次弯,而且还必须是90度的,那么就不可能走重复的路了. 代码: #include <cstdio> #include <cstring>

hdu5024 Wang Xifeng&#39;s Little Plot (水

http://acm.hdu.edu.cn/showproblem.php?pid=5024 网络赛 Wang Xifeng's Little Plot Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 239    Accepted Submission(s): 156 Problem Description <Dream of the

HDU 5024 Wang Xifeng&#39;s Little Plot (枚举 + DFS记忆化搜索)

Wang Xifeng's Little Plot Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 513    Accepted Submission(s): 338 Problem Description <Dream of the Red Chamber>(also <The Story of the Stone>)

2014 ACM/ICPC Asia Regional Guangzhou Online Wang Xifeng&#39;s Little Plot HDU5024

一道好枚举+模拟题目.转换思维视角 这道题是我做的,规模不大N<=100,以为正常DFS搜索,于是傻乎乎的写了起来.各种条件限制模拟过程 但仔细一分析发现对每个点进行全部八个方向的遍历100X100X100^8 .100X100个点,每个点在走的时候8中选择,TLE 于是改为另一个角度: 以符合要求的点为拐弯点,朝两个垂直的方向走,求出最远的距离.这样只要对每个点各个方向的长度知道,组合一下对应的就OK. 避免了每个点深搜. PS:搜索的时候x,y写反了,导致构图出现问题,以后用[dy][dx]

hdu 5024 Wang Xifeng&#39;s Little Plot【暴力dfs,剪枝】

2014年广州网络赛的C题,也是水题.要你在一个地图中找出一条最长的路,这条路要保证最多只能有一个拐角,且只能为90度 我们直接用深搜,枚举每个起点,每个方向进行dfs,再加上剪枝. 但是如果直接写的话,那一定会特别麻烦,再加上方向这一属性也是我们需要考虑的方面,我们将从别的地方到当前点的方向编一个号:往右为0,如下图顺时针顺序编号 (往右下方向为1,往下为2......以此类推) 我们知道了当前点的坐标,来到当前点的方向,以及到目前有没有拐弯,这几个属性之后,就可以记忆化搜索了,用一个四维数组

HDU - 5024 Wang Xifeng&#39;s Little Plot

Problem Description <Dream of the Red Chamber>(also <The Story of the Stone>) is one of the Four Great Classical Novels of Chinese literature, and it is commonly regarded as the best one. This novel was created in Qing Dynasty, by Cao Xueqin.

HDU 5024 Wang Xifeng&#39;s Little Plot(广州网络赛C题)

HDU 5024 Wang Xifeng's Little Plot 题目链接 思路:先利用记忆化搜索预处理出每个结点对应8个方向最远能走多远,然后枚举拐点记录最大值即可 代码: #include <cstdio> #include <cstring> #include <algorithm> using namespace std; const int d[8][2] = {{-1, 0}, {0, 1}, {1, 0}, {0, -1}, {-1, 1}, {1,

HDU 5024 Wang Xifeng&#39;s Little Plot (DP)

题意:给定一个n*m的矩阵,#表示不能走,.表示能走,让你求出最长的一条路,并且最多拐弯一次且为90度. 析:DP,dp[i][j][k][d] 表示当前在(i, j)位置,第 k 个方向,转了 d 次变的最多次数,然后用记忆化搜索就好. 代码如下: #pragma comment(linker, "/STACK:1024000000,1024000000") #include <cstdio> #include <string> #include <cs