MPLS VPN Case1

如下图示:

实验目标:CE1和CE2的Loopback0互通。
实验环境:
1.P、PE1和PE2是运营商路由器。CE1和CE2是VPN用户。
2.P、PE1和PE2运行OSPF 进程号1 Area 0。
3.PE1和PE2为iBGP AS 1。
4.CE1和CE2采用RIP V2。

实验步骤:
1.在P、PE1和PE2路由器启用ip cef。
2.在P、PE1和PE2路由器的互连接口启用mpls ip
3.在P、PE1和PE2配置ospf 1。
4.查看mpls vpn相关命令:
show mpls ldp neighbor
show mpls interface
show mpls forwarding-table
5.在PE路由器启用ip vrf、配置rd、在与CE相连接口启用ip vrf forwading和RIP路由
6.在PE1和PE2上配置iBGP、Address-family vpnv4的配置。
7.在PE1和PE2配置bgp和RIP相互间双向路由重分布。
8.在CE1和CE2配置loopback0和相连PE的接口,RIP V2配置。
9.在CE1 ping 5.5.5.5 source 4.4.4.4,在CE2 ping 4.4.4.4 source 5.5.5.5。

P、PE1和PE2 三位一体MPLS VPN主体OSPF贯通。
P:
ip cef
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
interface FastEthernet0/0
 ip address 12.1.1.1 255.255.255.0
 mpls ip
 no sh
interface FastEthernet0/1
 ip address 13.1.1.1 255.255.255.0
 mpls ip
 no sh
router ospf 1
 router-id 1.1.1.1
 network 1.1.1.1 0.0.0.0 area 0
 network 12.1.1.0 0.0.0.255 area 0
 network 13.1.1.0 0.0.0.255 area 0
PE1:
ip cef
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
interface FastEthernet0/0
 ip address 12.1.1.2 255.255.255.0
 mpls ip
 no sh
router ospf 1
 router-id 2.2.2.2
 network 2.2.2.2 0.0.0.0 area 0
 network 12.1.1.0 0.0.0.255 area 0
PE2:
ip cef
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
interface FastEthernet0/1
 ip address 13.1.1.3 255.255.255.0
 mpls ip
 no sh
router ospf 1
 router-id 3.3.3.3
 network 3.3.3.3 0.0.0.0 area 0
 network 13.1.1.0 0.0.0.255 area 0
用户VRF配置:
PE1:
ip vrf apple
 rd 45.1.1.2:45         //每个PE的rd和route-target是一样的。
 route-target export 45.1.1.2:45
 route-target import 45.1.1.2:45
interface FastEthernet0/1
 ip vrf forwarding apple
 ip address 24.1.1.2 255.255.255.0
 no sh
router rip
 version 2
 address-family ipv4 vrf apple
 network 24.0.0.0
PE2:
ip vrf apple
 rd 45.1.1.2:45         //每个PE的rd和route-target是一样的。
 route-target export 45.1.1.2:45
 route-target import 45.1.1.2:45
interface FastEthernet0/1
 ip vrf forwarding apple
 ip address 35.1.1.3 255.255.255.0
 no sh
router rip
 version 2
 address-family ipv4 vrf apple
 network 35.0.0.0
PE1和PE2之间的iBGP配置:
PE1:
router bgp 1
 bgp router-id 2.2.2.2
 neighbor 3.3.3.3 remote-as 1
 neighbor 3.3.3.3 update-source Loopback0
 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community both
PE2:
router bgp 1
 bgp router-id 3.3.3.3
 neighbor 2.2.2.2 remote-as 1
 neighbor 2.2.2.2 update-source Loopback0
 address-family vpnv4
  neighbor 2.2.2.2 activate
  neighbor 2.2.2.2 send-community both
BGP和RIP双向路由重分发
PE1:
router rip
 address-family ipv4 vrf apple
  redistribute bgp 1 metric transparent
router bgp 1
 address-family ipv4 vrf apple
  redistribute rip
PE2:
router rip
 address-family ipv4 vrf apple
  redistribute bgp 1 metric transparent
router bgp 1
 address-family ipv4 vrf apple
  redistribute rip
CE1和CE2配置
CE1:
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
interface FastEthernet0/1
 ip address 24.1.1.4 255.255.255.0
 no sh
router rip
 version 2
 network 4.0.0.0
 network 24.0.0.0
CE2:
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
interface FastEthernet0/0
 ip address 35.1.1.5 255.255.255.0
 no sh
router rip
 version 2
 network 5.0.0.0
 network 35.0.0.0
为了实验的完整性,特把P、PE1和PE2的完整配置一次性show出来供大家查对。
P:
ip cef
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
interface FastEthernet0/0
 ip address 12.1.1.1 255.255.255.0
 mpls ip
 no sh
interface FastEthernet0/1
 ip address 13.1.1.1 255.255.255.0
 mpls ip
 no sh
router ospf 1
 router-id 1.1.1.1
 network 1.1.1.1 0.0.0.0 area 0
 network 12.1.1.0 0.0.0.255 area 0
 network 13.1.1.0 0.0.0.255 area 0
PE1:
hostname PE1
ip cef
ip vrf apple
 rd 45.1.1.2:45
 route-target export 45.1.1.2:45
 route-target import 45.1.1.2:45
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
interface FastEthernet0/0
 ip address 12.1.1.2 255.255.255.0
 mpls ip
 no sh
interface FastEthernet0/1
 ip vrf forwarding apple
 ip address 24.1.1.2 255.255.255.0
 no sh
router ospf 1
 router-id 2.2.2.2
 network 2.2.2.2 0.0.0.0 area 0
 network 12.1.1.0 0.0.0.255 area 0
router rip
 version 2
 address-family ipv4 vrf apple
  redistribute bgp 1 metric transparent
  network 24.0.0.0
router bgp 1
 no synchronization
 bgp router-id 2.2.2.2
 neighbor 3.3.3.3 remote-as 1
 neighbor 3.3.3.3 update-source Loopback0
 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community both
 address-family ipv4 vrf apple
  redistribute rip
PE2:
hostname PE2
ip cef
ip vrf apple
 rd 45.1.1.2:45
 route-target export 45.1.1.2:45
 route-target import 45.1.1.2:45
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
interface FastEthernet0/0
 ip vrf forwarding apple
 ip address 35.1.1.3 255.255.255.0
 no sh
interface FastEthernet0/1
 ip address 13.1.1.3 255.255.255.0
 mpls ip
 no sh
router ospf 1
 router-id 3.3.3.3
 network 3.3.3.3 0.0.0.0 area 0
 network 13.1.1.0 0.0.0.255 area 0
router rip
 version 2
 address-family ipv4 vrf apple
  redistribute bgp 1 metric transparent
  network 35.0.0.0
router bgp 1
 bgp router-id 3.3.3.3
 neighbor 2.2.2.2 remote-as 1
 neighbor 2.2.2.2 update-source Loopback0
 address-family vpnv4
  neighbor 2.2.2.2 activate
  neighbor 2.2.2.2 send-community both
 address-family ipv4 vrf apple
  redistribute rip
				
时间: 2024-10-29 10:46:40

MPLS VPN Case1的相关文章

IPv6/IPv4双栈的MPLS VPN——6VPE实战部署(华为和思科大融合)

个人理解,6VPE(IPv6VPN Provider Edge)是承载IPv6的MPLSVPN,是在保持原有MPLS BGPv4骨干不做大变动的情况下,一种IPv6 MPLS VPN过渡技术.基本部署步骤如下:PE与CE之间存在IPv6 VRF,建立BGPv6的邻居关系:PE与RR之间可以建立IPv6的BGP邻居关系,也可以建立IPv4邻居关系,同步复制VPNv4地址族到VPNv6地址族中,其他配置跟IPv4的MPLS VPN没有什么大区别. 以下为实验室测试环境下部署6VPE案例实战分析: 环

BGP/MPLS VPN之总结

一 MPLS技术基础 1.MPLS利用已有的路由信息建立虚连接---基于标签的转发路径,提高了转发效率,在面向无连接的IP网络增加了连接的属性,为IP网络提供了一定Qos保证,满足不同类型服务队Qos的要求. 2.(1)MPLS网络路由器分为两种角色,分别是LSR(标签交换路由器),LER(标签交换边缘路由器) (2)FEC(转发等价类):一组具备某些共同特征的数据流被MPLS网络看做同一类报文,进入MPLS网络时,被LER执行相同的标签映射,从而在整个MPLS网络中被看做是同一种报文,并以等价

MPLS VPN原理及配置思路

VPN中的角色: CE/PE/P overlay vpn:隧道建立在CE上 在ce和ce之间建立隧道,并直接传递路由信息.典型代表是GRE.IPSEC overlay vpn:隧道建立在pe上 在pe上为每一个vpn用户建立相应的GRE隧道,路由信息在pe和pe之间传递. 不同的vpn用户不能共享相同的地址空间,并且需要大量的ACL和策略路由,在实际中不具备可行性 overlay vpn的本质是一种静态vpn 1,所有的配置与部署都需要手工完成 2,由于是静态vpn,则无法反应网络的实时变化 p

MPLS VPN

目标:配置MPLS VPN 配置思路: R3,R5,R6,R4为运营商网络,配置MPLS,IGP协议为ospf 110,R3和R4配置为IBGP邻居,R1和R2为位于两地的同一公司A的子公司,R7和R8同样是位于两地的同一公司B的子公司,在R3上为每个子公司R1,R7启用vrf,并将相关接口加入相应vrf(比如,vrf 1 关连R3的s1/1口),R1与R3之间静态路由,R2与R4之间静态路由,在R4上为每个子公司R2,R8启用vrf,并将相关接口加入相应vrf,R7与R3之间启用ospf 协议

什么是MPLS VPN ?

一.什么是MPLS VPN MPLS VPN是可管理的IP虚拟专用网络服务 (IP VPN),采用先进的多协议标签交换(MPLS)技术,将企业分布在不同地点的办事处及设备通过安全可靠.高效率的虚拟专用网络连接起来,实现数据.语音.视频传输或其他重要网络应用,兼具服务品质(QOS)保证. 二.产品特点 立足用户需求,通过成熟的技术手段,为企业客户提供"一站式"网络应用.信息增值.电子商务服务等数据通信整体解决方案 说明①:MPLS VPN是局域网解决方案,因此主要解决的是企业内部办公和I

MPLS VPN 之CE运行OSPF

实验拓扑图 实验描述:PE-R1.P-R2.PE-R3运行的IGP为OSPF,所属area 0,且运行MPLS,PE-R1.PE-R3配置MP-BGP,CE-R5.CE-R7路由器与PE路由器运行OSPF协议,且属于骨干区域0,配置MPLS VPN实现CE-R5与CE-R7互通: 一.PE-R1与PE-R3对于VRF Ting运行不同的OSPF进程时,对CE端的OSPF路由情况分析 部份配置如下: PE-R1: router ospf 12 vrf Ting redistribute bgp 1

L3 MPLS VPN InterAS Option A: Back-to-Back VRFs

Back-to-Back VRFs 优点: 配置思路简单,跟普通的域内MPLS VPN没有太多区别: 缺点: 在ASBR上需要有各个VRF,需要保存全网的VPNv4路由,ASBR之间需要多个接口分别划进每个VRF里.ASBR负担较重. 配置说明: 端口连接规律:RN E0/0 -- R(N+1)0/1 PE跟CE起OSPF协议,AS内部IGP使用EIGRP,ASBR之间使用RIP协议: CE端R1配置案例: hostname R1 interface Loopback0 ip address 1

MPLS VPN实例配置

需求: R1 R5模拟A公司总分部网关,R6 R7模拟B公司总分部网关, R2 R3 R4模拟公网路由器,在两家公司内部架设MPLS VPN. 公网底层起EIGRP邻居,保证TCP可达. 公网起VPNV4 BGP邻居 R2(config)#router bgp 1 R2(config-router)#no address-family ipv4 R2(config-router)#neighbor 4.4.4.4 remote-as 1 R2(config-router)#nei 4.4.4.4

单域MPLS vpn数据转发实验分析

MPLS VPN数据详细转发流程示意图: 配置思路: 在自治系统AS100中配置IGP,使得两台PE路由器的lo 0接口路由可达: 两台PE路由器路由可达后,在两台PE路由器之间建立MP-iBGP邻居关系,用来传输VPNV4路由: AS100中所有P路由器和PE路由器运行MPLS,并使用LDP来给非BGP路由分发标签: 在PE路由器和CE路由器之间运行ospf路由协议,使得PE路由器的VRF路由表可以学习到CE路由器的路由: 将PE路由器VRF学习到的路由重分发进BGP,使得对端PE路由器可以通