poj 1611~并查集基础

The Suspects

Time Limit: 1000MS   Memory Limit: 20000K
Total Submissions: 33160   Accepted: 16080

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1
#include<iostream>
#include<cstdio>

int pre[30050];

void init(int n)
{
    for(int i=0;i<n;i++)
        pre[i]=i;
}

int find(int x)
{
   if(x==pre[x]) return x;
   int temp=find(pre[x]);
   pre[x]=temp;
   return temp;
}

void Union(int u,int v)
{
    int p=find(u);
    int q=find(v);
    if(p!=q)
        pre[p]=q;
}

int main()
{
    int n,m;
    while(~scanf("%d %d",&n,&m)&&(n||m))
    {
        init(n);
        int a,b,c,d;
        int x;
        while(m--)
        {
            scanf("%d",&x);
            if(x==1) {scanf("%d",&b);continue;}
            else
            {
                scanf("%d",&a);
                x--;
                while(x--)
                {
                    scanf("%d",&b);
                    Union(a,b);
                    a=b;
                }

            }

        }
        int cnt=0;
        int t=find(0);
        for(int i=0;i<n;i++)
        {
            if(find(i)==t) cnt++;  //期初wa是因为这里、、这种路径压缩的写法可能造成不用find函数无法完成对树的非根节点的根节点的更新

        }

        printf("%d\n",cnt);
    }
    return 0;
}

  题目大意是说n个人,m组,只要一个组中一个人得了sars,一个组中其他人也被怀疑、并查集不解释,默认编号为0的人得了sars

时间: 2024-10-09 09:36:01

poj 1611~并查集基础的相关文章

POJ 1611 并查集

23333......简单的并查集模板.就是被并查集递归式路径压缩RE坑过...学习一下非递归式路径压缩. 附代码: #include<stdio.h>#include<iostream>#include<string.h>#define maxn 30100using namespace std; int fa[maxn];int n, m, k; void init(){    for (int i=0; i<=n; ++i)        fa[i] = i

The Suspects POJ - 1611 并查集,同集合的数

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.In the Not-Spread

poj 2524~并查集基础

Ubiquitous Religions Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 31746   Accepted: 15391 Description There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in findi

【HDU1232】畅通工程(并查集基础题)

裸敲并查集,很水一次AC 1 #include <iostream> 2 #include <cstring> 3 #include <cstdlib> 4 #include <cstdio> 5 #include <cctype> 6 #include <cmath> 7 #include <algorithm> 8 #include <numeric> 9 #include <string> 1

【HDU1856】More is better(并查集基础题)

裸并查集,但有二坑: 1.需要路径压缩,不写的话会TLE 2.根据题目大意,如果0组男孩合作的话,应该最大的子集元素数目为1.所以res初始化为1即可. 1 #include <iostream> 2 #include <cstring> 3 #include <cstdio> 4 #include <cstdlib> 5 #include <algorithm> 6 #include <numeric> 7 #include <

Codeforces Round #254 (Div. 2) DZY Loves Chemistry【并查集基础】

一开始不知道题意是啥意思,迟放进去反应和后放进去反应有什么区别 对于第三组数据不是很懂,为啥312,132的组合是不行的 后来发现这是一道考察并查集的题目 QAQ 怒贴代码: 1 #include <stdio.h> 2 #include <string.h> 3 #include <stdlib.h> 4 #include <math.h> 5 #include <iostream> 6 #include <algorithm> 7

【HDU1325】Is It A Tree?(并查集基础题)

有以下坑点: 1.结束输入不一定-1,题目中的叙述只是说所有权值都为正值. 2.是否构成一棵树不能只判断是否只有一个根节点,没有环路,而且还需要判断每个节点的入度一定是1,不然就不是一棵树. (无环路也可用树的性质:结点数 = 边树 + 1 来取代) 1 #include <iostream> 2 #include <cstdlib> 3 #include <cstring> 4 #include <cctype> 5 #include <cmath&

【HDU2120】Ice_cream&#39;s world I(并查集基础题)

查环操作,裸题.一次AC. 1 #include <iostream> 2 #include <cstring> 3 #include <cstdlib> 4 #include <cctype> 5 #include <cmath> 6 #include <string> 7 #include <cstdio> 8 #include <algorithm> 9 #include <numeric>

POJ 2524 并查集

Ubiquitous Religions Time Limit: 5000MS Memory Limit: 65536K Total Submissions: 23580 Accepted: 11609 Description There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding o