搜索:A - Tempter of the Bone题解

问题描述:

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

输入:

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X‘: a block of wall, which the doggie cannot enter; 
‘S‘: the start point of the doggie; 
‘D‘: the Door; or 
‘.‘: an empty block.

The input is terminated with three 0‘s. This test case is not to be processed.

输入样例:

4 4 5

S.X.

..X.

..XD

....

3 4 5

S.X.

..X.

...D

0 0 0

输出样例:

NO

YES

C代码:

#include<stdio.h>
#include<math.h>
#include<stdlib.h>
#include<string.h>
int state[10][10], time, a, b, rx, ry, ax, ay;
char map[10][10];
int num[4][2] = {{0, 1}, {0, -1}, {1, 0}, { -1, 0}}, flag;
void DFS(int x, int y, int step)
{
	int i, kx, ky;

	if (x == ax && y == ay)
	{
		if (step == time)
		{
			flag = 1;
		}

		return;
	}

	if (step == time)
	{
		return;
	}

	if (map[x][y] == ‘X‘)
	{
		return;
	}

	if (flag)
	{
		return;
	}

	for (i = 0; i < 4; i++)
	{
		kx = x + num[i][0];
		ky = y + num[i][1];

		if (kx < 0 || kx >= a || ky < 0 || ky >= b)
		{
			continue;
		}

		if (state[kx][ky] == 0)
		{
			state[kx][ky] = 1;
			DFS(kx, ky, step + 1);
			state[kx][ky] = 0;

			if (flag)
			{
				return;
			}
		}
	}
}
int main()
{
	int i, j;

	while (scanf("%d%d%d", &a, &b, &time), a || b || time)
	{
		memset(state, 0, sizeof(state));

		for (i = 0; i < a; i++)
		{
			getchar();

			for (j = 0; j < b; j++)
			{
				scanf("%c", &map[i][j]);

				if (map[i][j] == ‘S‘)
				{
					rx = i;
					ry = j;
				}

				if (map[i][j] == ‘D‘)
				{
					ax = i;
					ay = j;
				}
			}
		}

		getchar();

		if (abs(rx - ax) + abs(ry - ay) > time || (rx + ry + ax + ay + time) % 2 == 1)
		{
			printf("NO\n");
			continue;
		}

		flag = 0;
		state[rx][ry] = 1;
		DFS(rx, ry, 0);
		state[rx][ry] = 0;

		if (flag)
		{
			printf("YES\n");
		}
		else
		{
			printf("NO\n");
		}
	}

	return 0;
}

C++代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <set>
#include <vector>
#include <map>
#include <queue>
#include <set>
#include <algorithm>
using namespace std;
char map1[10][10];
int n,m,t;
int flag;
int stx,sty,etx,ety;
int dx[]={0,0,1,-1};
int dy[]={1,-1,0,0};
char vis[10][10];
inline int abss(int x,int y){
    if(x<y)return y-x;
    else return x-y;
}
void dfs(int x,int y,int t){
    if(flag)return ;
    if(x<1||x>n||y<1||y>m)return ;
    if(map1[x][y]==‘D‘){
        if(t==0) flag=true;
        return ;
    }
    int ss=abss(x,etx)+abss(y,ety);
    if(ss>t)return ;
    if((ss+t)&1)return ;
    if(!vis[x-1][y]&&map1[x-1][y]!=‘X‘){
        vis[x-1][y]=1;
        dfs(x-1,y,t-1);
        vis[x-1][y]=0;
    }
    if(!vis[x+1][y]&&map1[x+1][y]!=‘X‘){
        vis[x+1][y]=1;
        dfs(x+1,y,t-1);
        vis[x+1][y]=0;
    }
    if(!vis[x][y-1]&&map1[x][y-1]!=‘X‘){
        vis[x][y-1]=1;
        dfs(x,y-1,t-1);
        vis[x][y-1]=0;
    }
    if(!vis[x][y+1]&&map1[x][y+1]!=‘X‘){
        vis[x][y+1]=1;
        dfs(x,y+1,t-1);
        vis[x][y+1]=0;
    }
    return ;
}
int main()
{
    while(~scanf("%d%d%d",&n,&m,&t)&&(n||m||t)){
        memset(vis,0,sizeof(vis));
        int k=0;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                scanf(" %c",&map1[i][j]);
                if(map1[i][j]==‘S‘){
                    stx=i;sty=j;
                    vis[i][j]=1;
                }
                else if(map1[i][j]==‘D‘){
                    etx=i;ety=j;
                }
                else if(map1[i][j]==‘X‘)k++;
            }
        }
        flag=false;
        if(n*m-k-1>=t)
        dfs(stx,sty,t);
        if(flag)puts("YES");
        else puts("NO");
    }
    return 0;
}

搜索:A - Tempter of the Bone题解

时间: 2024-10-09 04:36:49

搜索:A - Tempter of the Bone题解的相关文章

HDU 搜索练习 Tempter of the Bone

Tempter of the Bone Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 21 Accepted Submission(s) : 7 Problem Description The doggie found a bone in an ancient maze, which fascinated him a lot. However

Tempter of the Bone(dfs奇偶剪枝)

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 92175    Accepted Submission(s): 25051 Problem Description The doggie found a bone in an ancient maze, which fascinated him a

hdoj 1010 Tempter of the Bone【dfs查找能否在规定步数时从起点到达终点】【奇偶剪枝】

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 89317    Accepted Submission(s): 24279 Problem Description The doggie found a bone in an ancient maze, which fascinated him a

HDU - 1010 Tempter of the Bone 深搜模板题(DPS)解题报告

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 88587    Accepted Submission(s): 24116 Problem Description The doggie found a bone in an ancient maze, which fascinated him a

【深搜加剪枝五】HDU 1010 Tempter of the Bone

Tempter of the BoneTime Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 64326    Accepted Submission(s): 17567 Problem Description The doggie found a bone in an ancient maze, which fascinated him a l

杭电 HDU ACM 1046 Tempter of the Bone

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 83458    Accepted Submission(s): 22740 Problem Description The doggie found a bone in an ancient maze, which fascinated him a

Tempter of the Bone(杭电1010)(DFS+奇偶剪枝)

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 74916    Accepted Submission(s): 20481 Problem Description The doggie found a bone in an ancient maze, which fascinated him a

(hdu step 4.3.1)Tempter of the Bone(在特定的时间约束下,判断是否能够从起点达到终点)

题目: Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 1134 Accepted Submission(s): 379   Problem Description The doggie found a bone in an ancient maze, which fascinated him a lo

HDU 1010 Tempter of the Bone (DFS 奇偶剪枝)

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 75141    Accepted Submission(s): 20531 Problem Description The doggie found a bone in an ancient maze, which fascinated him a