Battle Ships(完全背包)

Battle ShipsCrawling in process...
Crawling failed
Time Limit:2000MS    
Memory Limit:65536KB     64bit IO Format:%lld & %llu

Submit
Status

Description

Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has
L longevity. The player has a military factory, which can produce
N
kinds of battle ships. The factory takes ti seconds to produce the
i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins.
Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

Your job is to find out the minimum time the player should spend to win the game.

Input

There are multiple test cases.

The first line of each case contains two integers N(1 ≤ N ≤ 30) and
L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships,
L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers
t i(1 ≤ t i ≤ 20) and
li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

Output

Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

Sample Input

1 1
1 1
2 10
1 1
2 5
3 100
1 10
3 20
10 100

Sample Output

2
4
5

题意:打一个血量为L的baby怪兽,可以建N种塔,每种塔耗时ti秒每秒打怪ai点血。最少要多少秒可以杀死小怪兽。
思路:以时间为容量,伤害的总血量为价值。因为塔可以在建造好后每一秒都造成伤害,所以建造同种塔的情况下,先后顺序会影响最终结果。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <iostream>
#include <queue>
#include <string>
using namespace std;
#define inf 99999999
int main()
{
    int dp[400];
    int t[40],l[40];
    int N,L,i,j;
    int cnt;
    while(~scanf("%d %d",&N,&L))
    {
        memset(dp,0,sizeof(dp));
        for(i=0; i<N; i++)
            scanf("%d %d",&t[i],&l[i]);
        cnt=inf;
        for(i=0; i<N; i++)
        {
            for(j=t[i];j;j++)
            {
                dp[j]=max(dp[j],dp[j-t[i]]+(j-t[i])*l[i]);
               if(dp[j]>=L)
                break;
            }
            if(cnt>j)
                cnt=j;
        }
        printf("%d\n",cnt);
    }
    return 0;
}



时间: 2024-10-20 01:33:19

Battle Ships(完全背包)的相关文章

ZOJ3623:Battle Ships(完全背包)

Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes tiseconds to produce the

ZOJ3623:Battle Ships(全然背包)

Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes tiseconds to produce the

ZOJ3623 Battle Ships (完全背包)

Battle Ships Time Limit: 2 Seconds      Memory Limit: 65536 KB Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N ki

zoj3623 Battle Ships

Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce th

hdu 5093 Battle ships 最大二分匹配

Battle ships Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 589    Accepted Submission(s): 233 Problem Description Dear contestant, now you are an excellent navy commander, who is responsible

Battle ships(二分图,建图,好题)

Battle ships Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 1007    Accepted Submission(s): 353 Problem Description Dear contestant, now you are an excellent navy commander, who is responsible

zoj 3623 Battle Ships dp

 Description Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti second

Battle Ships(复习泛化物品**)

传送门Battle Ships Time Limit: 2 Seconds      Memory Limit: 65536 KB Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N

Codeforces Round #Pi (Div. 2) D. One-Dimensional Battle Ships

Alice and Bob love playing one-dimensional battle ships. They play on the field in the form of a line consisting of n square cells (that is, on a 1?×?n table). At the beginning of the game Alice puts k ships on the field without telling their positio