HDU3714——三分——Error Curves

Josephina is a clever girl and addicted to Machine Learning recently. She 
pays much attention to a method called Linear Discriminant Analysis, which 
has many interesting properties. 
In order to test the algorithm‘s efficiency, she collects many datasets. 
What‘s more, each data is divided into two parts: training data and test 
data. She gets the parameters of the model on training data and test the 
model on test data. To her surprise, she finds each dataset‘s test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.

It‘s very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function‘s minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it‘s too hard for her to solve this problem. As a super programmer, can you help her?

Input

The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.

Output

For each test case, output the answer in a line. Round to 4 digits after the decimal point.

Sample Input

2
1
2 0 0
2
2 0 0
2 -4 2

Sample Output

0.0000
0.5000

/*
三分适用于抛物线类型的,先增后减或者先减后增
精度问题。。

*/
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const double eps = 1e-15;
const int MAX = 1e4 + 10;
int a[MAX], b[MAX], c[MAX];
int n;
double  check(double x)
{
    double max1 = a[1]*x*x + b[1]*x + c[1];
    for(int i = 2; i <= n ; i++)
        max1 = max(max1, a[i]*x*x + b[i]*x + c[i]);
    return max1;
}

int main()
{
int T;
scanf("%d", &T);
while(T--){
    scanf("%d", &n);
    for(int i = 1; i <= n ; i++){
        scanf("%d%d%d", &a[i], &b[i], &c[i]);
    }
    double l = 0, r = 1000;
    while(l + eps < r){
        double mid = (l + r) / 2;
        double midmid = (mid + r) /2 ;
        if(check(mid) > check(midmid)){
            l = mid;
        }
        else r = midmid;
    }
    printf("%.4f\n",check(r));
}
return 0;
}

  

时间: 2024-10-06 10:57:19

HDU3714——三分——Error Curves的相关文章

三分 Error Curves

- Error Curves Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Description Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a method called Linear Discriminant

UVA - 1476 Error Curves 三分

                                       Error Curves Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a method called Linear Discriminant Analysis, which has many interesting properties.In order to test

三分 HDOJ 3714 Error Curves

题目传送门 1 /* 2 三分:凹(凸)函数求极值 3 */ 4 #include <cstdio> 5 #include <algorithm> 6 #include <cstring> 7 #include <cmath> 8 using namespace std; 9 10 const int MAXN = 1e4 + 10; 11 const int INF = 0x3f3f3f3f; 12 const double EPS = 0.0000000

LA 5009 (HDU 3714) Error Curves (三分)

A - Error Curves Time Limit:3000MS    Memory Limit:0KB    64bit IO Format:%lld & %llu SubmitStatusPracticeUVALive 5009 Appoint description: Description Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a

UVALive 5009 Error Curves 三分

//#pragma comment(linker, "/STACK:1024000000,1024000000") #include<cstdio> #include<cstring> #include<cstdlib> #include<algorithm> #include<iostream> #include<sstream> #include<cmath> #include<climits

HDU-3714 Error Curves(凸函数求极值)

Error Curves Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 6241    Accepted Submission(s): 2341 Problem Description Josephina is a clever girl and addicted to Machine Learning recently. Shepay

hdu 3714 Error Curves(三分)

Error Curves Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 1198    Accepted Submission(s): 460 Problem Description Josephina is a clever girl and addicted to Machine Learning recently. She pa

UVA - 1476 Error Curves (三分搜索)

Description Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a method called Linear Discriminant Analysis, which has many interesting properties. In order to test the algorithm's efficiency, she collect

hdu3714 Error Curves

题目: Error Curves Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 1151    Accepted Submission(s): 440 Problem Description Josephina is a clever girl and addicted to Machine Learning recently. She