hdu 1754 Ihate it

I Hate It

Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Submit Status Practice HDU 1754

Description

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。 
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

Input

本题目包含多组测试,请处理到文件结束。 
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。 
学生ID编号分别从1编到N。 
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。 
接下来有M行。每一行有一个字符 C (只取‘Q‘或‘U‘) ,和两个正整数A,B。 
当C为‘Q‘的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。 
当C为‘U‘的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。

Output

对于每一次询问操作,在一行里面输出最高成绩。

Sample Input

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

Sample Output

5
6
5
9
#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
const int maxx = 200010;
int tree[maxx<<2];
int a[maxx];
int n;
void build(int root,int l,int r)
{
    //cout<<"root:"<<root<<" l,r:"<<l<<"  "<<r<<endl;
    if(l==r)
    {
        tree[root]=a[l];
    }
    else
    {
        int mid=(l+r)>>1;
        build(root<<1,l,mid);
        build((root<<1)+1,mid+1,r);
        tree[root]=max(tree[root<<1],tree[(root<<1)+1]);
    }
}
void update(int root,int l,int r,int pos,int val)
{
    if(pos==l&&pos==r)
    {
        tree[root]=val;
        return;
    }
    int mid=(l+r)>>1;
    if(pos<=mid) update(root<<1,l,mid,pos,val);
    else update((root<<1)+1,mid+1,r,pos,val);
    tree[root]=max(tree[root<<1],tree[(root<<1)+1]);
}
int query(int root,int l,int r,int ql,int qr)
{
    //cout<<"root:"<<root<<" l,r:"<<l<<"  "<<r<<" ql,qr "<<ql<<"  "<<qr<<"  tree[root] is :"<<tree[root]<<endl;
    if(l==ql&&qr==r)
    {
        return tree[root];
    }
    int mid=(l+r)>>1;
    if(qr<=mid)
    {
        return query(root<<1,l,mid,ql,qr);
    }
    else if(ql>mid)
    {
        return query((root<<1)+1,mid+1,r,ql,qr);
    }

    else return max(query(root<<1,l,mid,ql,mid),query((root<<1)+1,mid+1,r,mid+1,qr));
}
void print()
{
    int j=1,t=1;
    for(int i=1; i<=(n<<2); i++)
    {
        j++;
        printf("%d ",tree[i]);
        if(j>pow(2,(t-1)))
        {
            printf("\n");
            j=1;
            t++;
        }

    }
    printf("\n\n");
}
int main()
{
    int m;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%d",a+i);
        }
        build(1,1,n);

        char  cmd;
        for(int i=0; i<m; i++)
        {
            cin>>cmd;
            if(cmd==‘U‘)
            {
                int tmp1,tmp2;
                scanf("%d%d",&tmp1,&tmp2);
                update(1,1,n,tmp1,tmp2);
            }
            else if(cmd==‘Q‘)
            {
                int tmp1,tmp2;
                scanf("%d%d",&tmp1,&tmp2);
                int ans=query(1,1,n,tmp1,tmp2);
                printf("%d\n",ans);
            }
        }
    }
    return 0;
}
时间: 2024-11-06 22:10:47

hdu 1754 Ihate it的相关文章

hdu 1754 I Hate It 线段树 点修改

// hdu 1754 I Hate It 线段树 点修改 // // 不多说,裸的点修改 // // 继续练 #include <algorithm> #include <bitset> #include <cassert> #include <cctype> #include <cfloat> #include <climits> #include <cmath> #include <complex> #i

HDU 1754 I Hate It (线段树 单点更新)

题目链接 中文题意,与上题类似. 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 #include <queue> 5 #include <cstdlib> 6 #include <algorithm> 7 const int maxn = 200000+10; 8 using namespace std; 9 int a[maxn], n, m; 10

hdu 1754:I Hate It(线段树,入门题,RMQ问题)

I Hate It Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 33726    Accepted Submission(s): 13266 Problem Description 很多学校流行一种比较的习惯.老师们很喜欢询问,从某某到某某当中,分数最高的是多少.这让很多学生很反感.不管你喜不喜欢,现在需要你做的是,就是按照老师的要求

HDU 1754 I Hate It 基础线段树

用区间值m表示这段区间的最大值,一直更新这个区间的最大值,很基础的线段树 #include<iostream> #include<stdio.h> using namespace std; #define N 200005 struct node{ int l,r,m; }tree[N*4]; int a[N]; void build(int left,int right,int i){ tree[i].l=left; tree[i].r=right; if(tree[i].l==

hdu 1754 I Hate It 线段树单点更新和区间求和

转载请注明出处:http://blog.csdn.net/u012860063 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1754 参照HH大牛写的额! Problem Description 很多学校流行一种比较的习惯.老师们很喜欢询问,从某某到某某当中,分数最高的是多少. 这让很多学生很反感. 不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问.当然,老师有时候需要更新某位同学的成绩. Input 本题目包含多

HDU 1754 I Hate It (线段树)

Problem Description 很多学校流行一种比较的习惯.老师们很喜欢询问,从某某到某某当中,分数最高的是多少. 这让很多学生很反感. 不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问.当然,老师有时候需要更新某位同学的成绩. Input 本题目包含多组测试,请处理到文件结束. 在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目. 学生ID编号分别从1编到N. 第二

线段树(单点更新) HDU 1754 I Hate It

题目传送门 1 /* 2 线段树基本功能:区间最大值,修改某个值 3 */ 4 #include <cstdio> 5 #include <cstring> 6 #include <algorithm> 7 #define lson l, m, rt << 1 8 #define rson m+1, r, rt << 1|1 9 10 const int MAX_N = 200000 + 10; 11 int sum[MAX_N<<2

HDU 1754 I Hate It(线段树初步应用)

HDU  1754  I Hate It Description 很多学校流行一种比较的习惯.老师们很喜欢询问,从某某到某某当中,分数最高的是多少. 这让很多学生很反感. 不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问.当然,老师有时候需要更新某位同学的成绩. Input 本题目包含多组测试,请处理到文件结束. 在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目. 学生ID

HDU 1754 树状数组 解法

mnesia在频繁操作数据的过程可能会报错:** WARNING ** Mnesia is overloaded: {dump_log, write_threshold},可以看出,mnesia应该是过载了.这个警告在mnesia dump操作会发生这个问题,表类型为disc_only_copies .disc_copies都可能会发生. 如何重现这个问题,例子的场景是多个进程同时在不断地mnesia:dirty_write/2 mnesia过载分析 1.抛出警告是在mnesia 增加dump