HDU_1285_确定比赛名次(拓扑排序)

确定比赛名次

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 14762    Accepted Submission(s): 5902

Problem Description

有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。

Input

输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。

Output

给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。

Sample Input

4 3
1 2
2 3
4 3

Sample Output

1 2 4 3

分析:拓扑排序,注意判重边。还有就是注意排列顺序,推荐用优先队列。

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1285

代码清单:

#include<map>
#include<cmath>
#include<ctime>
#include<queue>
#include<stack>
#include<cctype>
#include<string>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef unsigned int uint;
typedef long long ll;
typedef unsigned long long ull;

const int maxv = 500 + 5;

int N,M;
int p,q,index;
int degree[maxv];
int sortGraph[maxv];
bool graph[maxv][maxv];

void init(){
    index=0;
    memset(graph,false,sizeof(graph));
    memset(degree,0,sizeof(degree));
}

void topSort(){
    for(int i=1;i<=N;i++){
        for(int u=1;u<=N;u++){
            if(degree[u]==0){
                degree[u]=-1;
                sortGraph[index++]=u;
                for(int v=1;v<=N;v++){
                    if(graph[u][v]) degree[v]--;
                }break; //保证题意输出顺序
            }
        }
    }
    for(int i=0;i<index;i++){
        if(i==index-1) printf("%d\n",sortGraph[i]);
        else printf("%d ",sortGraph[i]);
    }
}

int main(){
    while(scanf("%d%d",&N,&M)!=EOF){
        init();
        for(int i=0;i<M;i++){
            scanf("%d%d",&p,&q);
            if(!graph[p][q]){
                graph[p][q]=true;
                degree[q]++;
            }
        }
        topSort();
    }return 0;
}

优先队列:

#include<map>
#include<cmath>
#include<ctime>
#include<queue>
#include<stack>
#include<cctype>
#include<string>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef unsigned int uint;
typedef long long ll;
typedef unsigned long long ull;

const int maxv = 500 + 5;

int N,M;
int p,q,index;
int degree[maxv];
int sortGraph[maxv];
bool graph[maxv][maxv];

void init(){
    index=0;
    memset(graph,false,sizeof(graph));
    memset(degree,0,sizeof(degree));
}

void topSort(){
    priority_queue<int,vector<int>,greater<int> >que;
    while(!que.empty()) que.pop();
    for(int i=1;i<=N;i++){
        if(degree[i]==0)
            que.push(i);
    }
    while(!que.empty()){
        int u=que.top(); que.pop();
        sortGraph[index++]=u;
        for(int v=1;v<=N;v++){
            if(graph[u][v]){
                degree[v]--;
                if(degree[v]==0) que.push(v);
            }
        }
    }
    for(int i=0;i<index;i++){
        if(i==index-1) printf("%d\n",sortGraph[i]);
        else printf("%d ",sortGraph[i]);
    }
}

int main(){
    while(scanf("%d%d",&N,&M)!=EOF){
        init();
        for(int i=0;i<M;i++){
            scanf("%d%d",&p,&q);
            if(!graph[p][q]){
                graph[p][q]=true;
                degree[q]++;
            }
        }
        topSort();
    }return 0;
}
时间: 2024-10-22 23:02:40

HDU_1285_确定比赛名次(拓扑排序)的相关文章

hdu1285 确定比赛名次 (拓扑排序)

确定比赛名次 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 16782    Accepted Submission(s): 6659 Problem Description 有N个比赛队(1<=N<=500),编号依次为1,2,3,....,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直

HDU[1285]确定比赛名次 拓扑排序

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1285 题目大意:某人知道N个队伍M场比赛的胜负结果,要求输出N个队伍的名次(id为第二关键字). 核心思想:转化为图论问题,进行拓扑排序.步骤1.选定入度为0的点 2.删除该点与关联边 3.重复该过程 代码如下: //拓扑排序 (1.选入度为0的点.2.删除该点及关联边 3.重复该过程) #include <iostream> #include <memory.h> using nam

HDOJ 1285 确定比赛名次(拓扑排序,四种实现方法)

确定比赛名次 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 17294    Accepted Submission(s): 6888 Problem Description 有N个比赛队(1<=N<=500),编号依次为1,2,3,....,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直

ACM: HDU 1285 确定比赛名次 - 拓扑排序

HDU 1285 确定比赛名次 Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description 有N个比赛队(1<=N<=500),编号依次为1,2,3,....,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前.现在请你编程序确定排名

hdu1285 确定比赛名次(拓扑排序多种方法)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1285 Problem Description 有N个比赛队(1<=N<=500),编号依次为1,2,3,....,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前.现在请你编程序确定排名. Input 输入有若干组,每组中的第一行为二个数N(1<=N&l

HDU 1285 确定比赛名次 拓扑排序水题

Problem Description 有N个比赛队(1<=N<=500),编号依次为1,2,3,....,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前.现在请你编程序确定排名. Input 输入有若干组,每组中的第一行为二个数N(1<=N<=500),M:其中N表示队伍的个数,M表示接着有M行的输入数据.接下来的M行数据中,每行也有两个整

HDU 1285 确定比赛名次(拓扑排序基础)

题目大意: 题目是说,给你一个n个节点的有向无环图,然后,对于这个无环图,我们对他进行拓扑排序,使得拓扑排序中的序列按照字典序的方式输出. 解题思路: 直接套用toposort()模板... 先说说toposort()的含义: 拓扑排序就是说,我们在一完成一项工程的时候,这个工程分为了很多的子工程,我们不可能每次都一下完成很多的工程,我们要按照一定事 务之间的内在联系来完成相应的工程,比如你要完成A工程,那么你必须先完成B工程,所以说B的优先级高于A.那么我们有建图.. 代码: 1 # incl

HDU 1285 确定比赛名次 拓扑排序(邻接矩阵 邻接表

确定比赛名次 Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description 有N个比赛队(1<=N<=500),编号依次为1,2,3,....,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前.现在请你编程序确定排名. Input 输

HDU-1285-确定比赛名次-拓扑排序(模板)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1285 这是一道拓扑排序的模板题,用来学拓扑排序很好.我的算法62ms过的,效率还是很低,不过很好理解:用一个结构体记录每个点的入度出度就搞定了: #include<iostream> #include<string> #include<cstdio> #include<cstring> #include<queue> #include<map&