Airport(未解决。。。)

Airport

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1534    Accepted Submission(s): 486

Problem Description

The country of jiuye composed by N cites. Each city can be viewed as a point in a two- dimensional plane with integer coordinates (x,y). The distance between city i and city j is defined by dij = |xi - xj| + |yi - yj|. jiuye want to setup airport in K cities among N cities. So he need your help to choose these K cities, to minimize the maximum distance to the nearest airport of each city. That is , if we define di(1 ≤ i ≤ N ) as the distance from city i to the nearest city with airport. Your aim is to minimize the value max{di|1 ≤ i ≤ N }. You just output the minimum.

Input

The first line of the input is T (1 ≤ T ≤ 100), which stands for the number of test cases you need to solve.

The first line of each case contains two integers N ,K (1 ≤ N ≤ 60,1 ≤ K ≤ N ),as mentioned above.

The next N lines, each lines contains two integer xi and yi (-109 ≤ xi, yi ≤ 109), denote the coordinates of city i.

Output

For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then a single integer means the minimum.

Sample Input

2
3 2
0 0
4 0
5 1
4 2
0 3
1 0
3 0
8 9

Sample Output

Case #1: 2
Case #2: 4

题意:就是给你一系列点,让你挑k个点建造飞机场,然后求剩下点到最近的飞机场的最小的最大距离;距离定义:dij = |xi - xj| + |yi - yj|

我的思路是分别找出每个点到剩下点的距离,然后sort排序,找出每个城市第k大值的最小值;

大婶们说这是DLX可重复覆盖:

下面是大神的说法:

HDU 2295 Radar(DLX可重复覆盖)差不多,我们的做法就是

保存n个城市之间的距离,sort一下,二分结果,对满足条件的DLX求覆盖程度,

求出最大距离最小值。此题二分0~INF也可解决。

http://www.2cto.com/kf/201412/364538.html

先把我的wa代码扔着,抽空补上。。。

wa代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<algorithm>
using namespace std;
#define mem(x,y) memset(x,y,sizeof(x))
const int MAXN=1e5+10;
int a[65][65];
int cmp(int a,int b){
	return a>b;
}
struct Node{
	int x,y;
};
Node dt[65];
int getl(Node a,Node b){
	return abs(a.x-b.x)+abs(a.y-b.y);
}
int main(){
	int T,N,K,kase=0;
	scanf("%d",&T);
	while(T--){
		scanf("%d%d",&N,&K);
		for(int i=0;i<N;i++){
			scanf("%d%d",&dt[i].x,&dt[i].y);
		}
		for(int i=0;i<N;i++)for(int j=0;j<N;j++){
			a[i][j]=getl(dt[i],dt[j]);
		}
		for(int i=0;i<N;i++)sort(a[i],a[i]+N,cmp);
	/*	for(int i=0;i<N;i++){
			for(int j=0;j<N;j++)printf("%d ",a[i][j]);
			puts("");
		}*/
		int mx=0x3f3f3f3f;
		for(int i=0;i<N;i++)mx=min(mx,a[i][K-1]);
		printf("Case #%d: %d\n",++kase,mx);
	}
	return 0;
}

  

时间: 2024-10-06 10:15:04

Airport(未解决。。。)的相关文章

使用CocoaPods的pod install 遇到的错误,未解决(Xcode版本v6.4,Mac OS版本v10.10.4)

转载请标明出处:http://blog.csdn.net/android_ls/article/details/47059957 一.CocoaPods 是一款很好的依赖管理工具,其安装步骤大致如下: 1.首先确保开发环境中已经安装了 Ruby(一般安装了 XCode,Ruby 会被自动安装上) 建议使用淘宝提供的 Gem源,在终端执行下列命令: $ gem sources --remove https://rubygems.org/ $ gem sources -a http://ruby.t

openSUSE13.1无法打开Yast的安装/移除软件管理软件的解决办法&#183;(未解决,临时方法)

没有发现解决方案: 可用 sudo /sbin/yast2 用命令行的GUI替代...虽然差不多 决定一会update一下试试 openSUSE13.1无法打开Yast的安装/移除软件管理软件的解决办法·(未解决,临时方法),布布扣,bubuko.com

Win8.1想要卸载openSUSE出现问题(未解决)

因为在蜥蜴上的Python被玩坏了,所以想要卸载重装.结果在Windows下的EasyBCD打开提示错误: The Boot Configuration Data Store Could Not Be Opened - The System Cannot Find The File Specified FQGoogle了半天,最终不知道在哪里看到的“Active”,把C盘 用DiskGenius Active了一下,好不好使就看我重启之后了 Win8.1想要卸载openSUSE出现问题(未解决)

jquery中form中使用submit出现的问题,未解决

$("#login_btn").click(function(){在type为submit的按钮下 if($("#id_password").val().length == 0){//检验密码是否为空 $('form').submit(function(){ alert("1") return false; }); }else if($("#vali").val() != code){//验证码是否正确 $('form').s

【求解】WinPhone模拟器报错:模拟器没法确定来宾虚拟机通信的主机ID地址。某些功能已被禁用【未解决】

先看警告 再看错误信息 计算机管理打不开就==>Win+R ==>compmgmt.msc 发现,dnt在管理员权限组里面,也在Hyper-V权限组里面 打开管理工具 重启 [求解]WinPhone模拟器报错:模拟器没法确定来宾虚拟机通信的主机ID地址.某些功能已被禁用[未解决][求解]WinPhone模拟器报错:模拟器没法确定来宾虚拟机通信的主机ID地址.某些功能已被禁用[未解决][求解]WinPhone模拟器报错:模拟器没法确定来宾虚拟机通信的主机ID地址.某些功能已被禁用[未解决][求解

OpenNebula 创建虚拟机失败(未解决)

Tue Jul 1 17:52:22 2014 [ReM][D]: Req:3472 UID:0 AclInfo invoked Tue Jul 1 17:52:22 2014 [ReM][D]: Req:3472 UID:0 AclInfo result SUCCESS, "<ACL_POOL><ACL><ID>0..." Tue Jul 1 17:52:22 2014 [ReM][D]: Req:3536 UID:0 VirtualMachine

String,Array等原生引用对象prototype问题(打X未解决,打勾已解决)

1.2014年6月29日 10:51:44    原型模式     疑问一:    String类型中,动态为其加入函数时候,可以通过String.prototype.[[functionname]] = function(){}方式或者直接string.[[functionname]] = function(){},但是遇到了一个问题,当创建一个实例时,只有前者可以运行,后者报错找不到该方法,如:var msg = 'hello world' ; msg.[[functionname]] ; 

记一次未解决的异常:java.lang.NoClassDefFoundError: net/sf/json/JSONObject

一.异常产生现象 使用json-lib转换实体类/字符串,跑单元测试没问题,但是启动jetty后调用JSONArray.fromObject(data)就会抛标题中异常 二.尝试解决的步骤 1.网上有的说tomcat存在此问题,需要将jar包拷贝到tomcat目录,容器用的是jetty,所以不是这个原因(未解决) http://blog.csdn.net/yeqiuzs/article/details/45097063 2.json-lib需要引入其它库,如图所示,引入后单元测试可以跑通,但是j

(未解决)WIN8下使用POWERSHELL安装python easy_install无法成功

按照https://pypi.python.org/pypi/setuptools#windows-8-powershell介绍的方法, 安装未成功.安装似乎没有启动, 也未安装成功. Windows 8 (Powershell) For best results, uninstall previous versions FIRST (see Uninstalling). Using Windows 8 or later, it's possible to install with one si

阿里云香港机房故障(到现在还未解决)

早上10点被客户电话叫醒,到现在问题还未解决.联系了就说是香港网络运营商问题,会尽快修复,可连具体时间都无法提供,难道这这么等下去? 我们的客户都快爆发了,这次真害死人了. 平时看阿里挺牛B的才买了他们的云服务. 可是作为一个云服务商,遇到这种问题,竟然没有一点备用方案. 要这样的话我们使用阿里云服务还有什么保障. 有没有跟我们一样悲剧的朋友.T T. 官方公告 阿里云香港region访问异常故障 尊敬的用户,目前香港机房故障仍在处理中.对由此异常导致的服务中断,我们深表歉意.同时我们会尽快启动