HDU3232 Crossing Rivers 数学期望问题

Crossing Rivers

                                                                                     Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description

You live in a village but work in another village. You decided to follow
the straight path between your house (A) and the working place (B), but
there are several rivers you need to cross. Assume B is to the right of
A, and all the rivers lie between them.

Fortunately, there is one "automatic" boat moving smoothly in each
river. When you arrive the left bank of a river, just wait for the boat,
then go with it. You‘re so slim that carrying you does not change the
speed of any boat.

Days and days after, you came up with the following question: assume
each boat is independently placed at random at time 0, what is the expected time to reach B from A? Your walking speed is always 1.

To be more precise, for a river of length L, the distance of the boat
(which could be regarded as a mathematical point) to the left bank at
time 0 is uniformly chosenfrom interval [0, L], and the boat is equally like to be moving left
or right, if it’s not precisely at the river bank.

Input

There will be at most 10 test cases. Each case begins with two integers n and D, where n (0 <= n <= 10) is the number of rivers between A and B, D (1 <= D <= 1000) is the distance from A to B. Each of the
following n lines describes a river with 3 integers: p, L and v (0 <= p < D, 0 < L <= D, 1 <= v <= 100). p is the distance from A to the left bank of this river, L is
the length of this river, v is the speed of the boat on this
river. It is guaranteed that rivers lie between A and B, and they don’t
overlap. The last test case is followed by n=D=0, which should not be processed.

Output

For each test case, print the case number and the expected time, rounded to 3 digits after the decimal point.

Print a blank line after the output of each test case.

Sample Input

1 1
0 1 2
0 1
0 0

Sample Output

Case 1: 1.000

Case 2: 1.000

题目大意:A、B两点之间距离为D,并且在A、B之间有n条河,每条河上有一条自 动船。船的宽度为L,把船看成一个点时,则它在第0时刻的位置是任意的,并且向两岸划动的可能性也是相同的。已知步行的速度为1,船的速度为v,每条河与 A点的距离为P,求A到B花费的时间是多少。

分析:由题意不难得出,船在0时刻在河上的位置满足均匀分布,那么由均匀分布我们可知它的数学期望E = L/2。船向左岸划的概率等于向右岸划的概率为1/2,因为人只有通过船到左岸上船,再向右岸划动,才能过河。所以当船向左岸划的时候,那它到达左岸的期望时间T1
= L/2 * 1/2 / v;当船向右岸划,那它到达的左岸的期望时间T2 = (L/2 + L) * 1 / 2 / v;最后再从左岸到右岸的时间为T3 =
L / v;所以过河的总期望时间为T = T1 + T2 + T3 = 2L / v;

#include<stdio.h>
int main()
{
    int n, i, cas = 0, d, p, l, v;
    while(~scanf("%d%d",&n,&d), n+d)
    {
        double ans = d*1.0;
        for(i = 0; i < n; i++)
        {
            scanf("%d%d%d",&p, &l, &v);
            ans -= l;  //减去不过这条河时所用的时间
            ans += 2.0*l / v; //加上过河时间
        }
        printf("Case %d: %.3lf\n\n",++cas, ans);
    }
    return 0;
}
时间: 2024-08-05 14:43:28

HDU3232 Crossing Rivers 数学期望问题的相关文章

Uva - 12230 Crossing Rivers (数学期望)

你住在村庄A,每天需要过很多条河到另一个村庄B上班,B在A的右边,所有的河都在A,B之间,幸运的是每条船上都有自由移动的自动船, 因此只要到达河左岸然后等船过来,在右岸下船,上船之后船的速度不变.现在问从A到B的期望时间是多少,假设在出发时船的位置都是 随机分布.人在 陆地上行走的速度为1. 根据数学期望的线性,过每条河的时间为L/v(到河边船刚好开)到3L/v(到河边船刚好开走)的均匀分布,因此期望过河时间为 (L+3L/v)/2=(2*L/v) 加上 D-sum(L) . 1 #includ

UVa12230 - Crossing Rivers (数学期望)

题意:给你A和B的距离,以及途中n条河的信息,问你从A到B的期望 思路:我们单纯算过河时间的话,最快的是l/v,最慢的可能是3l/v,期间的时间是线性的,所以期望就是4l/2v=2l/v #include<iostream> #include<cstring> #include<algorithm> #include<cstdio> int main() { int n; double p,l,v,d; int cas=1; while(scanf(&quo

UVA - 12230 Crossing Rivers (期望)

Description You live in a village but work in another village. You decided to follow the straight path between your house (A) and the working place (B), but there are several rivers you need to cross. Assume B is to the right of A, and all the rivers

UVA - 12230 Crossing Rivers 概率期望

You live in a village but work in another village. You decided to follow the straight path between yourhouse (A) and the working place (B), but there are several rivers you need to cross. Assume B is tothe right of A, and all the rivers lie between t

Uva12230Crossing Rivers (数学期望)

问题: You live in a village but work in another village. You decided to follow the straight path between your house (A) and the working place (B), but there are several rivers you need to cross. Assume B is to the right of A, and all the rivers lie bet

HDU3232 Crossing rivers

思路:这题关键一点就是根据题目的描述和测试数据得到启发,船都是 从对岸划过来的.心中有具体场景,就可以很简单了. 1 #include<cstdio> 2 int main() 3 { 4 double d, p, l, v, sum, flag = 0; 5 int n, kase = 1; 6 while(~scanf("%d %lf", &n, &d)) 7 { 8 if(n == 0 && d == 0) break; //跳出 9

uva 12230 - Crossing Rivers(求数学期望)

利用了数学期望的线性性质:有线个随机变量之和的数学期望的关于每个随机变量的期望之和: 由于过每条河的时间为L / V和3L / V的均匀分布,因此期望过河时间为2L / V. #include<cstdio> #include<cstring> #include<algorithm> using namespace std; int n;double d; int main() { int kase=0; while(scanf("%d%lf",&a

UVa 12230 Crossing Rivers (数学期望水题)

题意:你要从A到B去上班,然而这中间有n条河,距离为d.给定这n条河离A的距离p,长度L,和船的移动速度v,求从A到B的时间的数学期望. 并且假设出门前每条船的位置是随机的,如果不是在端点,方向也是不定的,你在陆地行走速度为1,输入保证河在AB之前,并且不会重叠. 析:一看这个题,好像不会啊...这怎么求,这么乱,这么复杂... 但是仔细一想求时间期望,不就是在过河的地方时间不是固定的么,只要求出过河的时间的数学期望,利用数学期望的线性,加起来就OK了. 这样一想感觉就不乱了,那么怎么求每个河的

UVa 12230 - Crossing Rivers(数学期望)

链接: https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=3382 题意: 你住在村庄A,每天需要过很多条河到另一个村庄B上班.B在A的右边,所有的河都在中间.幸运的是,每条河上都有匀速移动的自动船,因此每当到达一条河的左岸时,只需等船过来,载着你过河,然后在右岸下船.你很瘦,因此上船之后船速不变.日复一日,年复一年,你问自己:从A到B,平均