Problem Description
As we all know, in the computer science, an integer A is in the range of 32-signed integer, which means the integer A is between -2^31 and (2^31)-1 (inclusive), and A is a 64-signed integer, which means A is between -2^63 and (2^63)-1(inclusive). Now we give the K-signed range, and two K-signed integers A and B, you should check whether the sum of A and B is beyond the range of K-signed integer or not.
Input
There will be many cases to calculate. In each case, there comes the integer K (2<=K<=64) first in a single line. Then following the line, there is another single line which has two K-signed integers A and B.
Output
For each case, you should estimate whether the sum is beyond the range. If exceeded, print “Yes”, otherwise “WaHaHa”.
Sample Input
32
100 100
Sample Output
WaHaHa
高精度问题,但是这里却没用大数相加,看了人家思想和代码,说k=64要单独处理,很多人都wa看来这道题有点难度,我个人认为确实还是有点难度系数。
# include <iostream>
# include <cmath>
#include<cstdio>
using namespace std;
int main()
{
int k;
__int64 a,b,c,d;
while(cin>>k)
{
cin>>a>>b;
c=(__int64)(pow(2,k-1))-1;
d=(-1)*(__int64)(pow(2,k));
if((a<0&&b>0)||(a>0&&b<0))
{
cout<<"WaHaHa"<<endl;
continue;
}
if(k==64)
{
if(a>0&&b>0&&c-a<b)
printf("Yes\n");
else if(a<0&&b<0&&d-a>b)
printf("Yes\n");
else printf("WaHaHa\n");
continue;
}
if(a>0&&c-a<b)
printf("Yes\n");
else if (a<0&&d-a>=b)
printf("Yes\n");
else
printf("WaHaHa\n");
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。