Light, more light UVA 10110

说说:题意大概就是给定一个数n,然后从1遍历到n,原本要输出的状态是no,然后再遍历过程中遇到n的因子就变一次状态。最后将最终的状态输出。解法的话,将这个过程模拟一遍也是可以的。但我们知道若n能被m整出,那么也必定能被n/m整除,所以若n不是平方数的话状态肯定变换偶数次。照这个思路,代码的效率也就提高不少啦~

题目:

Light, more light

The Problem

There is man named "mabu" for switching on-off light in our University. He switches on-off the lights in a corridor. Every bulb has its

一个叫"mabu"的人是专门负责开关我们学校的灯的。他现在要开关一条走廊的灯。每个灯泡都有自己的开关,

own toggle switch. That is, if it is pressed then the bulb turns on. Another press will turn it off. To save power consumption (or may be

如果按一下开关灯泡就亮了,再按一下就灭了。为了省电(或者是他疯了)

he is mad or something else) he does a peculiar thing. If in a corridor there is `n‘ bulbs, he walks along the corridor back and forth `n‘

他做了一件非常奇怪的事。如果走廊里有‘n’盏灯,他沿着走廊来回走n次,

times and in i‘th walk he toggles only the switches whose serial is divisable by i. He does not press any switch when coming back to his

并且在第i次的时候只按序号能被i整除的灯泡的开关。他在回到他最初位置的过程中不按开关

initial position. A i‘th walk is defined as going down the corridor (while doing the peculiar thing) and coming back again.

第i次行走的意思是沿着走廊走过去(同时做上述奇怪的事)然后再走回来。

Now you have to determine what is the final condition of the last bulb. Is it on or off?

现在你要确定最后一盏灯的最后状态是开还是关?

The Input

The input will be an integer indicating the n‘th bulb in a corridor. Which is less then or equals 2^32-1. A zero indicates the end of input.

输入是一个整数,代表走廊上的第n盏灯。n小于等于2^32-1.输入为0代表输入结束,此时你无需输出

You should not process this input.

The Output

Output " yes"
if the light is on otherwise " no" , in a single line.

灯亮输出“yes”,否则输出“no”

Sample Input

3
6241
8191
0

Sample Output

no
yes
no

源代码:

#include <stdio.h>
#include <math.h>

int main(){
 double n;
 freopen("input.txt","r",stdin);
 while(scanf("%lf",&n)){
    if(n==0)
        break;

    if(sqrt(n)==(unsigned)sqrt(n))//判断是否为平方数
        printf("yes\n");
    else
        printf("no\n");
 }
 return 0;
}

Light, more light UVA 10110

时间: 2024-11-08 23:13:06

Light, more light UVA 10110的相关文章

UVA 10110 Light, more light【经典开灯问题】

Light, more light Time Limit: 3000ms Memory Limit: 131072KB This problem will be judged on UVA. Original ID: 10110 64-bit integer IO format: %lld      Java class name: Main Prev Submit Status Statistics Discuss Next Type: None None Graph Theory      

UVa 10110 - Light, more light

题目:有一个人负责开关走廊中的灯泡.走廊有n个灯泡(编号从1到n),他会来回走上n趟: 在第 i 趟开始走过去的时候,他会开关灯泡编号可以被 i 整除的灯泡: 现在要算出在走完n趟之后,最后一个电灯泡(编号n)是亮着的还是暗着的. 分析:数学.本题就是再求n个因数的个数的奇偶性. 如果 x|n,那么n/x | n,因此都是成对出现的: 这里有一个特例,如果n是完全平方数,那么sqrt(n)只会出现一次: 所以,n是完全平方数,则因数为奇数个:否则,因数为偶数个. 说明:注意int存不下(⊙_⊙)

精确光源(Punctual Light Sources)

<Physically-Based Shading Models in Film and Game Production>(SIGGRAPH 2010 Course Notes) (地址:http://renderwonk.com/publications/s2010-shading-course/hoffman/s2010_physically_based_shading_hoffman_a_notes.pdf) Punctual Light Sources一段若干注解: 由于物理渲染基于辐

Unity3D教程宝典之光影烘焙:第三讲Light probes

引言:烘焙出来的light map并不能作用于动态物体.如果场景里有动态物体的话,会显得与烘焙好的场景脱离.需要两个部分的效果:影子:(1)使用勾选阴影的实时光.(注意:Dual+deferred Dual+forward Single+forward都有影子   只有Single+deferred,即使光勾选了阴影,也不会有影子.) 明暗变化:(1)使用实时光(2)使用Light Probes(3)使用脚本控制物体处于阴影区域的颜色:(1)(2)都默认是黑色,除非自己在阴影区域再加光源(3)自

OpenGL学习脚印:光源类型和使用多个光源(Light source and multiple lights)

写在前面 上一节光照中使用材质和lighting maps介绍了使用材质属性和lighting maps使物体的光照效果能反映物体的材料特性,看起来更逼真.在前面的章节中使用的实际上都是一个点光源,本节将学习其他几种光源类型,以及在场景中使用多个光源.本节代码均可以在我的github下载. 本节内容整理自: 1.www.learnopengl.com light casters 2.www.learnopengl.com Multiple lights 通过本节可以了解到 方向光源 点光源 聚光

three.js 源码注释(三十八)Light/Light.js

商域无疆 (http://blog.csdn.net/omni360/) 本文遵循"署名-非商业用途-保持一致"创作公用协议 转载请保留此句:商域无疆 -  本博客专注于 敏捷开发及移动和物联设备研究:数据可视化.GOLANG.Html5.WEBGL.THREE.JS,否则,出自本博客的文章拒绝转载或再转载,谢谢合作. 俺也是刚开始学,好多地儿肯定不对还请见谅. 以下代码是THREE.JS 源码文件中Light/Light.js文件的注释. 更多更新在 : https://github

学英语《每日一歌》之Traveling Light

Joel Hanson(乔伊.汉森)曾经是荣获过格莱美奖和基督摇滚音乐和平鸽奖(Dove Award)的美国福音乐队(PFR)的 成员主唱和吉他手.在1997年PFR解体之后,他走上了单飞的音乐道路,但2000年PFR又重新组合起来,并且先后 推出了<Captured>和< Broken>两张专辑.但是并未取得理想的效果,直到他与Sara Groves合作的一首单曲 <Travelling Light>推出之后,才取得了轰动效果 一开始的鼓点就吸引了我.听这首歌有种特别

Commercial Lighting: LED Ceiling Light, LED Ceiling Light

Unlike ceiling lamps, floor lamps, chandeliers, lamps that can sometimes rely on "faces", LED ceiling lamps and LED ceiling lamps have always relied on strength - using pure light and shadow to shape the taste, and to achieve excellent decorativ

节点同步light、fast、full的区别

0x01 同步模式简介 安装好 geth 之后,运行 geth --help, 你就可以看到下面的命令行说明 ... ETHEREUM OPTIONS: ... --syncmode "fast" Blockchain sync mode ("fast", "full", or "light") ... DEPRECATED OPTIONS: --fast Enable fast syncing through state d