Description
Once upon a time, there is a special coco-cola store. If you return three empty bottles to the shop, you’ll get a full bottle of coco-cola to drink. If you have n empty bottles right in your hand, how many full bottles of coco-cola can you drink?
Input
There will be at most 10 test cases, each containing a single line with an integer n (1 ≤ n ≤ 100). The input terminates with n = 0, which should not be processed.
Output
For each test case, print the number of full bottles of coco-cola that you can drink. Spoiler Let me tell you how to drink 5 full bottles with 10 empty bottles: get 3 full bottles with 9 empty bottles, drink them to get 3 empty bottles, and again get a full bottle from them. Now you have 2 empty bottles. Borrow another empty bottle from the shop, then get another full bottle. Drink it, and finally return this empty bottle to the shop!
Sample Input
3
10
81
0
Sample Output
1
5
40
解题思路:当我们手中的空瓶数大于2时我们就可以拿去换满的可乐。每去换一次我们就少了三个空瓶。但是我们得到了一瓶满的可乐,把它喝完我们就又多了一个空瓶(即每去商店换一次我们就把空瓶数减一次3然后再加一次1)最后如果还剩了两个空瓶我们就可以先向商店借一瓶喝完,然后还给商店三个空瓶就可以了。
程序代码:
#include <stdio.h>
int main()
{
int n;
while(scanf("%d",&n)&&n) //程序循环条件
{
int j=0;
while(n>2)
{
n=n-3;
j++;
n++;
}
if(n-1)
j=j+1;
printf("%d\n",j);
}
return 0;
}