ZOJ 3609 Modular Inverse 解线性模方程

点击打开链接

Modular Inverse


Time Limit: 2 Seconds      Memory Limit: 65536 KB



The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1x (mod m).
This is equivalent to ax≡1 (mod m).

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn‘t exist, output "Not Exist".

Sample Input

3
3 11
4 12
5 13

Sample Output

4
Not Exist
8

模线性方程ax=b (mod n),令d=exgcd(a,n),该方程有解的充要条件为 d | b ,即 b% d==0

方程ax=b(mod n)的最小解 :x=(x*(b/d))%n

方程ax=b(mod n)的最整数小解: x=(x%(n/d)+n/d)%(n/d)

因为要求输出最小整数,所以如果答案为0的话,肯定是m=1的情况,此情况应输出1.

//0ms	168k
#include<stdio.h>
#include<string.h>
int exgcd(int A,int &x,int B,int &y)
{
    int x1,y1,x0,y0;
    x0=1;y0=0;
    x1=0;y1=1;
    int r=(A%B+B)%B;
    int q=(A-r)/B;
    x=0;y=1;
    while(r)
    {
        x=x0-q*x1;
        y=y0-q*y1;
        x0=x1;
        y0=y1;
        x1=x;y1=y;
        A=B;B=r;r=A%B;
        q=(A-r)/B;
    }
    return B;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int a,b=1,n,x,y;
        scanf("%d%d",&a,&n);
        int d=exgcd(a,x,n,y);
        if(b%d==0)
        {
            x=(x%(n/d)+n/d)%(n/d);
            if(!x)x++;
            printf("%d\n",x);
        }
        else printf("Not Exist\n");
    }
}

ZOJ 3609 Modular Inverse 解线性模方程,码迷,mamicode.com

时间: 2024-08-12 07:08:38

ZOJ 3609 Modular Inverse 解线性模方程的相关文章

ZOJ 3609 Modular Inverse (水题)

Modular Inverse Time Limit: 2 Seconds      Memory Limit: 65536 KB The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m). Input There are multiple test cases. Th

ZOJ 3609 Modular Inverse

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3609 题面: Modular Inverse Time Limit: 2 Seconds      Memory Limit: 65536 KB The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m).

ZOJ 3609 Modular Inverse(扩展欧几里德)

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=4712 The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m). Input There are multiple test cases.

ZOJ - 3609 —— Modular Inverse 【乘法逆,扩展欧几里得】

题目:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=4712 1. 这题数据范围太小,直接暴力即可 2. 不过其实这题也是很“直白的”求乘法逆的题目,即当b=1的特殊的模线性方程问题ax≡b mod(n),可以通过扩展欧几里得算法求解:   ax≡b mod(n) => (ax) mod n = b mod n => ax=k1*n+r ... (1) b=k2n+r    ... (2)  (1)-(2)=>ax-

ZOJ 4712: Modular Inverse

Modular Inverse ///@author Sycamore, ZJNU; ///@date 8/6/2017 ///@ref stanford-acm-master #include<bits/stdc++.h> using namespace std; typedef long long ll; int mod(int a, int b) { return ((a%b) + b) % b; } int extended_euclid(int a, int b, int &

【ZOJ】3609 Modular Inverse

1. 题目描述求乘法逆元. 2. 基本思路利用扩展gcd求逆元,模板题目. 3. 代码 1 /* 3609 */ 2 #include <iostream> 3 #include <sstream> 4 #include <string> 5 #include <map> 6 #include <queue> 7 #include <set> 8 #include <stack> 9 #include <vector

Modular Inverse(模逆元,扩展欧几里德)

Modular Inverse Time Limit: 2 Seconds      Memory Limit: 65536 KB The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m). Input There are multiple test cases. Th

Modular Inverse(zoj3609+欧几里德)

Modular Inverse Time Limit: 2 Seconds      Memory Limit: 65536 KB The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m). Input There are multiple test cases. Th

寒假 D3 D Modular Inverse

Modular Inverse Time Limit: 2 Seconds                                     Memory Limit: 65536 KB The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m). Input Th