poj2349

Arctic Network

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 0   Accepted: 0

Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel. 
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers.
Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in
km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13

/************************************************************************/

附上该题对应的中文题

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

国防部(DND)要用无线网络连接北部几个哨所。两种不同的通信技术被用于建立网络:每一个哨所有一个无线电收发器,一些哨所将有一个卫星频道。

任何两个有卫星信道的哨所可以通过卫星进行通信,而不管他们的位置。同时,当两个哨所之间的距离不超过D时可以通过无线电通讯,D取决于对收发器的功率。功率越大,D也越大,但成本更高。出于采购和维修的方便,所有哨所的收发器必须是相同的;那就是说,D值对每一个哨所相同。

你的任务是确定收发器的D的最小值。每对哨所间至少要有一条通信线路(直接或间接)。

Input

输入的第一行是测试数据的数量N。

每组测试数据的第一行包含卫星频道的数量S(1 < = S < = 100)和哨所的数量P(S < P < = 500)。接下来的P行,给出以公里为单位的每个哨所的坐标(x,y)( 坐标为0到10000之间的整数)。

Output

对于每组测试数据,输出一行,输出收发器的D的最小值。精确到小数点后两位。

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13

题意:有两种不同的通信技术,有卫星通信的两个城市之间可以任意联络,但用无线电通信的城市只能和距离不超过D的城市联系。无线电的能力越高(即传输距离D越大),花费就越大。已知无线电的数目m,求最小的D。

思路:先求出每两个顶点之间的距离,(注意:是double类型的),然后最小生成树。由于无线电的数目已给出m,所以需要把最小生成树分成m份,即删除m-1条边,得到m个连通分量。关键是删除哪些边呢,题目要求最小的D,故把构成最小生成树的边从大到小排序,删除前m-1条边,第m条边即所要求的最小D。其实只要思路清晰,很容易就能把这道题AC。

 pass:要在G++状态下提交

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
#define N 510
struct node{
    int x,y;
    double v;
}a[N],e[N*N];
int t,fa[N];
double ans[N*N];
bool cmp(const node &p,const node &q){
    return p.v<q.v;
}
int find(int x){
    return fa[x]==x?x:fa[x]=find(fa[x]);
}
int main(){
    //freopen("sh.in","r",stdin);
    scanf("%d",&t);
    while(t--){
        int n,m,cnt=0;
        scanf("%d%d",&m,&n);
        for(int i=1;i<=n;i++) fa[i]=i;
        memset(a,0,sizeof(a));
        memset(e,0,sizeof(e));
        memset(ans,0,sizeof(ans));
        for(int i=1;i<=n;i++) scanf("%d%d",&a[i].x,&a[i].y);
        for(int i=1;i<=n;i++){
            for(int j=1;j<i;j++){
                e[++cnt].x=i;e[cnt].y=j;
                e[cnt].v=sqrt((a[i].x-a[j].x)*(a[i].x-a[j].x)+(a[i].y-a[j].y)*(a[i].y-a[j].y));
            }
        }
        int k=0,res=0;
        sort(e+1,e+cnt+1,cmp);
        for(int i=1;i<=cnt;i++){
            int fx=find(e[i].x),fy=find(e[i].y);
            if(fx!=fy){
                fa[fx]=fy;
                ans[k++]=e[i].v;
            }
        }
        printf("%.2lf\n",ans[k-m]);//G++状态下要用f,不能用lf--唯一的坑爹之处
    }
    return 0;
}
时间: 2024-08-29 17:16:26

poj2349的相关文章

POJ2349&amp;ZOJ1914--Arctic Network【最小生成树】

链接:http://poj.org/problem?id=2349 题意:北极有一些村庄,现需要在这些村庄间建立起通讯,有s个卫星频道,任何两个拥有卫星频道的村庄都可以直接通过卫星进行通讯而无视距离,没有卫星的村庄通过无线电进行通讯,并且这两个村庄的距离不能超过D,D值取决于无线电收发器的功率,功率越大,D值越大,但价格也越高,出于购买费用和维护费用的考虑,所有村庄的无线电收发器都相同,即D值相同,现要求在保证任意两个村庄间都能直接或间接通讯,并且D值最小,输出这个最小值. 就是输出最小生成树最

POJ-2349 Arctic Network---MST的第m长的边

题目链接: https://vjudge.net/problem/POJ-2349 题目大意: 要在n个节点之间建立通信网络,其中m个节点可以用卫星直接连接,剩下的节点都要用线路连接,求剩下这些线路中最大的长度需要多长 思路: 还是MST的裸题,由于有m个节点可以用卫星连接,所以求出MST后,最长的m-1条边都可以用卫星连接,只需要求出第m长的边即可,直接用prim算法,保存mst每条边的长度,排序后直接输出第m长的边. 1 #include<iostream> 2 #include<c

[Poj2349]Arctic Network(二分,最小生成树)

[Poj2349]Arctic Network Description 国防部(DND)要用无线网络连接北部几个哨所.两种不同的通信技术被用于建立网络:每一个哨所有一个无线电收发器,一些哨所将有一个卫星频道. 任何两个有卫星信道的哨所可以通过卫星进行通信,而不管他们的位置.同时,当两个哨所之间的距离不超过D时可以通过无线电通讯,D取决于对收发器的功率.功率越大,D也越大,但成本更高.出于采购和维修的方便,所有哨所的收发器必须是相同的:那就是说,D值对每一个哨所相同. 你的任务是确定收发器的D的最

POJ-2349(kruskal算法+最小生成树中最大边的长度)

Arctic POJ-2349 这题是最小生成树的变形题目.题目的意思是已经有s个卫星频道,这几个卫星频道可以构成一部分的网络,而且不用费用,剩下的需要靠d的卫星接收器.题目要求的就是最小生成树中,最大的边的长度. 题目中的传入kruskal函数里面的sn表示还需要连接的顶点个数,因为剩下的可以使用卫星频道来连接. 剩下的就是kruskal的问题了,这里通过当前最大边来返回答案. #include<iostream> #include<cstdio> #include<alg

poj2349 Arctic Network

题意: 某地区共有n座村庄,每座村庄的坐标用一对整数(x, y)表示,现在要在村庄之间建立通讯网络.通讯工具有两种,分别是需要铺设的普通线路和无线通讯的卫星设备.只能给k个村庄配备卫星设备,拥有卫星设备的村庄互相间直接通讯.铺设了线路的村庄之间也可以通讯.但是由于技术原因,两个村庄之间线路长度最多不能超过 d, 否则就会由于信号衰减导致通讯不可靠.要想增大 d 值,则会导致要投入更多的设备(成本). 已知所有村庄的坐标 (x , y) ,卫星设备的数量 k .问:如何分配卫星设备,才能使各个村庄

POJ2349(求生成树中符合题意的边)

Arctic Network Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 14977   Accepted: 4777 Description The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication tec

poj2349 Arctic Network - 最小生成树

2017-08-04 16:19:13 writer:pprp 题意如下: Description The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every o

poj2349最小生成树prim

Arctic Network Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 23359   Accepted: 7170 Description The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication tec

POJ2349:Arctic Network(二分+最小生成树)

Arctic Network Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 28311   Accepted: 8570 题目链接:http://poj.org/problem?id=2349 Description: The Department of National Defence (DND) wishes to connect several northern outposts by a wireless net