CSU 1333: Funny Car Racing(SPFA)13年省赛题

1333: Funny Car Racing

Time Limit: 1 Sec  Memory Limit: 128 MB

Submit: 482  Solved: 116

[Submit][Status][Web
Board
]

Description

There is a funny car racing in a city with n junctions and m directed roads.

The funny part is: each road is open and closed periodically. Each road is associate with two integers (ab), that means the road will be open for a seconds, then closed for b seconds, then open for a seconds...
 All these start from the beginning of the race. You must enter a road when it‘s open, and leave it before it‘s closed again.

Your goal is to drive from junction s and arrive at junction t as early as possible. Note that you can wait at a junction even if all its adjacent roads are closed.

Input

There will be at most 30 test cases. The first line of each case contains four integers n, m, s, t (1<=n<=300, 1<=m<=50,000, 1<=s,t<=n). Each of the next m lines contains five integers u, v, a, b, t (1<=u,v<=n, 1<=a,b,t<=105), that means there is a road
starting from junction u ending with junction v. It‘s open for a seconds, then closed for b seconds (and so on). The time needed to pass this road, by your car, is t. No road connects the same junction, but a pair of junctions could be connected by more than
one road.

Output

For each test case, print the shortest time, in seconds. It‘s always possible to arrive at t from s.

Sample Input

3 2 1 31 2 5 6 32 3 7 7 63 2 1 31 2 5 6 32 3 9 5 6

Sample Output

Case 1: 20Case 2: 9

HINT

Source

湖南省第九届大学生计算机程序设计竞赛

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
#define ll long long
const ll INF  = 1LL<<60 ;
const ll N = 305 ;

struct EDG
{
    ll to , next ;
    ll a , b , c , d ;
} edg[50010];
ll eid , head[N] ;
ll dis[N] ;
void init()
{
    eid = 0;
    memset(head , -1 , sizeof(head));
    for(ll i = 0 ; i < N ; i++)
        dis[i] = INF ;
}
void addEdg(ll u , ll v , ll a , ll b , ll c)
{
    edg[eid].to = v ;
    edg[eid].next = head[u] ;
    edg[eid].a = a ;
    edg[eid].b = b ;
    edg[eid].c = c ;
    edg[eid].d = a + b ;
    head[u] = eid++;
}
void spfa(ll s , ll t)
{
    queue<ll>q;
    bool inq[N] = { 0 } ;
    ll u , v ;
    dis[s] = 0 ;
    if(s != t )
        q.push( s ) ;
    while(!q.empty())
    {
        u = q.front() ;
        q.pop() ;
        inq[u] = 0 ;
        for(ll i = head[u] ; i!=-1; i=edg[i].next)
        {
            v = edg[i].to ;
            ll tt = edg[i].a - (dis[u]%edg[i].d);
            if(tt<edg[i].c)
                tt += edg[i].b ;
            else
                tt = 0 ;
            if(dis[v] > dis[u] + tt +edg[i].c)
            {
                dis[v] = dis[u] + tt +edg[i].c ;
                if(inq[v]==0&&v!=t)
                    inq[v] = 1 , q.push(v);
            }
        }
    }
}
int main()
{
    ll n , m , s , t , u , v , a , b , c ;
    ll T = 0;
    while(scanf("%lld%lld%lld%lld",&n,&m,&s,&t)>0)
    {
        init();
        while(m--)
        {
            scanf("%lld%lld%lld%lld%lld",&u , &v , &a , &b , &c) ;
            if(c<=a)
                addEdg( u , v , a , b , c );
        }
        spfa(s  , t ) ;
        if(dis[t]==INF)
            dis[t] = -1;
        printf("Case %lld: %lld\n",++T,dis[t]);
    }
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-12 14:09:59

CSU 1333: Funny Car Racing(SPFA)13年省赛题的相关文章

CSU 1329: 一行盒子(双向链表)经典 13年省赛题

1329: 一行盒子 Time Limit: 1 Sec  Memory Limit: 128 MB Submit: 872  Solved: 176 [Submit][Status][Web Board] Description 你有一行盒子,从左到右依次编号为1, 2, 3,-, n.你可以执行四种指令: 1 X Y表示把盒子X移动到盒子Y左边(如果X已经在Y的左边则忽略此指令). 2 X Y表示把盒子X移动到盒子Y右边(如果X已经在Y的右边则忽略此指令). 3 X Y表示交换盒子X和Y的位

CSU 1333 Funny Car Racing (最短路)

题目链接: http://acm.csu.edu.cn/OnlineJudge/problem.php?id=1333 解题报告:一个图里面有n个点和m条单向边,注意是单向边,然后每条路开a秒关闭b秒,问从s点到t点的最短时间.一个简单的最短路稍微变了一下. 卡了很久就因为没看到边是单向边,无语.可以用队列优化. 1 #include<cstdio> 2 #include<cstring> 3 #include<iostream> 4 #include<algor

CSU 1333: Funny Car Racing 最短路

题目连接:http://acm.csu.edu.cn/OnlineJudge/problem.php?id=1333 题意:给你一个n个顶点,m条边(每条边都有三个参数,开放时间,关闭时间,和通过这条边的时间)的有向图: 要你求从s 到 t 的最短路:dijkstra算法可解: 坑点:我用的是队列优化+Vector存储每条边: 在每次调用dijkstra后,必须初始化邻接表,在这个地方坑了好久,这是第二次了,以后记住 如果用vector就要初始化~ 附上代码: #include <iostrea

CSU 1335: 高桥和低桥(扫描线) 13年省赛题

1335: 高桥和低桥 Time Limit: 1 Sec  Memory Limit: 128 MB Submit: 957  Solved: 279 [Submit][Status][Web Board] Description 有个脑筋急转弯是这样的:有距离很近的一高一低两座桥,两次洪水之后高桥被淹了两次,低桥却只被淹了一次,为什么?答案是:因为低桥太低了,第一次洪水退去之后水位依然在低桥之上,所以不算"淹了两次".举例说明: 假定高桥和低桥的高度分别是5和2,初始水位为1 第一

CSU 1511 残缺的棋盘 第十届湖南省赛题

题目链接:http://acm.csu.edu.cn/OnlineJudge/problem.php?id=1511 题目大意:在一个8*8的棋盘中,给你一个起点位置和一个终点位置,同时也给你一个陷阱位置,问你从起点绕过陷阱到终点的最短距离.(可以上下左右走还可以斜走) 解题思路:可以直接用搜索,也可以用数学知识来解决,我们之前学过,两点之间直接最短,所以当陷阱不在这条直线上的时候,我们就不用考虑陷阱了,直接是max(abs(x1-y1),abs(x2-y2))最终结果, 但是如果陷阱在两条直线

CSU 1507 超大型LED显示屏 第十届湖南省赛题

题目链接:http://acm.csu.edu.cn/OnlineJudge/problem.php?id=1507 解题思路:这是一道模拟题,看了那么多人的代码,我觉得我的代码是最简的,哈哈,其实就是分数变幻的时候要计算灯管的亮数复杂一点,我就直接暴力咯 AC代码: #include <iostream> #include <cstdio> #include <cstdlib> #include <cstring> using namespace std;

CSU OJ 1112机器人的指令 (湖南省12年省赛题)

 Welcome to CSU Online Judge! 1112: 机器人的指令 Time Limit: 1 Sec  Memory Limit: 128 MB Submit: 274  Solved: 97 [Submit][Status][Web Board] Description 数轴原点有一个机器人.该机器人将执行一系列指令,你的任务是预测所有指令执行完毕之后它的位置. ·LEFT:往左移动一个单位 ·RIGHT: 往右移动一个单位 ·SAME AS i: 和第i 条执行相同的

13杭州区域赛现场赛Rabbit Kingdom(树状数组+离线)

题意:给你一个长度数列,再给你m个询问(一个区间),问你在这个区间里面有多少个数与其他的数都互质. 解题思路:你看这种类型的题目都可以肯定这是 离线+树状数组(线段树).主要就是他的更新信息.这里我的处理是先把1-200000(每个数的范围)数里面所有的质因子求出来.然后从后往前遍历数组.会出现以下几种情况 1.a[k]的质因子在后面出现过而[更新标记] 和[被更新标记] 都为假 2.a[k]的质因子在后面出现过的那个位置 I   [更新标记]为 真 . 3.a[k]的质因子在后面出现过且那个位

[问题2014S14] 复旦高等代数II(13级)每周一题(第十四教学周)

[问题2014S14]  设 V 为酉空间, 证明: 不存在 V 上的非零线性变换 φ , 使得对 V 中任一向量 v 均有 (φ(v),v)=0. 注  本题是复旦高代教材 P326 习题 9.1.5 的推广. [问题2014S14] 复旦高等代数II(13级)每周一题(第十四教学周),布布扣,bubuko.com