hdu 1679 The Unique MST 次小生成树 简单题

The Unique MST

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 21737   Accepted: 7692

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V‘, E‘), with the following properties:

1. V‘ = V.

2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E‘) of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all
the edges in E‘.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a
triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string ‘Not Unique!‘.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

转载请申明原博客地址:http://blog.csdn.net/lionel_d

怎么判断生成树唯一不唯一呢?
只要判断他的次小生成树的总权值与最小生成树的总权值想不想等就可以了,如果相等的话,就说明,最小生成树不唯一,不相等的话,,,自然唯一啦!
次小生成树的求法,就是枚举边,然后再删除边,不断求次小的权值;
具体看博客:http://www.cnblogs.com/hxsyl/p/3290832.html
看代码:
#include <stdio.h>
#include <string.h>
#define MAX 110
#define INF 1000000000
int graph[MAX][MAX] , max[MAX][MAX];
bool used[MAX][MAX],visited[MAX] ;

int prim(int n)
{
	int lowCost[MAX],closest[MAX];
	memset(visited,false,sizeof(visited)) ;
	memset(used,false,sizeof(used)) ;
	for(int i = 1 ; i <= n ; ++i)
	{
		lowCost[i] = graph[1][i] ;
		closest[i] = 1 ;
	}
	visited[1] = true ;
	int sum=0;
	for(int i = 0 ; i < n-1  ; ++i)
	{
		int min = INF , index = -1 ;
		for(int j = 1 ; j <= n ; ++j)
		{
			if(!visited[j] && min > lowCost[j])
			{
				min = lowCost[j];
				index = j ;
			}
		}
		if(index == -1)
		{
			break ;
		}
		sum += lowCost[index] ;
		visited[index] = true ;
		used[index][closest[index]] = used[closest[index]][index] = true ;
		for(int j = 1 ; j <= n ; ++j)
		{
			if(visited[j] && index != j)
			{
				max[j][index] = max[index][j] = lowCost[index]>max[j][closest[index]]?lowCost[index]:max[j][closest[index]];
			}
			if(!visited[j] && lowCost[j]>graph[index][j])
			{
				lowCost[j] = graph[index][j] ;
				closest[j] = index ;
			}
		}
	}
	return sum ;
}

int main()
{
	int t ;
	scanf("%d",&t) ;
	while(t--)
	{
		int n , m;
		scanf("%d%d",&n,&m) ;
		for(int i = 0 ; i <= n ; ++i)
		{
			graph[i][i] = INF ;
			for(int j = 0 ; j < i ; ++j)
			{
				graph[i][j] = graph[j][i] = INF ;
			}
		}
		for(int i = 0 ; i < m ; ++i)
		{
			int xi,yi,wi;
			scanf("%d%d%d",&xi,&yi,&wi);
			graph[xi][yi] = graph[yi][xi] = wi ;
		}
		int sum = prim(n) , t = INF ;
		for(int i = 1 ; i <= n ; ++i )
		{
			for(int j = 1 ; j < i ; ++j)
			{
				if(!used[i][j] && graph[i][j] != INF)
				{
					int r = sum-max[i][j]+graph[i][j];
					t = t>r?r:t ;
				}
			}
		}
		if(sum == t)
		{
			puts("Not Unique!") ;
		}
		else
		{
			printf("%d\n",sum) ;
		}
	}
	return 0 ;
}

与君共勉

时间: 2024-10-14 15:28:31

hdu 1679 The Unique MST 次小生成树 简单题的相关文章

poj 1679 The Unique MST (次小生成树)

The Unique MST Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 20293   Accepted: 7124 Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Consider a connected, undire

poj 1679 The Unique MST (次小生成树(sec_mst)【kruskal】)

The Unique MST Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 35999   Accepted: 13145 Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Consider a connected, undir

POJ - 1679 The Unique MST(次小生成树)

版权声明:本文为博主原创文章,未经博主允许不得转载.

POJ_1679_The Unique MST(次小生成树模板)

The Unique MST Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 23942   Accepted: 8492 Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Consider a connected, undire

[POJ1679]The Unique MST 次小生成树

题目链接:http://poj.org/problem?id=1679 给你一个图的连通情况,询问你此图的最小生成树是否唯一. 假如最小生成树唯一,即生成树连通所有节点的权值和唯一.假如不唯一,那么存在另一条最小生成树使得权值等于之前最小生成树的权值. 换个思路考虑,也就是次小生成树的权值与最小生成树的权值相同,那么问题就变成了求次小生成树的权值. 我选择的是先求出最小生成树,将树上用到的边都保存下来.接着分别将每一条用到的边摘下来,再求一次最小生成树.假如不包含当前删掉的边生成的生成树的所选边

hdu 1679 The Unique MST (克鲁斯卡尔)

The Unique MST Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 24152   Accepted: 8587 Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Consider a connected, undire

hdu 4463 Outlets Prim 次小生成树 简单题

Outlets Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2200    Accepted Submission(s): 1028 Problem Description In China, foreign brand commodities are often much more expensive than abroad. T

POJ - 1679 The Unique MST (次小生成树)

Description Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the followin

poj 1679 The Unique MST 【次小生成树】【模板】

题目:poj 1679 The Unique MST 题意:给你一颗树,让你求最小生成树和次小生成树值是否相等. 分析:这个题目关键在于求解次小生成树. 方法是,依次枚举不在最小生成树上的边,然后添加到最小生成树上,然后把原树上添加了之后形成环的最长的边删去,知道一个最小的.就是次小生成树. 这些需要的都可以在求解最小生成树的时候处理出来. AC代码: #include <cstdio> #include <cstring> #include <iostream> #i