HDU 1045——Fire Net——————【最大匹配、构图、邻接矩阵做法】

Fire Net

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Submit Status Practice HDU 1045

Description

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.‘ indicating an open space and an uppercase ‘X‘ indicating a wall. There are no spaces in the input file.

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample Input

4

.X..

....

XX..

....

2

XX

.X

3

.X.

X.X

.X.

3

...

.XX

.XX

4

....

....

....

....

0

Sample Output

5

1

5

2

4

题目大意:给你n*n的矩阵,里面有些位置有墙。要在空地方放上炮弹,导弹会攻击上下左右四个方向,导弹的攻击不能通过墙即碰到墙就停止了。问你最多能在里面放入多少个炮弹。

解题思路:由于有墙的阻隔,所以不能简单地将行列直接分为二部。所以考虑一行中,如果遇到墙,可以认为是已经换行了,让行数加一。同样,列也这样考虑。在我们呢这种意义下的行列有交汇的地方,连一条边。求最大匹配。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
int vis[110][110], G[110][110], linker[110], used[110];
char Map[110][110];
bool dfs(int u,int _n){
    for(int v = 1; v <= _n; v++){
        if(G[u][v] && !used[v]){
            used[v] = u;
            if(linker[v] == -1 || dfs(linker[v],_n)){
                linker[v] = u;
                return true;
            }
        }
    }
    return false;
}
int hungary(int un,int vn){
    int ret = 0;
    memset(linker,-1,sizeof(linker));
    for(int i = 1; i <= un; i++){
        memset(used,0,sizeof(used));
        if(dfs(i,vn))
            ret++;
    }
    return ret;
}
int main(){
    int n;
    while(scanf("%d",&n)!=EOF&&n){

        for(int i = 1; i <= n; i++){
            getchar();
            for(int j = 1; j <= n; j++){
                scanf("%c",&Map[i][j]);
            }
        }
        memset(vis,0,sizeof(vis));
        int vn = 0, flag;
        for(int i = 1; i <= n; i++){
            flag = 1;
            for(int j = 1; j <= n; j++){
                if(Map[i][j] == ‘X‘){
                    flag = 1;
                }else{
                    if(flag) {
                        vn++;
                        flag = 0;
                    }
                    vis[i][j] = vn;
                }
            }
        }
        memset(G,0,sizeof(G));
        int un = 0;
        for(int j = 1; j <= n; j++){
            flag = 1;
            for(int i = 1; i <= n; i++){
                if(Map[i][j] == ‘X‘){
                    flag = 1;
                }else{
                    if(flag){
                        un++;
                        flag = 0;
                    }
                    G[un][vis[i][j]] = 1;
                }
            }
        }
        int ans = hungary(un,vn);
        printf("%d\n",ans);
    }
    return 0;
}

  

时间: 2024-08-24 13:32:10

HDU 1045——Fire Net——————【最大匹配、构图、邻接矩阵做法】的相关文章

HDU 1045 - Fire Net (最大独立集)

题意:给你一个正方形棋盘.每个棋子可以直线攻击,除非隔着石头.现在要求所有棋子都不互相攻击,问最多可以放多少个棋子. 这个题可以用搜索来做.每个棋子考虑放与不放两种情况,然后再判断是否能互相攻击来剪枝.最后取可以放置的最大值. 这里我转化成求最大独立集来做. 首先将每个空地编号,对于每个空地,与该位置可以攻击到的空地连边.找最多的空地使得不互相攻击,即求该图的最大独立集.与搜索做法基本一致,但是说法略有不同. 1 #include<iostream> 2 #include<cstring

HDU 1045 Fire Net 贪心

Problem Description Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. A blockhouse is a small castle that has four openings through wh

hdu 1045 Fire Net(最小覆盖点+构图(缩点))

http://acm.hdu.edu.cn/showproblem.php?pid=1045 Fire Net Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 1045 Description Suppose that we have a square city with straight streets. A map of a city

HDU 1045 Fire Net(图匹配)

题目大意: 这个是以前做过的一道DFS题目,当时是完全暴力写的. 给你一个N代表是N*N的矩阵,矩阵内 ‘X’代表墙, ‘.’代表通道. 问这个矩阵内最多可以放几个碉堡, 碉堡不能在同一行或者同一列,除非他们中间有墙. 二分图做法思想:我们用行去匹配列,判断最大匹配数. 我们需要重新构图, 假如一行中 (  ..X..X.. ) 那么在这一行中我们其实是可以分割到三个不同的行(因为中间隔有X).然后对这个三个行进行编号.同理列也是一样的.当我们完全构好图后就可以做完全匹配了,其他的跟HDU 10

HDU 1045 Fire Net 状压暴力

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1045 Fire Net Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 8073    Accepted Submission(s): 4626 Problem Description Suppose that we have a squar

HDU 1045 Fire Net(dfs,跟8皇后问题很相似)

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1045 Fire Net Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 14670    Accepted Submission(s): 8861 Problem Description Suppose that we have a squar

HDU 1045 Fire Net(缩点求最大匹配)

Problem Description: Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. A blockhouse is a small castle that has four openings through w

HDU - 1045 Fire Net (二分图最大匹配-匈牙利算法)

(点击此处查看原题) 匈牙利算法简介 个人认为这个算法是一种贪心+暴力的算法,对于二分图的两部X和Y,记x为X部一点,y为Y部一点,我们枚举X的每个点x,如果Y部存在匹配的点y并且y没有被其他的x匹配,那就直接匹配:如果Y中已经没有可以和x匹配的点(包括可以匹配的点已经被其他的x匹配),那就让已经匹配的y的原配x'寻找其他可以匹配的y’,并将y和x匹配,最后,统计出匹配的对数 (详细了解的话,可以看看这位的博客:https://blog.csdn.net/sunny_hun/article/de

HDU 1045 Fire Net (二分匹配)

Fire Net Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Description Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street