CDZSC_2015寒假新人(4)——搜索 N

Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this. 
The following commands need to be supported: 
BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored. 
FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored. 
VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied. 
QUIT: Quit the browser. 
Assume that the browser initially loads the web page at the URL http://www.acm.org/

Input

Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.

Output

For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

Sample Input

VISIT http://acm.ashland.edu/
VISIT http://acm.baylor.edu/acmicpc/
BACK
BACK
BACK
FORWARD
VISIT http://www.ibm.com/
BACK
BACK
FORWARD
FORWARD
FORWARD
QUIT

Sample Output

http://acm.ashland.edu/
http://acm.baylor.edu/acmicpc/
http://acm.ashland.edu/
http://www.acm.org/
Ignored
http://acm.ashland.edu/
http://www.ibm.com/
http://acm.ashland.edu/
http://www.acm.org/
http://acm.ashland.edu/
http://www.ibm.com/
Ignored

思路:这题模拟栈。自己开一个数组和栈头指针和栈尾指针来模拟。。。。。坑点:因为浏览器的特点当你在前进后退的途中输入一个网站,那么他那么这个网站的位置到栈尾的网站全部清空了,也就是说栈尾就是你输入的这个网站。
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char str[100][130];
int main()
{
#ifdef CDZSC_OFFLINE
    freopen("in.txt","r",stdin);
#endif
    char str1[10],a[100];
    int n,m;
    n=0,m=0;
    memset(str,0,sizeof(str));
    strcpy(str[0],"http://www.acm.org/");
    while(scanf("%s",str1)!=EOF)
    {
        if(strcmp(str1,"VISIT")==0)
        {
            scanf("%s",a);
            strcpy(str[++n],a);
            m=n;//后面的网站会被清空
            printf("%s\n",str[m]);
        }
        else if(strcmp(str1,"BACK")==0)
        {
            n--;
            if(n<0)
            {
                n=0;
                printf("Ignored\n");
            }
            else
            {
                printf("%s\n",str[n]);
            }
        }
        else if(strcmp(str1,"FORWARD")==0)
        {
            n++;
            if(n>m)
            {
                n=m;
                printf("Ignored\n");
            }
            else
            {
                printf("%s\n",str[n]);
            }
        }
        else if(strcmp(str1,"QUIT")==0)
        {
            break;
        }
    }
    return 0;
}
时间: 2024-10-12 08:08:29

CDZSC_2015寒假新人(4)——搜索 N的相关文章

CDZSC_2015寒假新人(4)——搜索 G

Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会. 魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟

CDZSC_2015寒假新人(4)——搜索 A

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and

CDZSC_2015寒假新人(4)——搜索 L

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description A message from humans to extraterrestrial intelligence was sent through the Arecibo radio telescope in Puerto Rico on the afternoon of Saturday November 16, 1974

CDZSC_2015寒假新人(4)——搜索 - P

Description  Parentheses Balance  You are given a string consisting of parentheses () and []. A string of this type is said to be correct: (a) if it is the empty string (b) if A and B are correct, AB is correct, (c) if A is correct, (A ) and [A ] is

CDZSC_2015寒假新人(4)——搜索 C

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two butto

CDZSC_2015寒假新人(4)——搜索 B

Description There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only

CDZSC_2015寒假新人(4)——搜索 - D

Description You're in space. You want to get home. There are asteroids. You don't want to hit them. Input Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following de

CDZSC_2015寒假新人(4)——搜索 F

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth

CDZSC_2015寒假新人(4)——搜索 H

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description Hiking in the mountains is seldom an easy task for most people, as it is extremely easy to get lost during the trip. Recently Green has decided to go on a hiking