F - City Game

F - City Game

Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Bob is a strategy game programming specialist. In his new city building game the gaming environment
is as follows: a city is built up by areas, in which there are streets, trees, factories and buildings. There
is still some space in the area that is unoccupied. The strategic task of his game is to win as much
rent money from these free spaces. To win rent money you must erect buildings, that can only be
rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible
building in each area. But he comes across some problems — he is not allowed to destroy already
existing buildings, trees, factories and streets in the area he is building in.
Each area has its width and length. The area is divided into a grid of equal square units. The rent
paid for each unit on which you’re building stands is 3$.
Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of
the areas is rectangular and has a different grid size with its own length M and width N. The existing
occupied units are marked with the symbol ‘R’. The unoccupied units are marked with the symbol ‘F’.
Input
The first line of the input file contains an integer K — determining the number of datasets. Next lines
contain the area descriptions. One description is defined in the following way: The first line contains
two integers-area length M ≤ 1000 and width N ≤ 1000, separated by a blank space. The next M
lines contain N symbols that mark the reserved or free grid units, separated by a blank space. The
symbols used are:
R - reserved unit
F - free unit
In the end of each area description there is a separating line.
Output
For each data set in the input file print on a separate line, on the standard output, the integer that
represents the profit obtained by erecting the largest building in the area encoded by the data set.
Sample Input
2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F
5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R
Sample Output
45
0

题解:给定一个m*n的矩阵,其中一些格子是空地(F),其他障碍是(R),找到一个全部由F组成的面积最大的子矩阵,输出其面积乘3的结果

大致思路,扫描法,扫描他的运动极限。

#include<stdio.h>
#include<string.h>
int main()
{
    char s[2];
    int l[1001],r[1001],d[2][1001];
    int i,j,n,m,t,max,res;
    scanf("%d",&t);
    while(t--)
    {
        memset(d,0,sizeof(d));
        scanf("%d%d",&n,&m);
        res=0;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {
                scanf("%s",s);
                if(s[0]==‘F‘)
                    d[i%2][j]=d[(i-1)%2][j]+1;    //滚动数组
                else
                    d[i%2][j]=0;
                l[j]=r[j]=j;
            }
            for(j=2;j<=m;j++)
            {
                while(l[j]>1&&d[i%2][l[j]-1]>=d[i%2][j])
                    l[j]=l[l[j]-1];
            }  //向左延伸
            for(j=m-1;j>=1;j--)
            {
                while(r[j]<m&&d[i%2][r[j]+1]>=d[i%2][j])
                    r[j]=r[r[j]+1];
            }  //向右延伸
            max=0;
            for(j=1;j<=m;j++)
                if((r[j]-l[j]+1)*d[i%2][j]>max)
                    max=(r[j]-l[j]+1)*d[i%2][j];
            if(max>res)
                res=max;
        }
        printf("%d\n",res*3);
    }
    return 0;
}
时间: 2024-12-15 07:01:08

F - City Game的相关文章

Designing Efficient Algorithms [Examples]~F - City Game

Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees, factories and buildings. There is still some space in the area that is

HDU 1505 City Game (hdu1506 dp二维加强版)

F - City Game Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 1505 Appoint description: Description Bob is a strategy game programming specialist. In his new city building game the gaming enviro

Linq练习

首先在Program.cs的Main()方法下添加如下代码: string[] names = { "heh", "haha", "huahua", "kuku" }; 1.取得以h开头的名称: (查询语法) var queryResult = from n in names where n.StartsWith("h") select n; (方法语法) var queryResult = names.W

【Java 面试】面试

一. 笔试题之Java基础部分 基础部分的顺序:基本语法,类相关的语法,内部类的语法,继承相关的语法,异常的语法,线程的语法,集合的语法,io 的语法,虚拟机方面的语法,其他.有些题来自网上搜集整理,有些题来自传智播客学员面试后的反馈,说真的,少数一些网上的面试题,我真怀疑其是否还有存在价值! 1.一个".java"源文件中是否可以包括多个类(不是内部类)?有什么限制? 可以有多个类,但只能有一个public的类,并且public的类名必须与文件名相一致. 2.Java有没有goto?

经典图算法Java代码实践:BFS,DFS以及几种最短路径算法

public class City { String name; int id; static int idCounter = 0; public City(String name) { this.name=name; id = idCounter++; } } import java.util.ArrayList; public class Graph { public static void main(String[] args) { // TODO Auto-generated metho

LinqToSql初探

LINQ TO SQL是一种轻量级的ORM框架,它对ADO.NET进行了轻量级的封装,讲数据库原封不动的映射成模型,常用于中小型项目,优点:简单.缺点:数据库模型过于复杂时,可能不满足开发要求. LINQ语句: 简单类型查询(string): using System; using System.Collections.Generic; using System.Linq; using System.Text; namespace LINQ { class Program { public de

silicon labs 代理商

http://www.silabs.com/buysample/pages/contact-sales.aspx?SearchLocation=China Silicon Labs Authorized Semiconductor Distributors: China To order Silicon Labs products, contact a distributor below: China Distributor Office Location Telephone Email Arr

Java面试宝典2013版(超长版)

一. Java基础部分......................................................................................................2 1.一个".java"源文件里能否够包含多个类(不是内部类)?有什么限制?.....2 2.Java有没有goto?........................................................................

BestCoder Round #32

PM2.5 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 613    Accepted Submission(s): 326 Problem Description Nowadays we use content of PM2.5 to discribe the quality of air. The lower content of