hdu5172---GTY's gay friends

Problem Description

GTY has n gay friends. To manage them conveniently, every morning he ordered all his gay friends to stand in a line. Every gay friend has a characteristic value ai , to express how manly or how girlish he is. You, as GTY’s assistant, have to answer GTY’s queries. In each of GTY’s queries, GTY will give you a range [l,r] . Because of GTY’s strange hobbies, he wants there is a permutation [1..r?l+1] in [l,r]. You need to let him know if there is such a permutation or not.

Input

Multi test cases (about 3) . The first line contains two integers n and m ( 1≤n,m≤1000000 ), indicating the number of GTY’s gay friends and the number of GTY’s queries. the second line contains n numbers seperated by spaces. The ith number ai ( 1≤ai≤n ) indicates GTY’s ith gay friend’s characteristic value. The next m lines describe GTY’s queries. In each line there are two numbers l and r seperated by spaces ( 1≤l≤r≤n ), indicating the query range.

Output

For each query, if there is a permutation [1..r?l+1] in [l,r], print ‘YES’, else print ‘NO’.

Sample Input

8 5 2 1 3 4 5 2 3 1 1 3 1 1 2 2 4 8 1 5 3 2 1 1 1 1 1 1 2

Sample Output

YES NO YES YES YES YES NO

Source

BestCoder Round #29

Recommend

hujie | We have carefully selected several similar problems for you: 5173 5169 5168 5165 5164

如果一个区间里是一个[1, … , r - l + 1]的排列,那么首先,区间和是

x * (x + 1) / 2, –>前缀和处理

其次每一个数都不同,预处理每一个数上一次出现的位置pre,然后求出区间里pre的最大值,如果最大的pre小于左端点且区间和是 x * (x + 1) / 2,那么输出YES,否则NO,这里可以用线段树解决

注意判断时,最好先判断区间和,如果这里已经不满足了,就别去查询线段树了,否则容易造成TLE

/*************************************************************************
    > File Name: hdu5172.cpp
    > Author: ALex
    > Mail: [email protected]
    > Created Time: 2015年02月14日 星期六 12时49分13秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const double pi = acos(-1);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

const int N = 1000010;
int pre[N];
LL sum[N];
int _hash[N];

struct node
{
    int l, r;
    int val;
}tree[N << 2];

void build (int p, int l, int r)
{
    tree[p].l = l;
    tree[p].r = r;
    if (l == r)
    {
        tree[p].val = pre[l];
        return;
    }
    int mid = (l + r) >> 1;
    build (p << 1, l, mid);
    build (p << 1 | 1, mid + 1, r);
    tree[p].val = max (tree[p << 1].val, tree[p << 1 | 1].val);
}

int query (int p, int l, int r)
{
    if (tree[p].l == l && tree[p].r == r)
    {
        return tree[p].val;
    }
    int mid = (tree[p].l + tree[p].r) >> 1;
    if (r <= mid)
    {
        return query (p << 1, l, r);
    }
    else if (l > mid)
    {
        return query (p << 1 | 1, l, r);
    }
    else
    {
        return max (query (p << 1, l, mid), query (p << 1 | 1, mid + 1, r));
    }
}

int main ()
{
    int n, m;
    while (~scanf("%d%d", &n, &m))
    {
        memset (_hash, -1, sizeof(_hash));
        memset (sum, 0, sizeof(sum));
        int x, l, r;
        for (int i = 1; i <= n; ++i)
        {
            scanf("%d", &x);
            pre[i] = _hash[x];
            _hash[x] = i;
            sum[i] = sum[i - 1] + (LL)x;
        }
        build (1, 1, n);
        while (m--)
        {
            scanf("%d%d", &l, &r);
            LL len = (LL)(r - l + 1);
            len = (len + 1) * len / 2;
            if (len != sum[r] - sum[l - 1])
            {
                printf("NO\n");
                continue;
            }
            int res = query (1, l, r);
            if (res < l)
            {
                printf("YES\n");
            }
            else
            {
                printf("NO\n");
            }
        }
    }
    return 0;
}

hdu5172---GTY's gay friends

时间: 2024-10-27 19:05:06

hdu5172---GTY's gay friends的相关文章

HDU 5172 GTY&#39;s gay friends (线段树)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5172 题意: 给你一个n个数的数组,m次询问,询问在[L, R] 这个区间里面有没有 [1, R-L+1] 的数. 题解: 判断有没有 1 ~ R-L+1 其实就是判断这一段区间和是不是等于 (R-L+1)*(R-L+1+1)/ 2 . 当然还有就是每一个数只能出现1次. 这个问题我们应该怎么解决呢. 我们可以记录第i个数x 的前一个x出现的位置.如果x的前一个x也出现在[L, R]里面,那么这一段

【BestCoder】#29 C GTY&#39;s gay friends(区间和 随机数判重)

题目大意:可以到相应的场次查看中文翻译. 思路:其实这道题很简单,对于一个等差数列,我们要判断他是否每个数都出现,只需要判断区间和或者是最大值是否符合即可,但这边需要注意的便是中间的重复部分.最大值的判重必要性我就不知道了,而且我也不会做,目测做也超时. 这边就写一下偷别人的区间和+随机数判重的做法 其实这边判重的方法是给一个数加上一个超过1000007的权,然后在计算和的时候,便是唯一的. 否则例如下面的情况 10 11的和可以由5和16构成,既然两个的和可以被另外一个的两个数替代,那我们就找

HDU - 5172 GTY&#39;s gay friends

题目链接 题意:n个数m个查询,问[l,r]中的数是否为1到r-l+1的一个排列. 做法1:hash一下,对于[1...n],每个数都随机分配一个hash值,一个集合的hash值为元素异或和.预处理出[1...n]的hash值及其前缀的hash,然后就可以O(1)查询了 #include<cstdio> #include<cstring> #include<iostream> #include<algorithm> #include<cstdlib&g

GTY&#39;s gay friends 线段树判断区间是否有相同数字

http://acm.hdu.edu.cn/showproblem.php?pid=5172 判断一个区间是否为全排列是: 1.区间总和 = (1 + R - L + 1) * (R - L + 1) / 2; 2.区间没有重复数字 记录数组a[i]表示第i个数上一次在那个位置出现. 那么最需要在[L, R]中a[i]的最大值 >= L的,就是有重复数字了. #include <bits/stdc++.h> #define IOS ios::sync_with_stdio(false)

hdu 5172 GTY&#39;s gay friends(线段树最值)

题意: GTY有n个朋友,站成一排,每个人有一个特征值ai. 有m个询问.每次询问给两个数L,R.问你[L,R](即aL...aR)是否是1..(R-L+1)的一个全排列. 是输出YES,否则输出NO 思路: 先判断是否segma(a[L,R])是否等于(R-L)*(R-L+1)/2. 记录每一个ai上一次的位置pre[i]. 这样只要判断a[L]...a[R]中的每一个pre[i]是否都小于L即可.(这个方法太妙) 线段树区间求最大值. *用map效率明显下降. 代码: int const N

hdu 5172 GTY&#39;s gay friends 线段树

GTY's gay friends 问题描述 GTY有n个基友,出于某种恶趣味,GTY每天早上会让他的基友们排成一行,每个基友有一个特征值,表示基友有多雄壮或娘炮,你,作为GTY的助手,必须回答GTY的每个询问,GTY每次会问一个区间[l,r][l,r]是否为一个11到r-l+1r−l+1的排列. 输入描述 多组数据(约3组),每组数据的第一行有两个数n,m(1 \leq n,m \leq 100000)n,m(1≤n,m≤100000) 表示初始基友数量和询问个数,第二行包含nn个数a_i (

HDU 5172 GTY&#39;s gay friends(线段树)

Problem Description GTY has n gay friends. To manage them conveniently, every morning he ordered all his gay friends to stand in a line. Every gay friend has a characteristic value ai , to express how manly or how girlish he is. You, as GTY's assista

BestCoder Round #29 GTY&#39;s gay friends

#include <cstdio>#include <cstring>#include <vector>#include <algorithm>using namespace std;const int MAX = 100000+10;int res[MAX<<2],ans[MAX],t[MAX];int a[MAX],last[MAX];struct node {    int L,R,id,d;    bool operator <(c

BestCoder Round #29 1003 (hdu 5172) GTY&#39;s gay friends [线段树 判不同 预处理 好题]

传送门 GTY's gay friends Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 264    Accepted Submission(s): 57 Problem Description GTY has n gay friends. To manage them conveniently, every morning he o

HDU 5172 GTY&#39;s gay friends (预处理+线段树)

题目链接:HDU 5172 GTY's gay friends 题意:给出一串序列,询问[l,r]区间里是否存在1~l-r+1的一个排列. 思路:1~l-r+1的一个排列 等价于 [l,r]中元素互不相同且[l,r]区间和等于(1+len)*len/2(len=l-r+1). 区间和可以用前缀和来处理. 元素互不相同,记录位置i上a[i]上次出现的位置记做pre[i],再用线段树来维护区间的pre最大值,若最大值小于l说明[l,r]中元素互不相同.(区间[l,r]中的每个pre[i]小于l说明区