1573 Robot Motion

Robot Motion

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 10219   Accepted: 4977

Description

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)

S south (down the page)

E east (to the right on the page)

W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the
grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns
of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number
of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the
number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

Source

Mid-Central USA 1999

http://poj.org/problem?id=1573

//主要是判断是否构成循环,根据题目特点,可以设置一个标记数组,如果走过了就不能在走,直到退出循环。

用另外一个数组表示到这一个坐标的步数。那么退出循环的时候其实已经到以前走过的点,输出步数,然后循环节就是总步数减去当前步数。

#include<stdio.h>
#include<string.h>
int main()
{
	int n,m,k,l,p,step;
	char s[11][11];
	int map[11][11];
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		if(n==0||m==0)break;
		scanf("%d",&k);
		for(int i=0;i<n;i++)
			scanf("%s",s[i]);
		l=0;
		p=k-1;
		step=0;
		while(l>=0&&l<n&&p>=0&&p<m&&s[l][p]!='0')
		{
			if(s[l][p]=='N')
			{
				s[l][p]='0';
				map[l][p]=++step; //先计算当前步数,然后在改变坐标值
				l--;
			}
			else if(s[l][p]=='S')
			{
				s[l][p]='0';
				map[l][p]=++step;
				l++;
			}
			else if(s[l][p]=='E')
			{
				s[l][p]='0';
				map[l][p]=++step;
				p++;
			}
			else if(s[l][p]=='W')
			{
				s[l][p]='0';
				map[l][p]=++step;
				p--;
			}
		}
		if(s[l][p]=='0') //表示循环 了、
			printf("%d step(s) before a loop of %d step(s)\n",map[l][p]-1,step+1-map[l][p]);
		else printf("%d step(s) to exit\n",step);
	}
	return 0;
}

1573 Robot Motion

时间: 2024-12-05 16:21:22

1573 Robot Motion的相关文章

POJ 1573 Robot Motion(模拟)

题目代号:POJ 1573 题目链接:http://poj.org/problem?id=1573 Language: Default Robot Motion Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 14195   Accepted: 6827 Description A robot has been programmed to follow the instructions in its path. Instr

POJ 1573 Robot Motion【是搜索,就不要纠结是DFS还是BFS】

Robot Motion Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 12845   Accepted: 6234 Description A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in

Poj OpenJudge 百练 1573 Robot Motion

1.Link: http://poj.org/problem?id=1573 http://bailian.openjudge.cn/practice/1573/ 2.Content: Robot Motion Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 10856   Accepted: 5260 Description A robot has been programmed to follow the instru

POJ 1573 Robot Motion 搜索

Robot Motion Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6297    Accepted Submission(s): 2952 Problem Description A robot has been programmed to follow the instructions in its path. Instruc

poj 1573 Robot Motion

Description A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are N north (up the page) S south (down the page) E east (to t

69棋牌游戏源码,POJ 1573 Robot Motion模拟

主题:http://pj.org/Debug ID=1573    主要思想:棋盘上充满了N,E,S,W指令.人们按照棋盘的指示从北方的初始列开始移动,直到你下完棋或四处走动.    N意味着向北(向上)移动.    E意味着向东移动(右).    S意味着向南移动(下).    W意味着向西移动(左).    分析:因为棋盘只有10*10,也就是说最多只有100步,所以您可以使用模拟算法.我们声明一个用于记录指令的字符卡映射,以及一个初始值为零的象棋卡,用于记录所走过的路径.国际象棋棋局或发现

PKU 1573 Robot Motion(简单模拟)

原题大意:原题链接 给出一个矩阵(矩阵中的元素均为方向英文字母),和人的初始位置,问是否能根据这些英文字母走出矩阵.(因为有可能形成环而走不出去) 此题虽然属于水题,但是完全独立完成而且直接1A还是很开心的 注意:对于形成环的情况则从进入环的交点处重新走一遍,记录步数即可 #include<cstdio> #include<cstring> int n,m,p; bool vis[1010][1010]; char str[1010][1010]; bool can(int x,i

POJ 1573:Robot Motion

Robot Motion Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 10267   Accepted: 5001 Description A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in

poj1573 Robot Motion

题目链接: http://poj.org/problem?id=1573 题目: Robot Motion Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 10202   Accepted: 4971 Description A robot has been programmed to follow the instructions in its path. Instructions for the next direct