POJ1011 Sticks DFS+剪枝

Description

乔治拿来一组等长的木棒,将它们随机地砍断,使得每一节木棍的长度都不超过50个长度单位。然后他又想把这些木棍恢复到为裁截前的状态,但忘记了初始时有多少木棒以及木棒的初始长度。请你设计一个程序,帮助乔治计算木棒的可能最小长度。每一节木棍的长度都用大于零的整数表示。

Input

输入包含多组数据,每组数据包括两行。第一行是一个不超过64的整数,表示砍断之后共有多少节木棍。第二行是截断以后,所得到的各节木棍的长度。在最后一组数据之后,是一个零。

Output

为每组数据,分别输出原始木棒的可能最小长度,每组数据占一行。

Sample Input

9

5 2 1 5 2 1 5 2 1

4

1 2 3 4

0

Sample Output

6

5

解题思路

DFS思路不难,主要说剪枝(剪枝剪得不够好,47ms过的)

1.长度必须能整除sum

2.从最长的木棒开始搜就可以了

3.排序要从大到小排,灵活度从小到大

4.只要发现如果和自己相同的上一个边没有用到,那么这一个肯定也用不到

5.拼成ans-1条边就够了

6.在拼”新边”的时候,如果没有成功,直接就退出好了(因为最后一定全部都用上)

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 70;
int s[maxn];
int vis[maxn];
int n;
int ans;
bool cmp(int a,int b)
{
    return a>b;
}
bool dfs(int _sum,int node,int kase,int p,int floor)
{
    if(_sum > p) return false;
    if(kase == ans-1) return true;
    if(_sum == p && dfs(0,1,kase+1,p,1)) return true;
    for(int i = node ; i <= n ; i ++) {
        if(vis[i] == 1) continue;
        if(vis[i-1] == 0 && s[i-1] == s[i]) continue;
        vis[i] = 1;
        if(dfs(_sum+s[i],node+1,kase,p,2)) return true;
        if(floor == 1) {vis[i] = 0; return false;}
        vis[i] = 0;
    }
    return false;
}
int main()
{
    while(scanf("%d",&n) && n) {
        int sum = 0;
        for(int i = 1 ; i <= n ; i ++) {
            scanf("%d",&s[i]);
            sum += s[i];
        }
        sort(s+1,s+n+1,cmp);
        for(int i = s[1] ; i <= sum ; i ++) {
            if(i == sum) {printf("%d\n",i);break;}
            //拼成i长度的木棒
            if(sum%i) continue;
            ans = sum/i;
            memset(vis,0,sizeof(vis));
            if(dfs(0,1,0,i,1)) {
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}
时间: 2024-10-10 20:12:03

POJ1011 Sticks DFS+剪枝的相关文章

EOJ1981 || POJ1011 经典dfs+剪枝+奇怪的数据

题目:EOJ1981 || POJ1011   经典dfs+剪枝+奇怪的数据 Description George took sticks of the same length and cut them randomly until all partsbecame at most 50 units long. Now he wants to return sticks to the originalstate, but he forgot how many sticks he had origi

poj1011 Sticks DFS+回溯

转载请注明出处:http://blog.csdn.net/u012860063 题目链接:http://poj.org/problem?id=1011 Description George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but

[POJ 1011]Sticks(DFS剪枝)

Description George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were original

poj1011(DFS+剪枝)

题目链接:https://vjudge.net/problem/POJ-1011 题意:给定n(<=64)条木棍的长度(<=50),将这些木棍刚好拼成长度一样的若干条木棍,求拼出的可能的最小长度. 思路:经典的DFS剪枝题,这道题的剪枝技巧很关键. 数据不大,可以想到枚举木棍所有可能的长度,然后利用dfs来查找所有可能的搭配情况,dfs的参数len表示当前的木棍长度,rest表示还需要的长度,num表示原始木棍中剩余没有匹配的数量,搜索的终止条件为rest==0&&num==0

POJ 1011 - Sticks DFS+剪枝

POJ 1011 - Sticks 题意:    一把等长的木段被随机砍成 n 条小木条    已知他们各自的长度,问原来这些木段可能的最小长度是多少 分析:    1. 该长度必能被总长整除    2. 从大到小枚举,因为小长度更灵活, 可拼接可不拼接    3. 因为每一跟木条都要用到, 故若轮到其中一根原始木段选它的第一根木条时,若第一根木条若不满足,则显然第一根木条在接下来任何一根原始木段都不会满足,故无解    4. 由于所有棒子已排序,在DFS时,若某根棒子未被选,则跳过其后面所有与

POJ1011 Sticks 【剪枝】

Sticks Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 122771   Accepted: 28441 Description George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the or

UVa307 Sticks (DFS+剪枝)

链接:http://vjudge.net/problem/19648 分析:这题重要的是剪枝.maxd表示的是最小可能长度(把砍完的木棍长度降序排好,最小可能长度大于等于砍完后最长的木棍长度,小于等于总长度的一半,且木棍的根数是整数,所以(总长度%每段最小可能长度=0)),dfs的三个状态分别为cur表示当前要凑maxd长度的木棍已经凑好的长度,from表示从砍完后的第from根木棍开始考虑,cnt表示已经凑好maxd长度木棍的根数. 1.将所有木棍按长度从大到小排序,dfs组合木棍时优先使用长

POJ1011 (DFS+剪枝)

Sticks Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 129606   Accepted: 30388 Description George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the or

POJ 1011 Sticks dfs,剪枝 难度:2

http://poj.org/problem?id=1011 要把所给的集合分成几个集合,每个集合相加之和ans相等,且ans最小,因为这个和ans只在[1,64*50]内,所以可以用dfs一试 首先ans需要满足两个条件1.可以被总集合的和sum整除 2.是总集合的某个子集的和 对于条件1,可以通过试除遍历 对于条件2,可以通过dp预筛选,这两个花费时间都不大 接着搜索能不能划分成集合之和恰为ans的若干集合, 1. 可以从大向小找,因为大的更不灵活,而且所有的元素都需要取到 2.比如对于5,