HDUJ 1072 Nightmare 搜索

Nightmare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6992    Accepted Submission(s): 3354

Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is
set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute)
takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius‘ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:

1. We can assume the labyrinth is a 2 array.

2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.

3. If Ignatius get to the exit when the exploding time turns to 0, he can‘t get out of the labyrinth.

4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can‘t use the equipment to reset the bomb.

5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.

6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.

There are five integers which indicate the different type of area in the labyrinth:

0: The area is a wall, Ignatius should not walk on it.

1: The area contains nothing, Ignatius can walk on it.

2: Ignatius‘ start position, Ignatius starts his escape from this position.

3: The exit of the labyrinth, Ignatius‘ target position.

4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

Sample Input

3
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4
1 0 0 0 1 0 0 1
1 4 1 0 1 1 0 1
1 0 0 0 0 3 0 1
1 1 4 1 1 1 1 1 

Sample Output

4
-1
13
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;

int map[10][10];
int a,b,c,d;
int w[][2]={-1,0,1,0,0,-1,0,1};

struct node
{
	int x,y;
	int ans,time;
};

int bfs()
{
	node now,tmp;
	queue<node >   q;
	now.x=c;
	now.y=d;
	now.time=6;
	now.ans=0;
	map[c][d]=0;
	q.push(now);

	while(!q.empty())
	{
		now=q.front();
		q.pop();
		for(int i=0;i<4;i++)
		{
			tmp.x=now.x+w[i][0];
			tmp.y=now.y+w[i][1];
			tmp.ans=now.ans+1;
			tmp.time=now.time-1;

			if(tmp.x>=0&&tmp.x<a&&&tmp.y>=0&&tmp.y<b&&map[tmp.x][tmp.y]!=0&&tmp.time>0)
			{
				if(map[tmp.x][tmp.y]==3)
				{
					return tmp.ans;
				}
				else   if(map[tmp.x][tmp.y]==4)
				{
					tmp.time=6;
					map[tmp.x][tmp.y]=0;
				}
				q.push(tmp);
			}
		}
	}

	return -1;
}

int main()
{
	int T;
	cin>>T;
	while(T--)
	{
		cin>>a>>b;
		int i,j;
		for(i=0;i<a;i++)
			for(j=0;j<b;j++)
			{
				cin>>map[i][j];
				if(map[i][j]==2)
					c=i,d=j;
			}

		cout<<bfs()<<endl;
	}

	return 0;
}

HDUJ 1072 Nightmare 搜索

时间: 2024-11-05 02:24:05

HDUJ 1072 Nightmare 搜索的相关文章

HDUJ 1242 Rescue 搜索

Rescue Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 15582    Accepted Submission(s): 5656 Problem Description Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is

HDU 1072 Nightmare (BFS)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1072 题目大意: 走迷宫,初始剩余时间为6min,每步1min:到reset区是若剩余时间大于0,则可以重置.到终点3区,若时间大于0,则成功逃脱.(可以走回路) 0:wall 1:可以走 2:起点 3:终点 4:剩余时间重置为6 源代码: #include<iostream> #include<cstring> #include<cstdio> #include<q

HDU ACM 1072 Nightmare

Nightmare Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8125    Accepted Submission(s): 3896 Problem Description Ignatius had a nightmare last night. He found himself in a labyrinth with a ti

hdu 1072 Nightmare BFS,第一次刷BFS的题,感好牛逼的。。。

Nightmare Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7758    Accepted Submission(s): 3723 Problem Description Ignatius had a nightmare last night. He found himself in a labyrinth with a ti

HDU 1072 Nightmare(BFS)

Nightmare Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9120    Accepted Submission(s): 4389 Problem Description Ignatius had a nightmare last night. He found himself in a labyrinth with a ti

HDU 1072 Nightmare( 身上带有定时炸弹的他能否在炸弹爆炸之前离开—— BFS+DP思想)

Nightmare Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the

hdoj 1072 Nightmare

Nightmare Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 8480    Accepted Submission(s): 4069 Problem Description Ignatius had a nightmare last night. He found himself in a labyrinth with a tim

hdoj 1072 Nightmare 【bfs】

Nightmare Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8568    Accepted Submission(s): 4107 Problem Description Ignatius had a nightmare last night. He found himself in a labyrinth with a ti

hdu 1072 Nightmare

还是bfs,主要考虑剪枝,数组标记走过时炸弹剩余的时间,以及炸弹延时后将4变成1 #include<stdio.h> #include<string.h> #include<algorithm> #include<queue> using namespace std; struct node { int x,y,s,w; }t,t0; int n,m,g[10][10],vis[10][10]; int dx[]={0,0,1,-1}; int dy[]={