ZOJ3640-Help Me Escape

Help Me Escape


Time Limit: 2 Seconds     
Memory Limit: 32768 KB


Background

    If thou doest well, shalt thou not be accepted? and if thou doest not well, sin lieth at the door. And unto thee shall be his desire, and thou shalt rule over him.

And Cain talked with Abel his brother: and it came to pass, when they were in the field, that Cain rose up against Abel his brother, and slew him.

And the LORD said unto Cain, Where is Abel thy brother? And he said, I know not: Am I my brother‘s keeper?

And he said, What hast thou done? the voice of thy brother‘s blood crieth unto me from the ground.

And now art thou cursed from the earth, which hath opened her mouth to receive thy brother‘s blood from thy hand;

When thou tillest the ground, it shall not henceforth yield unto thee her strength; a fugitive and a vagabond shalt thou be in the earth.

—— Bible Chapter 4

Now Cain is unexpectedly trapped in a cave with N paths. Due to LORD‘s punishment, all the paths are zigzag and dangerous. The difficulty of the
ith path is ci.

Then we define f as the fighting capacity of Cain. Every day, Cain will be sent to one of the
N paths randomly.

Suppose Cain is in front of the ith path. He can successfully take
ti
days to escape from the cave as long as his fighting capacity f is larger than
ci. Otherwise, he has to keep trying day after day. However, if Cain failed to escape, his fighting capacity would increase
ci as the result of actual combat. (A kindly reminder: Cain will never died.)

As for ti, we can easily draw a conclusion that ti is closely related to
ci. Let‘s use the following function to describe their relationship:

After D days, Cain finally escapes from the cave. Please output the expectation of D.

Input

The input consists of several cases. In each case, two positive integers
N
and f (n ≤ 100, f ≤ 10000) are given in the first line. The second line includes N positive integers
ci (ci ≤ 10000, 1 ≤ i ≤ N)

Output

For each case, you should output the expectation(3 digits after the decimal point).

Sample Input

3 1
1 2 3

Sample Output

6.889

题目大意:有N条路,每条路都有一个Ci值,如今一个人要从中挑一条路逃出去。挑中每条路概率同样,一開始这个人有一个f值,他随机挑一条路。假设f值大于Ci那么他须要花费Ti天逃出去,假设小于的话那么就f增长Ci的大小,然后反复该过程,问逃出去须要的天数的数学期望

做法:DP[f] 表示 眼下这个人战斗力为f时逃出去须要的天数,转移就是n个嘛。

。。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
#include <cmath>
using namespace std;

const int maxn = 100000+10;
struct path{
    int c,t;
    path(int c,int t):c(c),t(t){}
};
vector<path> vp;
int n,f;
double dp[maxn];
bool vis[maxn];

double dfs(int f){

    if(vis[f])  return dp[f];
    vis[f] = 1;
    double ans = 0;
    for(int i = 0; i < n; i++){
        if(vp[i].c >= f){
            ans += (1+dfs(f+vp[i].c))/n;
        }else{
            ans += double(vp[i].t)/n;
        }
    }
    return dp[f] = ans;
}

int main(){

    while(~scanf("%d%d",&n,&f)){
        vp.clear();
        memset(vis,0,sizeof vis);
        for(int i = 0; i < n; i++){
            int t;
            scanf("%d",&t);
            int k = int((1+sqrt(5.0))/2*t*t);
            vp.push_back(path(t,k));
        }
        printf("%.3lf\n",dfs(f));
    }
    return 0;
}

时间: 2024-10-26 07:16:26

ZOJ3640-Help Me Escape的相关文章

ZOJ3640 Help Me Escape(概率dp)

p Me Escape Time Limit: 2 Seconds      Memory Limit: 32768 KB Background     If thou doest well, shalt thou not be accepted? and if thou doest not well, sin lieth at the door. And unto thee shall be his desire, and thou shalt rule over him. And Cain

ZOJ3640之简单慨率DP

Help Me Escape Time Limit: 2 Seconds      Memory Limit: 32768 KB Background     If thou doest well, shalt thou not be accepted? and if thou doest not well, sin lieth at the door. And unto thee shall be his desire, and thou shalt rule over him. And Ca

newLISP处理mysql escape character

什么是转义字符 mysql的escape character指的是需要转义的特殊字符,这些字符出现在sql语句中,如果没有转移会导致sql语法报错或者有sql注入攻击的可能. 主要有以下几种都需转义: \x00, \n, \r, \, ', " and \x1a. 比如' 就需要变成\' 下面是sql测试: mysql> INSERT INTO nodes(name) VALUES ('select a.dt, count(*), count(distinct a.uv) from (se

hzau 1204 Escape from the Darkness

1204: Escape from the Darkness Time Limit: 1 Sec  Memory Limit: 1280 MBSubmit: 93  Solved: 3[Submit][Status][Web Board] Description Xiao Ming, a high school student, learnt blackbody radiation from the physics class. The black body on the book is ind

Python 3 与 Javascript escape 传输确保数据正确方法和中文乱码解决方案

前几天用Python的Bottle框架写个小web程序,在进行Ajax交互之时,前端则先用 JSON.stringify 来将类序列化,然后用escape() 函数将其编码,确保传输正确. 再基本上配合上Jquery的$.ajax应该就可以了,可能是经验不足,即使编码之后的数据依然在 Python 中难以处理. 后来慢慢思考出一种方式,在网上也发现了类似的方式,于是将其实现. 基本思路如下: escape('你好世界ABC'); //返回 "%u4F60%u597D%u4E16%u754CABC

【转】escape()、encodeURI()、encodeURIComponent()区别详解

escape().encodeURI().encodeURIComponent()区别详解 原文链接:http://www.cnblogs.com/tylerdonet/p/3483836.html JavaScript中有三个可以对字符串编码的函数,分别是: escape,encodeURI,encodeURIComponent,相应3个解码函数:unescape,decodeURI,decodeURIComponent . 下面简单介绍一下它们的区别 1 escape()函数 定义和用法 e

hdu 3605 Escape 二分图的多重匹配(匈牙利算法)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3605 Escape Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 8001    Accepted Submission(s): 1758 Problem Description 2012 If this is the end of th

HDU 5389 Zero Escape(dp啊 多校啊 )

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5389 Problem Description Zero Escape, is a visual novel adventure video game directed by Kotaro Uchikoshi (you may hear about ever17?) and developed by Chunsoft. Stilwell is enjoying the first chapter of

jdbc escape

假如有这样1个查询请求,模糊查询标题中包含a%b_cc’d的记录,正确的sql应该是下面这样的:      select * from t_sch_work_info t where  t.title like  ‘%a/%b/_cc”d%’ ESCAPE ‘/’; Spring 并没有提供相应的工具类,您可以通过 jakarta commons lang 通用类包中(spring/lib/jakarta-commons/commons-lang.jar)的 org.apache.commons