pat 1012 The Best Rank

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

Problem Solving:For each subject, it needs to take a sort, and then traverse the sorted vector to find his minimun rank of this subject. Notice that if the ranks are same of same grades, andthe next rank of different grade is the position in the rank vector, for example, the grades are 97 95 95 90, and ranks are 1 2 2 4.

Code:
#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;
struct Stu
{
    int id;
    int C, M, E, A;
};
bool CCmp(const Stu &s1, const Stu &s2)
{
    return s1.C > s2.C;
}
bool MCmp(const Stu &s1, const Stu &s2)
{
    return s1.M > s2.M;
}
bool ECmp(const Stu &s1, const Stu &s2)
{
    return s1.E > s2.E;
}
bool ACmp(const Stu &s1, const Stu &s2)
{
    return s1.A > s2.A;
}
int main()
{
    string na = "N/A";
    char names[] = {‘A‘, ‘C‘, ‘M‘, ‘E‘};
    int m, n, i;
    int a[2500];
    vector<Stu> stus;
    vector<Stu> CRank;
    vector<Stu> MRank;
    vector<Stu> ERank;
    vector<Stu> ARank;
    cin >> n >> m;
    Stu *s;
    for (i = 0; i < n; i++)
    {
        s = new Stu();
        cin >> s->id >> s->C >> s->M >> s->E;
        s->A = s->C + s->M + s->E;
        stus.push_back(*s);
    }
    Stu head = {200, 200, 200, 200, 400};
    stus.insert(stus.begin(), head);
    if (n == 0 || m == 0)
    {
        cout << na;
        return 0;
    }
    sort(stus.begin(), stus.end(), CCmp);
    CRank.assign(stus.begin(), stus.end());
    sort(stus.begin(), stus.end(), MCmp);
    MRank.assign(stus.begin(), stus.end());
    sort(stus.begin(), stus.end(), ECmp);
    ERank.assign(stus.begin(), stus.end());
    sort(stus.begin(), stus.end(), ACmp);
    ARank.assign(stus.begin(), stus.end());
    int size = stus.size(), min;
    int id;
    int num[4];
    char name;
    for (int j = 0; j < m; j++)
    {
        cin >> id;
        min = 3000;
        for (i = 0; i < 4; i++)
        {
            num[i] = 0;
        }
        //如果相等则排名不变,如果和之前的不等,则排名为当前i
        // 97 95 95 90
        // 1  2  2  4
        for (i = 1; i < size; i++)
        {
            if (ARank[i].A != ARank[i - 1].A)
                num[0] = i;
            if (ARank[i].id == id)
            {
                break;
            }
        }
        if (i == size)
        {
            cout << na << endl;
            continue;
        }
        for (i = 1; i < size; i++)
        {
            if (CRank[i].C != CRank[i - 1].C)
                num[1] = i;
            if (CRank[i].id == id)
            {
                break;
            }
        }
        for (i = 1; i < size; i++)
        {
            if (MRank[i].M != MRank[i - 1].M)
                num[2] = i;
            if (MRank[i].id == id)
            {
                break;
            }
        }
        for (i = 1; i < size; i++)
        {
            if (ERank[i].E != ERank[i - 1].E)
                num[3] = i;
            if (ERank[i].id == id)
            {
                break;
            }
        }
        for (i = 0; i < 4; i++)
        {
            if (min > num[i])
            {
                min = num[i];
                name = names[i];
            }
        }
        cout << min << ‘ ‘ << name << endl;
    }
    return 0;
}

Impression:

Honestly, I have adpoted a not very good method to solve this problem, and I recommend the method in this blog, here is the link:https://blog.csdn.net/qq_24572475/article/details/82811274

原文地址:https://www.cnblogs.com/stormax/p/11079363.html

时间: 2024-10-04 23:37:41

pat 1012 The Best Rank的相关文章

PAT 1012. The Best Rank (25)

1012. The Best Rank (25) To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, w

1012. The Best Rank (25)——PAT (Advanced Level) Practise

题目信息: 1012. The Best Rank (25) 时间限制 400 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Math

[PTA] PAT(A) 1012 The Best Rank (25 分)

目录 Problem Solution Analysis Code Problem portal: 1012 The Best Rank (25 分) Solution Analysis ?一名学生有三门科目,以及计算出的一个平均成绩,每一个成绩都会有一个排名,现在想要让你输出某一个同学最高的排名(四种成绩排名的最高),以及对应的科目 ?如果给定的同学的四种课程排名的名次信息已经存在,那么就很简单,在里面找到最小的名次,以及对应的科目输出即可. ?可以创建四个数组,数组的每个元素存储某一门科目的

PAT 1012

1012. The Best Rank (25) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematic

1012. The Best Rank

1012. The Best Rank (25) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematic

PAT 1012 数字分类 C语言

给定一系列正整数,请按要求对数字进行分类,并输出以下5个数字: A1 = 能被5整除的数字中所有偶数的和: A2 = 将被5除后余1的数字按给出顺序进行交错求和,即计算n1-n2+n3-n4...: A3 = 被5除后余2的数字的个数: A4 = 被5除后余3的数字的平均数,精确到小数点后1位: A5 = 被5除后余4的数字中最大数字. 输入格式: 每个输入包含1个测试用例.每个测试用例先给出一个不超过1000的正整数N,随后给出N个不超过1000的待分类的正整数.数字间以空格分隔. 输出格式:

1012 The Best Rank (25)(25 分)

1012 The Best Rank (25)(25 分) To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean ti

PAT A1012 The Best Rank

PAT A1012 The Best Rank 题目描述: To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean ti

1012 The Best Rank (25分) vector与结构体排序

1012 The Best Rank (25分) To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, w