HDU1540 Tunnel Warfare

Problem Description

During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every village was directly connected
with two neighboring ones.

Frequently the invaders launched attack on some of the villages and destroyed the parts of tunnels in them. The Eighth Route Army commanders requested the latest connection state of the tunnels and villages. If some villages are severely isolated, restoration
of connection must be done immediately!

Input

The first line of the input contains two positive integers n and m (n, m ≤ 50,000) indicating the number of villages and events. Each of the next m lines describes an event.

There are three different events described in different format shown below:

D x: The x-th village was destroyed.

Q x: The Army commands requested the number of villages that x-th village was directly or indirectly connected with including itself.

R: The village destroyed last was rebuilt.

Output

Output the answer to each of the Army commanders’ request in order on a separate line.

Sample Input

7 9
D 3
D 6
D 5
Q 4
Q 5
R
Q 4
R
Q 4

Sample Output

1
0
2
4

可用set来保存 炸毁的点  查询的时候二分 到它的左右两个数(当查询的数在set中直接输出0) 相减即为所得!

一开始RE了很久。。。得到一个教训就是 用upper_bound 和 lower_bound的时候最好给set加个边界。。不然迭代器自减的话会发生很多乱七八糟的情况
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
#include <set>
using namespace std;
int n,m;
set<int> sv;
stack<int> dv;
int main(){

    while(~scanf("%d%d",&n,&m)){
        while(!dv.empty()) dv.pop();
        sv.clear();
        sv.insert(0);//给其加上边界
        sv.insert(n+1);
        while(m--){
            getchar();
            set<int>::iterator itlow,itup;
            char op;
            int d;
            scanf("%c",&op);
            if(op==‘D‘){
                scanf("%d",&d);
                dv.push(d);
                sv.insert(d);
            }else if(op == ‘R‘){
                if(!dv.empty()){
                    int td = dv.top();
                    dv.pop();
                    if(sv.count(td)!=0){
                        sv.erase(td);
                    }
                }
            }else{
                scanf("%d",&d);
                if(sv.count(d)!=0){
                    printf("0\n");
                }else{
                    int ans = 0;
                    itlow = sv.lower_bound(d);
                    itup = sv.upper_bound(d);
                    itlow--;
                    printf("%d\n",*itup-*itlow-1);
                }
            }

        }
    }
    return 0;
}

HDU1540 Tunnel Warfare,布布扣,bubuko.com

时间: 2024-10-08 18:44:28

HDU1540 Tunnel Warfare的相关文章

hdu1540 Tunnel Warfare 线段树/树状数组

During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every village was directly con

hdu--1540 Tunnel Warfare(线段树+区间合并)

Description During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every village was

kuangbin专题七 HDU1540 Tunnel Warfare (前缀后缀线段树)

During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every village was directly con

hdu1540 &amp;&amp; POJ2892 Tunnel Warfare

[比赛提醒]BestCoder 你报名了吗?(点击报名) [科普]什么是BestCoder?如何参加? Tunnel Warfare Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4513    Accepted Submission(s): 1725 Problem Description During the War of Res

HDU 1540 Tunnel Warfare(线段树,单点更新,区间查询)

Problem Description During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every vill

HDU 1540 Tunnel Warfare 平衡树 / 线段树:单点更新,区间合并

Tunnel Warfare                                  Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Problem Description During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast

HDU 1540 &amp;&amp; POJ 2892 Tunnel Warfare (线段树,区间合并).

~~~~ 第一次遇到线段树合并的题,又被律爷教做人.TAT. ~~~~ 线段树的题意都很好理解吧.. 题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1540 http://poj.org/problem?id=2892 ~~~~ 我的代码:200ms #include<cstdio> #include<cstring> #include<iostream> #include<algorithm> #defin

POJ 题目2892 Tunnel Warfare(线段树单点更新查询,求单点所在最大连续区间长度)

Tunnel Warfare Time Limit: 1000MS   Memory Limit: 131072K Total Submissions: 7307   Accepted: 2997 Description During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally sp

hdu 1540 Tunnel Warfare 线段树 单点更新,查询区间长度,区间合并

Tunnel Warfare Time Limit: 1 Sec  Memory Limit: 256 MB 题目连接 http://acm.hdu.edu.cn/showproblem.php?pid=1540 Description During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Gene