PAT 1107 Social Clusters

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:
Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K?i : hi [1] hi?? [2] ... hi [Ki?]

where Ki? (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:
For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

#include<iostream> //集合的查并补
#include<vector>
#include<algorithm>
using namespace std;
vector<int> father, isroot;
bool cmp(const int& a, const int& b){
  return a>b;
}
int findfather(int a){
  int b=a;
  while(father[a]!=a){
    a=father[a];
  }
  while(b != father[b]) {
        int z = b;
        b = father[b];
        father[z] = a;
    }
  return a;
}
void Union(int a, int b){ //并集
  int faA= findfather(a);
  int faB= findfather(b);
  if(faA!=faB) father[faA]=faB;
}
int main(){
  int N, cnt=0;
  cin>>N;
  vector<int> course(1001, 0);
  father.resize(N+1);
  isroot.resize(N+1);
  for(int i=1; i<=N; i++)
    father[i]=i;
  for(int i=1; i<=N; i++){
    int k;
    scanf("%d:",&k);
    for(int j=0; j<k; j++){
      int t;
      cin>>t;
      if(course[t]==0)
        course[t]=i;
      Union(i, findfather(course[t]));
    }
  }
  for(int i=1; i<=N; i++){
    isroot[findfather(i)]++;
  }
  for(int i=1; i<=N; i++){
    if(isroot[i]!=0)
      cnt++;
  }
  sort(isroot.begin(), isroot.end(), cmp);
  cout<<cnt<<endl;
  for(int i=0; i<cnt; i++)
    i==0?cout<<isroot[i]:cout<<" "<<isroot[i];
  return 0;
}

原文地址:https://www.cnblogs.com/A-Little-Nut/p/9501895.html

时间: 2024-10-30 06:00:23

PAT 1107 Social Clusters的相关文章

PAT Advanced 1107 Social Clusters (30) [并查集]

题目 When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A "social cluster" is a set of people who have some of their hobbies in common. You are supposed to

1107. Social Clusters (30)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A "social cluster" is a set of people who have some of their hobbies in common. You are supposed to fi

PAT_A1107#Social Clusters

Source: PAT A1107 Social Clusters (30 分) Description: When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of

PAT-1107 Social Clusters (30 分) 并查集模板

1107 Social Clusters (30 分) When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. Y

并查集——A1107.Social Clusters(30)

#include <bits/stdc++.h> #include <stdio.h> #include <stdlib.h> #include <queue> using namespace std; const int N = 1010; int father[N]; int isRoot[N] = {0}; int course[N] = {0}; int findFather(int x){ int a = x; while(x != father[

A1107 Social Clusters (30分)

一.技术总结 这是一道并查集的题目,这里无非就是明白题目的含义,然后将套路用上基本上问题不大. 一个是father数组用于存储父亲结点,isRoot用于存储根结点,如果题目需要,还可以建立一个course数组,用于存储,例如这个题目就是用于判断该该兴趣是否有人涉及. findFather函数,用于查找结点的父亲结点,同时包含压缩路径. Union函数,用于合并. 初始化函数. 二.参考代码 #include<bits/stdc++.h> using namespace std; const i

pat甲级1107

1107 Social Clusters (30 分) When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. Y

A题目

1 1001 A+B Format(20) 2 1002 A+B for Polynomials(25) 3 1003 Emergency(25) 4 1004 Counting Leaves(30) 5 1005 Spell It Right(20) 6 1006 Sign In and Sign Out(25) 7 1007 Maximum Subsequence Sum(25) 8 1008 Elevator(20) 9 1009 Product of Polynomials(25) 10

PAT A1107——并查集

Social Clusters When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are suppo