HDU 1025 LIS二分优化

题目链接:

acm.hdu.edu.cn/showproblem.php?pid=1025

Constructing Roads In JGShining‘s Kingdom

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28755    Accepted Submission(s): 8149

Problem Description

JGShining‘s kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they‘re unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don‘t wanna build a road with other poor ones, and rich ones also can‘t abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.

In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^

Input

Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.

Output

For each test case, output the result in the form of sample.
You should tell JGShining what‘s the maximal number of road(s) can be built.

Sample Input

2

1 2

2 1

3

1 2

2 3

3 1

Sample Output

Case 1:

My king, at most 1 road can be built.

Case 2:

My king, at most 2 roads can be built.

Hint

Huge input, scanf is recommended.

题目大意:

两排城市,要把标号相同的连接起来,但是不能交叉,问至少连几根线

LIS问题,不过要优化

#include<bits/stdc++.h>
#define max_v 500005
using namespace std;
int a[max_v],dp[max_v],len;
int main()
{
    int n,c=1;
    while(~scanf("%d",&n))
    {
        for(int i=1; i<=n; i++)
        {
            int x,y;
            scanf("%d %d",&x,&y);
            a[x]=y;
        }
        //dp[k]代表长度为k的LIS序列的最末元素,
        //若有多个长度为k的上升子序列,
        //则记录最小的那个最末元素
        //dp[]中的元素是单调递增的,
        //二分优化的时候利用这个性质

        dp[1]=a[1];
        len=1;
        for(int i=2; i<=n; i++)
        {
            if(a[i]>dp[len])
            {
                dp[++len]=a[i];
            }
            else
            {
               int j=lower_bound(dp,dp+len,a[i])-dp;
                dp[j]=a[i];
            }
        }
        if(len==1)
        {
            printf("Case %d:\nMy king, at most %d road can be built.\n\n",c++,len);
        }else
        {
            printf("Case %d:\nMy king, at most %d roads can be built.\n\n",c++,len);
        }
    }
    return 0;
}

原文地址:https://www.cnblogs.com/yinbiao/p/9128222.html

时间: 2024-11-08 20:45:01

HDU 1025 LIS二分优化的相关文章

HDU 1025:Constructing Roads In JGShining&#39;s Kingdom(LIS+二分优化)

http://acm.hdu.edu.cn/showproblem.php?pid=1025 Constructing Roads In JGShining's Kingdom Problem Description JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.Half of these cities are r

Constructing Roads In JGShining&#39;s Kingdom(HDU 1025 LIS nlogn方法)

Constructing Roads In JGShining's Kingdom Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 21002    Accepted Submission(s): 5935 Problem Description JGShining's kingdom consists of 2n(n is no mor

Hdu 1025(LIS)

Constructing Roads In JGShining's Kingdom Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 15126    Accepted Submission(s): 4300 Problem Description JGShining's kingdom consists of 2n(n is no mor

POJ 3903:Stock Exchange(裸LIS + 二分优化)

http://poj.org/problem?id=3903 Stock Exchange Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 5983   Accepted: 2096 Description The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. J

hdu 1025 LIS nlogn复杂度

#include <cstdio> #include <iostream> #include <algorithm> #include <queue> #include <cmath> #include <cstring> #include <stack> #include <set> #include <map> #include <vector> using namespace st

hdu 1025 dp+二分求最长递增子序列

//dp[i],长度为i的递增子序列的最后一位的最小值 //对于这种处理得到的dp[i]必然是递增的 //对于第i个数a[i],只需要找到最小的大于它的位置pos, //由于是最小的大于a[i] ,pos - 1 的值必然小于a[i] //那么dp[pos] = a[i] ; #include<cstdio> #include<cstring> #include<iostream> using namespace std ; const int maxn = 50001

hdu 1025 Constructing Roads In JGShining&#39;s Kingdom(DP + 二分)

此博客为转发 Constructing Roads In JGShining's Kingdom Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Problem Description JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in t

HDU 1025 Constructing Roads In JGShining&#39;s Kingdom LIS题解

本题是LIS题解.主要是理解他的题意.他的题意都好像比较隐晦,比如每个poor city和rich city一定是需要对应起来的,比如poor city和rich city并不是按顺序给出的. 其实是可以把数列按照poor city排序,然后求rich city城市号的最大递增子序列. 不过这里不用排序,利用hash的思想直接对应起来就可以了. 然后就是本题是卡DP的O(n*n)的解法的,这里需要O(nlgn)的LIS解法. 二分好已经找到的递增序列,插入新的数值就可以了.是利用了一个单调队列的

HDU 1025 Constructing Roads In JGShining&#39;s Kingdom(二维LIS)

Constructing Roads In JGShining's Kingdom Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 23467    Accepted Submission(s): 6710 Problem Description JGShining's kingdom consists of 2n(n is no mo