POJ 3468——A Simple Problem with Integers——————【线段树区间更新, 区间查询】

A Simple Problem with Integers

Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 86780   Accepted: 26950
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

POJ Monthly--2007.11.25, Yang Yi

题目大意:给你n个数,m次询问。询问包括为区间内每个值增加c以及查询区间内所有值的和。

解题思路:延迟标记。保证当前值的正确性。lazy不能清空,应该累积,因为可能上次的lazy还没有向下推。

#include<stdio.h>
#include<vector>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 1e6+20;
const int INF = 0x3f3f3f3f;
const int mod = 1e9+7;
#define mid (L+R)/2
#define lson rt*2,L,mid
#define rson rt*2+1,mid+1,R
struct SegTree{
    LL val, lazy;
}segs[maxn*4];
void PushUp(int rt){
    segs[rt].val = segs[rt*2+1].val + segs[rt*2].val;
}
void PushDown(int rt,int L,int R){
    if(segs[rt].lazy){
        segs[rt*2].val += segs[rt].lazy*(mid-L +1); //保证当前的正确性
        segs[rt*2+1].val += segs[rt].lazy*(R-mid);
        segs[rt*2].lazy += segs[rt].lazy;   //累积
        segs[rt*2+1].lazy += segs[rt].lazy;
        segs[rt].lazy = 0;
    }
}
void buildtree(int rt,int L,int R){
    segs[rt].val = 0;
    segs[rt].lazy = 0;
    if(L == R){
        scanf("%lld",&segs[rt].val);
        return ;
    }
    buildtree(lson);
    buildtree(rson);
    PushUp(rt);
}
//void Update(int rt,int L,int R,int _idx,int _val){
//    if(L == R && L == _idx){
//        segs[rt].val += _val;
//        return ;
//    }
//    if(_idx <= mid)
//        Update(lson,_idx,_val);
//    else
//        Update(rson,_idx,_val);
//    PushUp(rt);
//}
LL query(int rt,int L,int R,int l_ran,int r_ran){
    if(l_ran <= L&&R <= r_ran){
        return segs[rt].val;
    }
    PushDown(rt,L,R);
    LL ret = 0;
    if(l_ran <= mid){
        ret += query(lson,l_ran,r_ran);
    }
    if(r_ran > mid){
        ret += query(rson,l_ran,r_ran);
    }
    PushUp(rt);
    return ret;
}
void Update(int rt,int L,int R,int l_ran,int r_ran,LL chg){
    if(l_ran <= L&&R <= r_ran){
        segs[rt].val += chg*(R-L+1);
        segs[rt].lazy += chg;
        return ;
    }
    PushDown(rt,L,R);
    if(l_ran <= mid)
    Update(lson,l_ran,r_ran,chg);
    if(r_ran > mid)
    Update(rson,l_ran,r_ran,chg);
    PushUp(rt);
}
int main(){
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF){
        buildtree(1,1,n);
        int l,r;
        LL c;
        char s[12];
        for(int i = 1; i <= m; i++){
            scanf("%s",s);
            if(s[0]==‘Q‘){
                scanf("%d%d",&l,&r);
                LL ans = query(1,1,n,l,r);
                printf("%lld\n",ans);
            }else{
                scanf("%d%d%lld",&l,&r,&c);
                Update(1,1,n,l,r,c);
            }
        }
    }
    return 0;
}

  

时间: 2024-08-28 14:08:57

POJ 3468——A Simple Problem with Integers——————【线段树区间更新, 区间查询】的相关文章

POJ 3468 A Simple Problem with Integers 线段树 区间更新 区间查询

题目链接: http://poj.org/problem?id=3468 题目描述: 一组数列, 可进行一段区间加上某一个数, 和区间查询 解题思路: 线段树, 之前的那道题是求总区间直接输出sum[1] 就可以了, 这次有了区间查询, 同理, 查询的时候Pushdown 代码: #include <iostream> #include <cstdio> #include <string> #include <vector> #include <map

POJ 3468 A Simple Problem with Integers(线段树区间更新)

题目地址:POJ 3468 打了个篮球回来果然神经有点冲动..无脑的狂交了8次WA..居然是更新的时候把r-l写成了l-r... 这题就是区间更新裸题.区间更新就是加一个lazy标记,延迟标记,只有向下查询的时候才将lazy标记向下更新.其他的均按线段树的来就行. 代码如下: #include <iostream> #include <cstdio> #include <cstring> #include <math.h> #include <stac

(简单) POJ 3468 A Simple Problem with Integers , 线段树+区间更新。

Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval. 题意

[POJ] 3468 A Simple Problem with Integers [线段树区间更新求和]

A Simple Problem with Integers Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of

POJ 3468 A Simple Problem with Integers(线段树区间更新区间求和)

A Simple Problem with Integers Time Limit: 5000MS   Memory Limit: 131072K Total Submissions: 67511   Accepted: 20818 Case Time Limit: 2000MS Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of

poj 3468 A Simple Problem with Integers 线段树区间更新

点击打开链接题目链接 A Simple Problem with Integers Time Limit: 5000MS   Memory Limit: 131072K Total Submissions: 63565   Accepted: 19546 Case Time Limit: 2000MS Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations.

POJ 3468 A Simple Problem with Integers(线段树 区间更新)

http://poj.org/problem?id=3468 题意 :对于一个序列有两种操作 1 查询 l到r 的和 2 对于l 到r上的每个数 加上 up 思路: 用单点更新必然超时 所以需要区间更新 (位运算时 注意 m-m>>1 与 m-(m>>1) 的区别) #include<cstdio> #include<cstring> #include<iostream> #include<algorithm> using names

POJ 3468 A Simple Problem with Integers (线段树区域更新)

A Simple Problem with Integers Time Limit: 5000MS   Memory Limit: 131072K Total Submissions: 62431   Accepted: 19141 Case Time Limit: 2000MS Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of

poj 3468 A Simple Problem with Integers 线段树第一次 + 讲解

A Simple Problem with Integers Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of

POJ 3468 A Simple Problem with Integers //线段树的成段更新

A Simple Problem with Integers Time Limit: 5000MS   Memory Limit: 131072K Total Submissions: 59046   Accepted: 17974 Case Time Limit: 2000MS Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of