zzuli 1732: 五子棋 (搜索+模拟)

1732: 五子棋

Time Limit: 1 Sec  Memory Limit: 128 MB

Submit: 234  Solved: 4

SubmitStatusWeb
Board

Description

Input

Output

Sample Input

210 10.......................1.........2..................................................................10 10.................................1........1.........1.2.............................................

Sample Output

otherfault

考虑下面几种情况:

1、黑手先,则黑子和白子相等或者多一个;

2、若黑胜,则黑子比白子多一个;

3、若白胜,则白子和黑子相等;

4、双方不能同时胜利;

最后,若存在一方胜利,则枚举这一方的所有点,把它去掉。则必存在一点,去掉后棋盘无5个连续颜色的棋子。

其他就是other。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<math.h>
#include<vector>
using namespace std;
#define mem(a,t) memset(a,t,sizeof(a))
#define N 115
#define ll __int64
const int inf=0x1f1f1f1f;
const double eps=1e-7;
char s[N][N];
int dir[8][2]={1,1,1,0,1,-1,0,-1,-1,-1,-1,0,-1,1,0,1};
int n,m;
int judge(int x,int y)
{
    if(x>=0&&x<n&&y>=0&&y<m)
        return 1;
    return 0;
}

int bfs(int f)      //判断f方是否存在5子连续
{
    char tmp=f+'0';
    int i,j,k,cnt,x,y;
    for(i=0;i<n;i++)
    {
        for(j=0;j<m;j++)
        {
            if(s[i][j]==tmp)
            {
                for(k=0;k<8;k++)
                {
                    x=i;
                    y=j;
                    cnt=1;
                    while(1)
                    {
                        x+=dir[k][0];
                        y+=dir[k][1];
                        if(!judge(x,y)||s[x][y]!=tmp)
                            break;
                        cnt++;
                    }
                    if(cnt>=5)
                        return 1;
                }
            }
        }
    }
    return 0;
}

void fun(int f)    //去掉一子
{
    int i,j,flag=0;
    char tmp=f+'0';
    for(i=0;i<n;i++)
    {
        for(j=0;j<m;j++)
        {
            if(s[i][j]==tmp)
            {
                s[i][j]='0';
                if(bfs(f)==0)
                {
                    flag=1;
                    break;
                }
                s[i][j]=tmp;
            }
        }
        if(flag)
            break;
    }
    if(flag)
    {
        if(f==1)
            printf("white\n");
        else
            printf("black\n");
    }
    else
        printf("fault\n");
}

int main()
{
    int i,j,T;
    int b,w;
    int f1,f2;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        b=w=0;
        for(i=0;i<n;i++)
        {
            scanf("%s",s[i]);
            for(j=0;j<m;j++)
            {
                if(s[i][j]=='1')
                    w++;
                else if(s[i][j]=='2')
                    b++;
            }
        }
        if(b!=w&&b!=w+1)
        {
            printf("fault\n");
            continue;
        }
        f1=bfs(1);
        f2=bfs(2);
        if(f1&&f2)
        {
            printf("fault\n");
            continue;
        }
        if(f1)
        {
            if(w!=b)
                printf("fault\n");
            else
                fun(1);
        }
        else if(f2)
        {
            if(b!=w+1)
                printf("fault\n");
            else
                fun(2);
        }
        else
            printf("other\n");
    }
    return 0;
}
时间: 2024-11-03 13:48:32

zzuli 1732: 五子棋 (搜索+模拟)的相关文章

组队赛#1 解题总结 ZOJ 3803 YY&#39;s Minions (DFS搜索+模拟)

YY's Minions Time Limit: 2 Seconds      Memory Limit: 65536 KB Despite YY's so much homework, she would like to take some time to play with her minions first. YY lines her minions up to an N*M matrix. Every minion has two statuses: awake or asleep. W

模拟 --- 搜索模拟

Robot Motion Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 10130   Accepted: 4932 Description A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in

CCF 201512-3 画图 (DFS搜索+模拟)

问题描述 用 ASCII 字符来画图是一件有趣的事情,并形成了一门被称为 ASCII Art 的艺术.例如,下图是用 ASCII 字符画出来的 CSPRO 字样. ..____.____..____..____...___.. ./.___/.___||.._.\|.._.\./._.\. |.|...\___.\|.|_).|.|_).|.|.|.| |.|___.___).|..__/|.._.<|.|_|.| .\____|____/|_|...|_|.\_\\___/. 本题要求编程实现

CodeForces - 7A Kalevitch and Chess(搜索?!模拟!)

Kalevitch and Chess Time Limit: 2000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u Submit Status Description A famous Berland's painter Kalevitch likes to shock the public. One of his last obsessions is chess. For more than a thousand ye

java 模拟简单搜索

Java 模拟简单搜索 实体类 package org.dennisit.entity; /** * * * @version : 1.0 * * @author : 苏若年 <a href="mailto:[email protected]">发送邮件</a> * * @since : 1.0 创建时间: 2013-4-8 下午04:51:03 * * @function: TODO * */ public class Medicine { private I

1105. Spiral Matrix (25)【模拟】——PAT (Advanced Level) Practise

题目信息 1105. Spiral Matrix (25) 时间限制150 ms 内存限制65536 kB 代码长度限制16000 B This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left co

使用Httpclient模拟登陆正方软件股份有限公司开发的教务管理系统

事先声明,我写这篇,只是为了分享一下,登录网站不止有使用cookies这一种方法,还有一种使用随机码的方法,并没有泄露"商业机密"的想法,本人才疏学浅,只是在站在巨人的肩膀上,摘到了一个小小的苹果... 毕设ing... 有一模块就是获取教务管理系统里面对应学号的学生信息,并有后续的操作!正常情况下,为了实现这些功能必须要求用户正确登陆!有一段时间学习HttpClient,并在网上寻找关于HttpClent模拟登录网站的blog和demo学习,但是找的很多都是这样说"在获取验

清北学堂 最大速度

最大速度 (maxv.pas/c/cpp) [问题描述] Ron的老爸的Flying Car出了些问题,现在必须要在地上跑到很大的速度才能飞起来,但是Flying Car飞起来的那一刻不能被麻瓜看到.为了确保安全飞起来,需要知道车到可以飞起来的地方时所能达到的最大速度.他的Flying Car一开始拥有一个初速度,移动一次增加速度1:因为车道很窄,宽度只有1,所以仅当要转向的方向有路时才能转,左转一次减少速度35,右转一次减少速度40,当前进.左转.右转都无路可走的时候,调头(连左转两次或连右转

【HDOJ】3295 An interesting mobile game

其实就是一道搜索模拟题.因为数据量小,用char就够了. 1 /* 3295 */ 2 #include <iostream> 3 #include <cstdio> 4 #include <cstring> 5 #include <cstdlib> 6 #include <queue> 7 using namespace std; 8 9 typedef struct { 10 char m[6][6]; 11 char x, y; 12 ch